section 3 · Library functions 📚
178720 pages · page 584 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
R (continued)
- redi_basic_pstream(3)Class template for Bidirectional PStreams✨
- redi_basic_pstreambuf(3)Class template for stream buffer✨
- redi_basic_rpstream(3)Class template for Restricted PStreams✨
- redi_pstream_common(3)Class template for common base class✨
- redi_pstreams(3)Common base class providing constants and typenames✨
- redirector(3bobcat)Redirects a file descriptor to another descriptor✨
- Redis(3pm)Perl binding for Redis database✨
- Redis::Fast(3pm)Perl binding for Redis database✨
- Redis::Fast::Hash(3pm)tie Perl hashes to Redis hashes✨
- Redis::Fast::List(3pm)tie Perl arrays to Redis lists✨
- Redis::Fast::Sentinel(3pm)connect to a Sentinel instance✨
- Redis::Hash(3pm)tie Perl hashes to Redis hashes✨
- Redis::List(3pm)tie Perl arrays to Redis lists✨
- Redis::Sentinel(3pm)Redis Sentinel interface✨
- redland(3)Resource Description Framework (RDF) Library✨
- redo_prebinding(3)✨
- redrawwin(3)refresh curses windows or lines thereupon✨
- redrawwin(3ncurses)refresh curses windows or lines thereupon✨
- redrawwin(3x)refresh curses windows or lines thereupon✨
- reduce(3)Determines whether the number of groups should be increased in order to reduce the size of the large groups, and to make that adjustment.✨
- reduce.c(3)Determines whether the number of groups should be increased in order to reduce the size of the large groups, and to make that adjustment.✨
- reexec_to_match_kernel(3)Re-exec the current binary to match the ABI of the running kernel✨
- Ref::Util(3pm)Utility functions for checking references✨
- Ref::Util::PP(3pm)pure-Perl version of Ref::Util✨
- Ref::Util::XS(3pm)XS implementation for Ref::Util✨
- refchan(3tcl)Command handler API for channels implemented in Tcl code✨
- refcnt(3)✨
- refill_head(3)✨
- refill_requirement(3)✨
- reflect(3G)calculate the reflection direction for an incident vector✨
- reflector_aux_grp(3)Householder reflectors✨
- refract(3G)calculate the refraction direction for an incident vector✨
- refresh(3)refresh curses windows or lines thereupon✨
- refresh(3ncurses)refresh curses windows or lines thereupon✨
- refresh(3x)refresh curses windows or lines thereupon✨
- refreshCDKScreen(3)Cdk screen and widget manipulation functions✨
- Reg::Asused(3pm)Perl module for asused.✨
- regcomp(3)POSIX regex functions✨
- regcomp(3p)regular expression matching✨
- regcomp(3posix)regular expression matching✨
- regerror(3)POSIX regex functions✨
- regex(3)POSIX regex functions✨
- regex(3ast)regular expression interface✨
- regex(3em)Lua execution engine✨
- regex_t(3)overview of system data types✨
- regex_t(3type)POSIX regex functions✨
- regexdev_capa(3)✨
- regexdev_stop_flush_t(3)✨
- regexec(3)POSIX regex functions✨
- RegExp(3)Pattern matching with regular expressions✨
- regexp(3)regular expression✨
- Regexp(3I)regular expression searching✨
- RegExp(3tcl)Pattern matching with regular expressions✨
- regexp(3tcl)Match a regular expression against a string✨
- Regexp::Assemble(3pm)Assemble multiple Regular Expressions into a single RE✨
- Regexp::Assemble::Compressed(3pm)Assemble more compressed Regular Expression✨
- Regexp::Common(3pm)Provide commonly requested regular expressions✨
- Regexp::Common::_support(3pm)Support functions for Regexp::Common.✨
- Regexp::Common::balanced(3pm)provide regexes for strings with balanced parenthesized delimiters or arbitrary delimiters.✨
- Regexp::Common::CC(3pm)provide patterns for credit card numbers.✨
- Regexp::Common::comment(3pm)provide regexes for comments.✨
- Regexp::Common::delimited(3pm)provides a regex for delimited strings✨
- Regexp::Common::Email::Address(3pm)Returns a pattern for Email Addresses✨
- Regexp::Common::lingua(3pm)provide regexes for language related stuff.✨
- Regexp::Common::list(3pm)provide regexes for lists✨
- Regexp::Common::net(3pm)provide regexes for IPv4, IPv6, and MAC addresses.✨
- Regexp::Common::net::CIDR(3pm)provide patterns for CIDR blocks.✨
- Regexp::Common::number(3pm)provide regexes for numbers✨
- Regexp::Common::profanity(3pm)provide regexes for profanity✨
- Regexp::Common::SEN(3pm)provide regexes for Social-Economical Numbers.✨
- Regexp::Common::time(3pm)Date and time regexps.✨
- Regexp::Common::URI(3pm)provide patterns for URIs.✨
- Regexp::Common::URI::fax(3pm)Returns a pattern for fax URIs.✨
- Regexp::Common::URI::file(3pm)Returns a pattern for file URIs.✨
- Regexp::Common::URI::ftp(3pm)Returns a pattern for FTP URIs.✨
- Regexp::Common::URI::gopher(3pm)Returns a pattern for gopher URIs.✨
- Regexp::Common::URI::http(3pm)Returns a pattern for HTTP URIs.✨
- Regexp::Common::URI::news(3pm)Returns a pattern for file URIs.✨
- Regexp::Common::URI::pop(3pm)Returns a pattern for POP URIs.✨
- Regexp::Common::URI::prospero(3pm)Returns a pattern for prospero URIs.✨
- Regexp::Common::URI::RFC1035(3pm)Definitions from RFC1035;✨
- Regexp::Common::URI::RFC1738(3pm)Definitions from RFC1738;✨
- Regexp::Common::URI::RFC1808(3pm)Definitions from RFC1808;✨
- Regexp::Common::URI::RFC2384(3pm)Definitions from RFC2384;✨
- Regexp::Common::URI::RFC2396(3pm)Definitions from RFC2396;✨
- Regexp::Common::URI::RFC2806(3pm)Definitions from RFC2806;✨
- Regexp::Common::URI::tel(3pm)Returns a pattern for telephone URIs.✨
- Regexp::Common::URI::telnet(3pm)Returns a pattern for telnet URIs.✨
- Regexp::Common::URI::tv(3pm)Returns a pattern for tv URIs.✨
- Regexp::Common::URI::wais(3pm)Returns a pattern for WAIS URIs.✨
- Regexp::Common::whitespace(3pm)provides a regex for leading or trailing whitescape✨
- Regexp::Common::zip(3pm)provide regexes for postal codes.✨
- Regexp::Debugger(3pm)Visually debug regexes in-place✨
- Regexp::Grammars(3pm)Add grammatical parsing features to Perl 5.10 regexes✨
- Regexp::IPv6(3pm)Regular expression for IPv6 addresses✨
- Regexp::List(3pm)Assemble multiple Regular Expressions into a single RE✨
- Regexp::Log(3pm)A base class for log files regexp builders✨
- Regexp::Optimizer(3pm)optimizes regular expressions✨
- Regexp::Pattern(3pm)Convention/framework for modules that contain collection of regexes✨
- Regexp::Pattern::DefHash(3pm)Regexp patterns related to DefHash✨
- Regexp::Pattern::Example(3pm)An example Regexp::Pattern::* module✨
- Regexp::Pattern::License(3pm)Regular expressions for legal licenses✨
- Regexp::Pattern::License::Parts(3pm)Regular expressions for licensing sub-parts✨
- Regexp::Pattern::Perl(3pm)Regexp patterns related to Perl✨
- Regexp::Pattern::Perl::Dist(3pm)Regexp patterns related to Perl distribution✨
- Regexp::Pattern::Perl::Module(3pm)Regexp patterns related to Perl modules✨
- Regexp::Pattern::Perl::Release(3pm)Regexp patterns related to Perl release✨
- Regexp::RegGrp(3pm)Groups a regular expressions collection✨
- Regexp::Shellish(3pm)Shell-like regular expressions✨
- Regexp::Stringify(3pm)Stringify a Regexp object✨
- Regexp::Tr(3pm)Run-time-compiled tr/// objects.✨
- Regexp::Trie(3pm)builds trie-ized regexp✨
- Regexp::Wildcards(3pm)Converts wildcard expressions to Perl regular expressions.✨
- regfree(3)POSIX regex functions✨
- region_id(3)✨
- register_app_config_handler(3)netsnmp_config_api functions✨
- register_app_prenetsnmp_mib_handler(3)netsnmp_config_api functions✨
- register_assert_handler(3)Registers a custom handler for assert failures. Allegro game programming library.✨
- register_assert_handler(3alleg4)Registers a custom handler for assert failures. Allegro game programming library.✨
- register_bitmap_file_type(3)Registers custom bitmap loading/saving functions. Allegro game programming library.✨
- register_bitmap_file_type(3alleg4)Registers custom bitmap loading/saving functions. Allegro game programming library.✨
- register_config_handler(3)netsnmp_config_api functions✨
- register_const_config_handler(3)netsnmp_config_api functions✨
- register_datafile_object(3)Registers load/destroy functions for custom object types. Allegro game programming library.✨
- register_datafile_object(3alleg4)Registers load/destroy functions for custom object types. Allegro game programming library.✨
- register_font_file_type(3)Register a new font loading function. Allegro game programming library.✨
- register_font_file_type(3alleg4)Register a new font loading function. Allegro game programming library.✨
- register_mib_handlers(3)netsnmp_config_api functions✨
- register_prenetsnmp_mib_handler(3)netsnmp_config_api functions✨
- register_printf_modifier(3)define custom behavior for printf-like functions✨
- register_printf_specifier(3)define custom behavior for printf-like functions✨
- register_printf_type(3)define custom behavior for printf-like functions✨
- register_sample_file_type(3)Registers custom loading/saving sample routines. Allegro game programming library.✨
- register_sample_file_type(3alleg4)Registers custom loading/saving sample routines. Allegro game programming library.✨
- register_trace_handler(3)Registers a custom handler for trace output. Allegro game programming library.✨
- register_trace_handler(3alleg4)Registers a custom handler for trace output. Allegro game programming library.✨
- register_uformat(3)Installs handler functions for a new text encoding format. Allegro game programming library.✨
- register_uformat(3alleg4)Installs handler functions for a new text encoding format. Allegro game programming library.✨
- registerCDKObject(3)Cdk screen and widget manipulation functions✨
- registerrpc(3)library routines for remote procedure calls✨
- registry(3tcl)Manipulate the Windows registry✨
- regmatch_t(3)overview of system data types✨
- regmatch_t(3type)POSIX regex functions✨
- regoff_t(3)overview of system data types✨
- regoff_t(3type)POSIX regex functions✨
- regsub(3tcl)Perform substitutions based on regular expression pattern matching✨
- rel2abs(3)make an absolute path name from a relative path name✨
- relationalFunctions(3clc)Click an item in the table below for details about that function…✨
- relative(3)✨
- relative(3pm)Load modules with relative names✨
- relative_sectag_insert(3)✨
- relaxed_matching(3)✨
- release_bitmap(3)Releases a previously locked bitmap. Allegro game programming library.✨
- release_bitmap(3alleg4)Releases a previously locked bitmap. Allegro game programming library.✨
- release_handler(3)Unpacking and Installation of Release Packages✨
- release_handler(3erl)Unpacking and Installation of Release Packages✨
- release_method(3)Release Numbering and Methodology✨
- release_method(3avr)Release Numbering and Methodology✨
- release_screen(3)Shortcut of release_bitmap(screen); Allegro game programming library.✨
- release_screen(3alleg4)Shortcut of release_bitmap(screen); Allegro game programming library.✨
- release_voice(3)Releases a sound card voice. Allegro game programming library.✨
- release_voice(3alleg4)Releases a sound card voice. Allegro game programming library.✨
- relic(3)the NDBM-compatible API of QDBM✨
- Religion::Islam::PrayerTimes(3pm)Calculates Muslim Prayers Times and Sunrise✨
- relink_image(3)Reassign and translate the property-space to be relative another object✨
- reload_config_texts(3)Reloads translated strings returned by get_config_text(). Allegro game programming library.✨
- reload_config_texts(3alleg4)Reloads translated strings returned by get_config_text(). Allegro game programming library.✨
- relprodbddnodeassoc(3)computes a relational product.✨
- relprodbddnodeassoc(3alc)computes a relational product.✨
- reltool(3)Main API of the Reltool application✨
- reltool(3erl)Main API of the Reltool application✨
- rem(3)✨
- rem(3avr)✨
- remainder(3)floating-point remainder function✨
- remainder(3clc)Floating point remainder function. gentype remainder(gentype x, gentype y);✨
- remainder(3p)remainder function✨
- remainder(3posix)remainder function✨
- remainder(3scm)number-theoretic integer division✨
- remainderf(3)floating-point remainder function✨
- remainderl(3)floating-point remainder function✨
- remctl(3)Simple remctl call to a remote server✨
- remctl_close(3)Close a remctl connection and free the client object✨
- remctl_command(3)Send a command to a remctl server✨
- remctl_commandv(3)Send a command to a remctl server✨
- remctl_error(3)Retrieve the error from a failed remctl operation✨
- remctl_new(3)Create a new remctl client✨
- remctl_noop(3)Send a NOOP message to a remctl server✨
- remctl_open(3)Connect to a remote remctl server✨
- remctl_open_addrinfo(3)Connect to a remote remctl server✨
- remctl_open_fd(3)Connect to a remote remctl server✨
- remctl_open_sockaddr(3)Connect to a remote remctl server✨
- remctl_output(3)Retrieve the results of a remctl command✨
- remctl_result_free(3)Simple remctl call to a remote server✨
- remctl_set_ccache(3)Set credential cache for remctl client connections✨
- remctl_set_source_ip(3)Set source IP for remctl client connections✨
- remctl_set_timeout(3)Set timeout for subsequent remctl client operations✨
- Remind::PDF(3pm)Render a month's worth of Remind data to PDF✨
- Remind::PDF::Entry(3pm)Representation of one calendar entry✨
- remove(3)remove a file or directory✨
- remove(3p)remove a file✨
💅
getting it ready, bestie…