section 3pmc · Library functions 📚
296 pages · page 1 of 2
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
C
- Compress::Raw::Bzip2(3pmc)Low-Level Interface to bzip2 compression library✨
- Compress::Raw::Zlib(3pmc)Low-Level Interface to zlib or zlib-ng compression library✨
- Compress::Zlib(3pmc)Interface to zlib compression library✨
- CPAN::Meta::Requirements(3pmc)a set of version requirements for a CPAN dist✨
- CPAN::Meta::Requirements::Range(3pmc)a set of version requirements for a CPAN dist✨
D
- Devel::PPPort(3pmc)Perl/Pollution/Portability✨
- Digest::MD5(3pmc)Perl interface to the MD5 Algorithm✨
E
- Encode(3pmc)character encodings in Perl✨
- Encode::Alias(3pmc)alias definitions to encodings✨
- Encode::CJKConstants(3pmc)Internally used by Encode::??::ISO_2022_*✨
- Encode::CN::HZ(3pmc)internally used by Encode::CN✨
- Encode::Config(3pmc)internally used by Encode✨
- Encode::Encoder(3pmc)Object Oriented Encoder✨
- Encode::Encoding(3pmc)Encode Implementation Base Class✨
- Encode::GSM0338(3pmc)ETSI GSM 03.38 Encoding✨
- Encode::Guess(3pmc)Guesses encoding from data✨
- Encode::JP::H2Z(3pmc)internally used by Encode::JP::2022_JP*✨
- Encode::JP::JIS7(3pmc)internally used by Encode::JP✨
- Encode::KR::2022_KR(3pmc)internally used by Encode::KR✨
- Encode::MIME::Header(3pmc)MIME encoding for an unstructured email header✨
- Encode::MIME::Name(3pmc)internally used by Encode✨
- Encode::PerlIO(3pmc)a detailed document on Encode and PerlIO✨
- Encode::Supported(3pmc)Encodings supported by Encode✨
- Encode::Unicode::UTF7(3pmc)UTF-7 encoding✨
- encoding(3pmc)allows you to write your script in non-ASCII and non-UTF-8✨
- experimental(3pmc)Experimental features made easy✨
- ExtUtils::Command(3pmc)utilities to replace common UNIX commands in Makefiles etc.✨
- ExtUtils::Command::MM(3pmc)Commands for the MM's to use in Makefiles✨
- ExtUtils::Liblist(3pmc)determine libraries to use and how to use them✨
- ExtUtils::MakeMaker(3pmc)Create a module Makefile✨
- ExtUtils::MakeMaker::Config(3pmc)Wrapper around Config.pm✨
- ExtUtils::MakeMaker::FAQ(3pmc)Frequently Asked Questions About MakeMaker✨
- ExtUtils::MakeMaker::Locale(3pmc)bundled Encode::Locale✨
- ExtUtils::MakeMaker::Tutorial(3pmc)Writing a module with MakeMaker✨
- ExtUtils::Manifest(3pmc)Utilities to write and check a MANIFEST file✨
- ExtUtils::Mkbootstrap(3pmc)make a bootstrap file for use by DynaLoader✨
- ExtUtils::Mksymlists(3pmc)write linker options files for dynamic extension✨
- ExtUtils::MM(3pmc)OS adjusted ExtUtils::MakeMaker subclass✨
- ExtUtils::MM_AIX(3pmc)AIX specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_Any(3pmc)Platform-agnostic MM methods✨
- ExtUtils::MM_BeOS(3pmc)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_Cygwin(3pmc)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_Darwin(3pmc)special behaviors for OS X✨
- ExtUtils::MM_DOS(3pmc)DOS specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_MacOS(3pmc)once produced Makefiles for MacOS Classic✨
- ExtUtils::MM_NW5(3pmc)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_OS2(3pmc)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_OS390(3pmc)OS390 specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_QNX(3pmc)QNX specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_Unix(3pmc)methods used by ExtUtils::MakeMaker✨
- ExtUtils::MM_UWIN(3pmc)U/WIN specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_VMS(3pmc)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_VOS(3pmc)VOS specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_Win32(3pmc)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_Win95(3pmc)method to customize MakeMaker for Win9X✨
- ExtUtils::MY(3pmc)ExtUtils::MakeMaker subclass for customization✨
- ExtUtils::testlib(3pmc)add blib/* directories to @INC✨
F
- File::GlobMapper(3pmc)Extend File Glob to Allow Input and Output Files✨
- File::Path(3pmc)Create or remove directory trees✨
H
- HTTP::Tiny(3pmc)A small, simple, correct HTTP/1.1 client✨
I
- IO::Compress(3pmc)read/write compressed data in multiple formats✨
- IO::Compress::Base(3pmc)Base Class for IO::Compress modules✨
- IO::Compress::Bzip2(3pmc)Write bzip2 files/buffers✨
- IO::Compress::Deflate(3pmc)Write RFC 1950 files/buffers✨
- IO::Compress::FAQ(3pmc)Frequently Asked Questions about IO::Compress✨
- IO::Compress::Gzip(3pmc)Write RFC 1952 files/buffers✨
- IO::Compress::RawDeflate(3pmc)Write RFC 1951 files/buffers✨
- IO::Compress::Zip(3pmc)Write zip files/buffers✨
- IO::Uncompress::AnyInflate(3pmc)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyUncompress(3pmc)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::Base(3pmc)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Bunzip2(3pmc)Read bzip2 files/buffers✨
- IO::Uncompress::Gunzip(3pmc)Read RFC 1952 files/buffers✨
- IO::Uncompress::Inflate(3pmc)Read RFC 1950 files/buffers✨
- IO::Uncompress::RawInflate(3pmc)Read RFC 1951 files/buffers✨
- IO::Uncompress::Unzip(3pmc)Read zip files/buffers✨
L
- List::Util(3pmc)A selection of general-utility list subroutines✨
- List::Util::XS(3pmc)Indicate if List::Util was compiled with a C compiler✨
M
- Math::BigFloat(3pmc)arbitrary size floating point math package✨
- Math::BigInt(3pmc)arbitrary size integer math package✨
- Math::BigInt::Calc(3pmc)pure Perl module to support Math::BigInt✨
- Math::BigInt::Lib(3pmc)virtual parent class for Math::BigInt libraries✨
- Math::BigRat(3pmc)arbitrary size rational number math package✨
- Module::Metadata(3pmc)Gather package and POD information from perl module files✨
O
- ok(3pmc)Alternative to Test::More::use_ok✨
S
- Scalar::Util(3pmc)A selection of general-utility scalar subroutines✨
- stable(3pmc)Experimental features made easy, once we know they're stable✨
- Sub::Util(3pmc)A selection of utility subroutines for subs and CODE references✨
T
- Term::Table(3pmc)Format a header and rows into a table✨
- Term::Table::Cell(3pmc)Representation of a cell in a table.✨
- Term::Table::CellStack(3pmc)Combine several cells into one (vertical)✨
- Term::Table::HashBase(3pmc)Build hash based classes.✨
- Term::Table::LineBreak(3pmc)Break up lines for use in tables.✨
- Term::Table::Util(3pmc)Utilities for Term::Table.✨
- Test2(3pmc)Framework for writing test tools that all work together.✨
- Test2::API(3pmc)Primary interface for writing Test2 based testing tools.✨
- Test2::API::Breakage(3pmc)What breaks at what version✨
- Test2::API::Context(3pmc)Object to represent a testing context.✨
- Test2::API::Instance(3pmc)Object used by Test2::API under the hood✨
- Test2::API::InterceptResult(3pmc)Representation of a list of events.✨
- Test2::API::InterceptResult::Event(3pmc)Representation of an event for use in testing other test tools.✨
- Test2::API::InterceptResult::Hub(3pmc)Hub used by InterceptResult.✨
- Test2::API::InterceptResult::Squasher(3pmc)Encapsulation of the algorithm that squashes diags into assertions.✨
- Test2::API::Stack(3pmc)Object to manage a stack of Test2::Hub instances.✨
- Test2::AsyncSubtest(3pmc)Object representing an async subtest.✨
- Test2::AsyncSubtest::Event::Attach(3pmc)Event to attach a subtest to the parent.✨
- Test2::AsyncSubtest::Event::Detach(3pmc)Event to detach a subtest from the parent.✨
- Test2::AsyncSubtest::Hub(3pmc)Hub used by async subtests.✨
- Test2::Bundle(3pmc)Documentation for bundles.✨
- Test2::Bundle::Extended(3pmc)Old name for Test2::V0✨
- Test2::Bundle::More(3pmc)ALMOST a drop-in replacement for Test::More.✨
- Test2::Bundle::Simple(3pmc)ALMOST a drop-in replacement for Test::Simple.✨
- Test2::Compare(3pmc)Test2 extension for writing deep comparison tools.✨
- Test2::Compare::Array(3pmc)Internal representation of an array comparison.✨
- Test2::Compare::Bag(3pmc)Internal representation of a bag comparison.✨
- Test2::Compare::Base(3pmc)Base class for comparison classes.✨
- Test2::Compare::Bool(3pmc)Compare two values as booleans✨
- Test2::Compare::Custom(3pmc)Custom field check for comparisons.✨
- Test2::Compare::DeepRef(3pmc)Ref comparison✨
- Test2::Compare::Delta(3pmc)Representation of differences between nested data structures.✨
- Test2::Compare::Event(3pmc)Event specific Object subclass.✨
- Test2::Compare::EventMeta(3pmc)Meta class for events in deep comparisons✨
- Test2::Compare::Float(3pmc)Compare two values as numbers with tolerance.✨
- Test2::Compare::Hash(3pmc)Representation of a hash in a deep comparison.✨
- Test2::Compare::Isa(3pmc)Check if the value is an instance of the class.✨
- Test2::Compare::Meta(3pmc)Check library for meta-checks✨
- Test2::Compare::Negatable(3pmc)Poor mans 'role' for compare objects that can be negated.✨
- Test2::Compare::Number(3pmc)Compare two values as numbers✨
- Test2::Compare::Object(3pmc)Representation of an object during deep comparison.✨
- Test2::Compare::OrderedSubset(3pmc)Internal representation of an ordered subset.✨
- Test2::Compare::Pattern(3pmc)Use a pattern to validate values in a deep comparison.✨
- Test2::Compare::Ref(3pmc)Ref comparison✨
- Test2::Compare::Regex(3pmc)Regex direct comparison✨
- Test2::Compare::Scalar(3pmc)Representation of a Scalar Ref in deep comparisons✨
- Test2::Compare::Set(3pmc)Allows a field to be matched against a set of checks.✨
- Test2::Compare::String(3pmc)Compare two values as strings✨
- Test2::Compare::Undef(3pmc)Check that something is undefined✨
- Test2::Compare::Wildcard(3pmc)Placeholder check.✨
- Test2::Env(3pmc)Documentation for environment variables used or set by Test2.✨
- Test2::Event(3pmc)Base class for events✨
- Test2::Event::Bail(3pmc)Bailout!✨
- Test2::Event::Diag(3pmc)Diag event type✨
- Test2::Event::Encoding(3pmc)Set the encoding for the output stream✨
- Test2::Event::Exception(3pmc)Exception event✨
- Test2::Event::Fail(3pmc)Event for a simple failed assertion✨
- Test2::Event::Generic(3pmc)Generic event type.✨
- Test2::Event::Note(3pmc)Note event type✨
- Test2::Event::Ok(3pmc)Ok event type✨
- Test2::Event::Pass(3pmc)Event for a simple passing assertion✨
- Test2::Event::Plan(3pmc)The event of a plan✨
- Test2::Event::Skip(3pmc)Skip event type✨
- Test2::Event::Subtest(3pmc)Event for subtest types✨
- Test2::Event::TAP::Version(3pmc)Event for TAP version.✨
- Test2::Event::V2(3pmc)Second generation event.✨
- Test2::Event::Waiting(3pmc)Tell all procs/threads it is time to be done✨
- Test2::EventFacet(3pmc)Base class for all event facets.✨
- Test2::EventFacet::About(3pmc)Facet with event details.✨
- Test2::EventFacet::Amnesty(3pmc)Facet for assertion amnesty.✨
- Test2::EventFacet::Assert(3pmc)Facet representing an assertion.✨
- Test2::EventFacet::Control(3pmc)Facet for hub actions and behaviors.✨
- Test2::EventFacet::Error(3pmc)Facet for errors that need to be shown.✨
- Test2::EventFacet::Hub(3pmc)Facet for the hubs an event passes through.✨
- Test2::EventFacet::Info(3pmc)Facet for information a developer might care about.✨
- Test2::EventFacet::Info::Table(3pmc)Intermediary representation of a table.✨
- Test2::EventFacet::Meta(3pmc)Facet for meta-data✨
- Test2::EventFacet::Parent(3pmc)Facet for events contains other events✨
- Test2::EventFacet::Plan(3pmc)Facet for setting the plan✨
- Test2::EventFacet::Render(3pmc)Facet that dictates how to render an event.✨
- Test2::EventFacet::Trace(3pmc)Debug information for events✨
- Test2::Formatter(3pmc)Namespace for formatters.✨
- Test2::Formatter::TAP(3pmc)Standard TAP formatter✨
- Test2::Hub(3pmc)The conduit through which all events flow.✨
- Test2::Hub::Interceptor(3pmc)Hub used by interceptor to grab results.✨
- Test2::Hub::Interceptor::Terminator(3pmc)Exception class used by Test2::Hub::Interceptor✨
- Test2::Hub::Subtest(3pmc)Hub used by subtests✨
- Test2::IPC(3pmc)Turn on IPC for threading or forking support.✨
- Test2::IPC::Driver(3pmc)Base class for Test2 IPC drivers.✨
- Test2::IPC::Driver::Files(3pmc)Temp dir + Files concurrency model.✨
- Test2::Manual(3pmc)Documentation hub for Test2 and Test2-Suite.✨
- Test2::Manual::Anatomy(3pmc)The hub for documentation of the inner workings of Test2 components.✨
- Test2::Manual::Anatomy::API(3pmc)Internals documentation for the API.✨
- Test2::Manual::Anatomy::Context(3pmc)Internals documentation for the Context objects.✨
- Test2::Manual::Anatomy::EndToEnd(3pmc)Overview of Test2 from load to finish.✨
- Test2::Manual::Anatomy::Event(3pmc)The internals of events✨
- Test2::Manual::Anatomy::Hubs(3pmc)Internals documentation for the hub stack, and hubs.✨
- Test2::Manual::Anatomy::IPC(3pmc)Manual for the IPC system.✨
- Test2::Manual::Anatomy::Utilities(3pmc)Overview of utilities for Test2.✨
- Test2::Manual::Concurrency(3pmc)Documentation for Concurrency support.✨
- Test2::Manual::Contributing(3pmc)How to contribute to the Test2 project.✨
- Test2::Manual::Testing(3pmc)Hub for documentation about writing tests with Test2.✨
- Test2::Manual::Testing::Introduction(3pmc)Introduction to testing with Test2.✨
- Test2::Manual::Testing::Migrating(3pmc)How to migrate existing tests from Test::More to Test2.✨
- Test2::Manual::Testing::Planning(3pmc)The many ways to set a plan.✨
- Test2::Manual::Testing::Todo(3pmc)Tutorial for marking tests as TODO.✨
- Test2::Manual::Tooling(3pmc)Manual page for tool authors.✨
- Test2::Manual::Tooling::FirstTool(3pmc)Write your first tool with Test2.✨
- Test2::Manual::Tooling::Formatter(3pmc)How to write a custom formatter, in our case a JSONL formatter.✨
- Test2::Manual::Tooling::Nesting(3pmc)Tutorial for using other tools within your own.✨
- Test2::Manual::Tooling::Plugin::TestExit(3pmc)How to safely add pre-exit behaviors.✨
- Test2::Manual::Tooling::Plugin::TestingDone(3pmc)Run code when the test file is finished, or when done_testing is called.✨
💅
getting it ready, bestie…