section 3pm · Library functions 📚
34259 pages · page 9 of 172
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
A (continued)
- Audio::Scrobbler(3pm)Perl interface to audioscrobbler.com/last.fm✨
- Audio::Wav(3pm)Modules for reading & writing Microsoft WAV files.✨
- Audio::Wav::Read(3pm)Module for reading Microsoft WAV files.✨
- Audio::Wav::Write(3pm)Module for writing Microsoft WAV files.✨
- Audio::WMA(3pm)Perl extension for reading WMA/ASF Metadata✨
- Auth::GoogleAuth(3pm)Google Authenticator TBOT Abstraction✨
- Auth::Yubikey_Decrypter(3pm)Decrypting the output from the yubikey token✨
- Auth::Yubikey_WebClient(3pm)Authenticating the Yubikey against the Yubico Web API✨
- AuthCAS(3pm)Client library for JA-SIG CAS 2.0 authentication server✨
- Authen::Bitcard(3pm)Bitcard authentication verification✨
- Authen::Captcha(3pm)Perl extension for creating captcha's to verify the human element in transactions.✨
- Authen::CAS::Client(3pm)Provides an easy-to-use interface for authentication using JA-SIG's Central Authentication Service✨
- Authen::CAS::Client::Response(3pm)A set of classes for implementing responses from a CAS server✨
- Authen::Credential(3pm)abstraction of a credential✨
- Authen::Credential::none(3pm)abstraction of a "none" credential✨
- Authen::Credential::plain(3pm)abstraction of a "plain" credential✨
- Authen::Credential::x509(3pm)abstraction of an X.509 credential✨
- Authen::DecHpwd(3pm)DEC VMS password hashing✨
- Authen::DigestMD5(3pm)SASL DIGEST-MD5 authentication (RFC2831)✨
- Authen::Htpasswd(3pm)interface to read and modify Apache .htpasswd files✨
- Authen::Htpasswd::User(3pm)represents a user line in a .htpasswd file✨
- Authen::Htpasswd::Util(3pm)performs encryption of supported .htpasswd formats✨
- Authen::Krb5(3pm)XS bindings for Kerberos 5✨
- Authen::Krb5::Admin(3pm)Perl extension for MIT Kerberos 5 admin interface✨
- Authen::Krb5::AuthContext(3pm)Kerberos 5 auth_context object.✨
- Authen::Krb5::Ccache(3pm)Kerberos 5 credentials cache object.✨
- Authen::Krb5::Creds(3pm)Object representing a credential.✨
- Authen::Krb5::EncTktPart(3pm)Object representation of the krb5_enc_tkt_part structure.✨
- Authen::Krb5::KeyBlock(3pm)Kerberos 5 keyblock object.✨
- Authen::Krb5::Keyblock(3pm)Object representation of the krb5_keyblock structure.✨
- Authen::Krb5::Keytab(3pm)A Kerberos 5 keytab✨
- Authen::Krb5::KeytabEntry(3pm)Entry in a Kerberos Keytab✨
- Authen::Krb5::Principal(3pm)Kerberos 5 princpal object.✨
- Authen::Krb5::Simple(3pm)Basic user authentication using Kerberos 5✨
- Authen::Krb5::Ticket(3pm)Kerberos 5 ticket object.✨
- Authen::Libwrap(3pm)access to Wietse Venema's TCP Wrappers library✨
- Authen::ModAuthPubTkt(3pm)Generate Tickets (Signed HTTP Cookies) for mod_auth_pubtkt protected websites.✨
- Authen::NTLM(3pm)An NTLM authentication module✨
- Authen::OATH(3pm)OATH One Time Passwords✨
- Authen::PAM(3pm)Perl interface to PAM library✨
- Authen::PAM::FAQ(3pm)Frequently-Asked Questions about Authen::PAM.✨
- Authen::Passphrase(3pm)hashed passwords/passphrases as objects✨
- Authen::Passphrase::AcceptAll(3pm)accept any passphrase✨
- Authen::Passphrase::BigCrypt(3pm)passphrases using bigcrypt algorithm✨
- Authen::Passphrase::BlowfishCrypt(3pm)passphrases using the Blowfish-based Unix crypt()✨
- Authen::Passphrase::Clear(3pm)cleartext passphrases✨
- Authen::Passphrase::Crypt16(3pm)passphrases using Ultrix crypt16 algorithm✨
- Authen::Passphrase::DESCrypt(3pm)passphrases using the DES-based Unix crypt()✨
- Authen::Passphrase::EggdropBlowfish(3pm)passphrases using Eggdrop's blowfish.mod✨
- Authen::Passphrase::LANManager(3pm)passphrases using the LAN Manager hash algorithm✨
- Authen::Passphrase::LANManagerHalf(3pm)passphrases using half the LAN Manager algorithm✨
- Authen::Passphrase::MD5Crypt(3pm)passphrases using the MD5-based Unix crypt()✨
- Authen::Passphrase::MySQL323(3pm)passphrases using the MySQL v3.23 algorithm✨
- Authen::Passphrase::MySQL41(3pm)passphrases using the MySQL v4.1 algorithm✨
- Authen::Passphrase::NetscapeMail(3pm)passphrases using Netscape Mail Server's method✨
- Authen::Passphrase::NTHash(3pm)passphrases using the NT-Hash algorithm✨
- Authen::Passphrase::PHPass(3pm)passphrases using the phpass algorithm✨
- Authen::Passphrase::RejectAll(3pm)reject all passphrases✨
- Authen::Passphrase::SaltedDigest(3pm)passphrases using the generic salted digest algorithm✨
- Authen::Passphrase::VMSPurdy(3pm)passphrases with the VMS Purdy polynomial system✨
- Authen::Radius(3pm)provide simple Radius client facilities✨
- Authen::SASL(3pm)SASL Authentication framework✨
- Authen::SASL::Cyrus(3pm)XS code to glue Perl SASL to Cyrus SASL✨
- Authen::SASL::Perl(3pm)Perl implementation of the SASL Authentication framework✨
- Authen::SASL::Perl::ANONYMOUS(3pm)Anonymous Authentication class✨
- Authen::SASL::Perl::CRAM_MD5(3pm)(DEPRECATED) CRAM MD5 Authentication class✨
- Authen::SASL::Perl::DIGEST_MD5(3pm)(DEPRECATED) Digest MD5 Authentication class✨
- Authen::SASL::Perl::EXTERNAL(3pm)External Authentication class✨
- Authen::SASL::Perl::GSSAPI(3pm)GSSAPI (Kerberosv5) Authentication class✨
- Authen::SASL::Perl::LOGIN(3pm)Login Authentication class✨
- Authen::SASL::Perl::OAUTHBEARER(3pm)OAUTHBEARER Authentication class✨
- Authen::SASL::Perl::PLAIN(3pm)Plain Login Authentication class✨
- Authen::SASL::Perl::SCRAM_SHA_1(3pm)SCRAM-SHA-1 support for Authen::SASL✨
- Authen::SASL::Perl::SCRAM_SHA_256(3pm)SCRAM-SHA-256 support for Authen::SASL✨
- Authen::SASL::Perl::SCRAM_SHA_512(3pm)SCRAM-SHA-512 support for Authen::SASL✨
- Authen::SASL::Perl::XOAUTH2(3pm)XOAUTH2 Authentication class✨
- Authen::SASL::SASLprep(3pm)A Stringprep Profile for User Names and Passwords (RFC 4013)✨
- Authen::SASL::SCRAM(3pm)SCRAM support for Authen::SASL✨
- Authen::SASL::XS(3pm)XS code to glue Perl SASL to Cyrus SASL✨
- Authen::SCRAM(3pm)Salted Challenge Response Authentication Mechanism (RFC 5802)✨
- Authen::SCRAM::Client(3pm)RFC 5802 SCRAM client✨
- Authen::SCRAM::Role::Common(3pm)✨
- Authen::SCRAM::Server(3pm)RFC 5802 SCRAM Server✨
- Authen::Simple(3pm)Simple Authentication✨
- Authen::Simple::ActiveDirectory(3pm)Simple ActiveDirectory authentication✨
- Authen::Simple::Adapter(3pm)Adapter class for implementations✨
- Authen::Simple::Apache(3pm)PerlAuthenHandler handler for Apache✨
- Authen::Simple::CDBI(3pm)Simple Class::DBI authentication✨
- Authen::Simple::DBI(3pm)Simple DBI authentication✨
- Authen::Simple::DBM(3pm)Simple DBM authentication✨
- Authen::Simple::FTP(3pm)Simple FTP authentication✨
- Authen::Simple::HTTP(3pm)Simple HTTP authentication✨
- Authen::Simple::Kerberos(3pm)Simple Kerberos authentication✨
- Authen::Simple::LDAP(3pm)Simple LDAP authentication✨
- Authen::Simple::Log(3pm)Simple log class✨
- Authen::Simple::PAM(3pm)Simple PAM authentication✨
- Authen::Simple::Passwd(3pm)Simple Passwd authentication✨
- Authen::Simple::Password(3pm)Simple password checking✨
- Authen::Simple::POP3(3pm)Simple POP3 authentication✨
- Authen::Simple::RADIUS(3pm)Simple RADIUS authentication✨
- Authen::Simple::SMB(3pm)Simple SMB authentication✨
- Authen::Simple::SMTP(3pm)Simple SMTP authentication✨
- Authen::Smb(3pm)Perl extension to authenticate against an SMB server✨
- Authen::TacacsPlus(3pm)Perl extension for authentication using tacacs+ server✨
- Authen::U2F(3pm)FIDO U2F library✨
- Authen::U2F::Tester(3pm)FIDO/U2F Authentication Test Client✨
- Authen::U2F::Tester::Const(3pm)Constants for Authen::U2F::Tester✨
- Authen::U2F::Tester::Error(3pm)Authen::U2F::Tester Error Response✨
- Authen::U2F::Tester::Keypair(3pm)Authen::U2F::Tester Keypair Object✨
- Authen::U2F::Tester::Keystore::Wrapped(3pm)Wrapped Keystore for Authen::U2F::Tester✨
- Authen::U2F::Tester::RegisterResponse(3pm)U2F Tester Registration Response✨
- Authen::U2F::Tester::Role::Keystore(3pm)U2F Tester Keystore Role.✨
- Authen::U2F::Tester::Role::Response(3pm)U2F Successful Response Role✨
- Authen::U2F::Tester::SignResponse(3pm)U2F Tester Sign Response✨
- Authen::WebAuthn(3pm)A library to add Web Authentication support to server applications✨
- auto::share::dist::Module-Starter-Plugin-CGIApp::default::Module(3pm)The great new <tmpl_var module> web application!✨
- auto::share::dist::Module-Starter-Plugin-CGIApp::titanium::Module(3pm)The great new <tmpl_var module> web application!✨
- autobox(3pm)call methods on native types✨
- autobox::Core(3pm)Provide core functions to autoboxed scalars, arrays and hashes.✨
- autobox::dump(3pm)human/perl readable strings from the results of an EXPR✨
- autobox::Junctions(3pm)Autoboxified junction-style operators✨
- autobox::List::Util(3pm)bring the List::Util functions to autobox✨
- autobox::Transform(3pm)Autobox methods to transform Arrays and Hashes✨
- Autodia(3pm)The configuration and Utility perl module for AutoDia.✨
- autodia(3pm)a perl script using the Autodia modules to create UML Class Diagrams or documents. from code or other data sources.✨
- Autodia::Diagram(3pm)Class to hold a collection of objects representing parts of a Dia Diagram.✨
- Autodia::Diagram::Class(3pm)Class that holds, updates and outputs the values of a diagram element of type class.✨
- Autodia::Diagram::Component(3pm)✨
- Autodia::Handler(3pm)generic language handler superclass✨
- Autodia::Handler::ASP(3pm)AutoDia handler for ASP✨
- Autodia::Handler::Cpp(3pm)AutoDia handler for C++✨
- Autodia::Handler::CSharp(3pm)AutoDia handler for C#✨
- Autodia::Handler::DBI(3pm)AutoDia handler for DBI connections✨
- Autodia::Handler::DBI_SQLT(3pm)AutoDia handler for DBI connections✨
- Autodia::Handler::dia(3pm)AutoDia handler for dia✨
- Autodia::Handler::Mason(3pm)Allows Autodia to parse HTML::Mason files✨
- Autodia::Handler::Perl(3pm)AutoDia handler for perl✨
- Autodia::Handler::PHP(3pm)AutoDia handler for PHP✨
- Autodia::Handler::SQL(3pm)AutoDia handler for SQL✨
- Autodia::Handler::Torque(3pm)AutoDia handler for Torque xml database schema✨
- Autodia::Handler::umbrello(3pm)AutoDia handler for umbrello✨
- autodie(3pm)Replace functions with ones that succeed or die with lexical scope✨
- autodie::exception(3pm)Exceptions from autodying functions.✨
- autodie::exception::system(3pm)Exceptions from autodying system().✨
- autodie::hints(3pm)Provide hints about user subroutines to autodie✨
- autodie::Scope::Guard(3pm)Wrapper class for calling subs at end of scope✨
- autodie::Scope::GuardStack(3pm)Hook stack for managing scopes via %^H✨
- autodie::skip(3pm)Skip a package when throwing autodie exceptions✨
- autodie::Util(3pm)Internal Utility subroutines for autodie and Fatal✨
- AutoLoader(3pm)load subroutines only on demand✨
- AutoSplit(3pm)split a package for autoloading✨
- autouse(3pm)postpone load of modules until a function is used✨
- autovivification(3pm)Lexically disable autovivification.✨
- AutoXS::Header(3pm)Container for the AutoXS header files✨
- AWS::Signature4(3pm)Create a version4 signature for Amazon Web Services✨
B
- B(3pm)The Perl Compiler Backend✨
- B::Clobbers(3pm)clobbering analyzer✨
- B::Compiling(3pm)Expose PL_compiling to perl✨
- B::Concise(3pm)Walk Perl syntax tree, printing concise info about ops✨
- B::ConstOptree(3pm)Optree constant folding for $^O, $^V, and $]✨
- B::COW(3pm)B::COW additional B helpers to check COW status✨
- B::Debug(3pm)Walk Perl syntax tree, printing debug info about ops✨
- B::Deparse(3pm)Perl compiler backend to produce perl code✨
- B::Generate(3pm)Create your own op trees.✨
- B::Hooks::AtRuntime(3pm)Lower blocks from compile time to runtime✨
- B::Hooks::EndOfScope(3pm)Execute code after a scope finished compilation✨
- B::Hooks::EndOfScope::PP(3pm)Execute code after a scope finished compilation - PP implementation✨
- B::Hooks::EndOfScope::XS(3pm)Execute code after a scope finished compilation - XS implementation✨
- B::Hooks::OP::Annotation(3pm)annotate and delegate hooked OPs✨
- B::Hooks::OP::Check(3pm)Wrap OP check callbacks✨
- B::Hooks::OP::Check::EntersubForCV(3pm)Invoke callbacks on construction of entersub OPs for certain CVs✨
- B::Hooks::OP::Check::StashChange(3pm)Invoke callbacks when the stash code is being compiled in changes✨
- B::Hooks::OP::PPAddr(3pm)Hook into opcode execution✨
- B::Hooks::Parser(3pm)Interface to perl's parser variables✨
- B::Keywords(3pm)Lists of reserved barewords and symbol names✨
- B::Lint(3pm)Perl lint✨
- B::Lint::Debug(3pm)Adds debugging stringification to B::✨
- B::Module::Info(3pm)information about Perl modules✨
- B::Op_private(3pm)OP op_private flag definitions✨
- B::PerlReq(3pm)Perl compiler backend to extract Perl dependencies✨
- B::Showlex(3pm)Show lexical variables used in functions or files✨
- B::Terse(3pm)Walk Perl syntax tree, printing terse info about ops✨
- B::Utils(3pm)Helper functions for op tree manipulation✨
- B::Utils::OP(3pm)op related utility functions for perl✨
- B::Walker(3pm)dumb walker, optree ranger✨
- B::Xref(3pm)Generates cross reference reports for Perl programs✨
- BackPAN::Index(3pm)An interface to the BackPAN index✨
- BackPAN::Index::Dist(3pm)Representing a distribution on BackPAN✨
- BackPAN::Index::File(3pm)Represent a file on BackPAN✨
- BackPAN::Index::Release(3pm)A single release of a distribution✨
- BackPAN::Index::Role::AsHash(3pm)Role to dump object data as a hash✨
- BackupPC::XS(3pm)Perl extension for BackupPC libraries✨
- Badger(3pm)Perl Application Programming Toolkit✨
- Badger::App(3pm)base class application module✨
- Badger::Apps(3pm)factory module for application modules✨
- Badger::Base(3pm)base class module✨
- Badger::Class(3pm)class metaprogramming module✨
- Badger::Class::Config(3pm)class mixin for configuration✨
- Badger::Class::Methods(3pm)metaprogramming module for adding methods to a class✨
- Badger::Class::Vars(3pm)class module for defining package variables✨
💅
getting it ready, bestie…