section 3pm · Library functions 📚
34259 pages · page 49 of 172
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
D (continued)
- DNS::LDNS::DNSSecRRs(3pm)Linked list of rrs in a dnssec zone✨
- DNS::LDNS::DNSSecRRSets(3pm)Linked list of rrsets in a dnssec zone✨
- DNS::LDNS::DNSSecTrustTree(3pm)Trust tree from signed RR to trust anchors✨
- DNS::LDNS::DNSSecZone(3pm)Zone with dnssec data✨
- DNS::LDNS::GC(3pm)Garbage collector, used internally by the DNS::LDNS modules✨
- DNS::LDNS::Key(3pm)DNSSec private key✨
- DNS::LDNS::KeyList(3pm)Linked list of dnssec keys✨
- DNS::LDNS::Packet(3pm)DNS packet✨
- DNS::LDNS::RBNode(3pm)Node in the RBTree✨
- DNS::LDNS::RBTree(3pm)Tree of DNSSecName nodes✨
- DNS::LDNS::RData(3pm)Rdata field or a dname in an rr✨
- DNS::LDNS::Resolver(3pm)DNS resolver✨
- DNS::LDNS::RR(3pm)Resource record✨
- DNS::LDNS::RRList(3pm)List of rrs✨
- DNS::LDNS::Zone(3pm)Parsed zonefile✨
- DNS::nsdiff(3pm)the nsdiff, nspatch, and nsvi scripts✨
- DNS::Unbound(3pm)Query DNS recursively via libunbound <https://www.nlnetlabs.nl/documentation/unbound/libunbound/>✨
- DNS::Unbound::AnyEvent(3pm)DNS::Unbound for AnyEvent✨
- DNS::Unbound::AsyncQuery(3pm)✨
- DNS::Unbound::IOAsync(3pm)DNS::Unbound for IO::Async✨
- DNS::Unbound::Mojo(3pm)DNS::Unbound for Mojolicious✨
- DNS::Unbound::Result(3pm)✨
- DNS::Unbound::X::ResolveError(3pm)✨
- DNS::Unbound::X::Unbound(3pm)✨
- DNS::ZoneParse(3pm)Parse and manipulate DNS Zone Files.✨
- Domain::PublicSuffix(3pm)Parse a domain down to root✨
- Domain::PublicSuffix::Default(3pm)Default PublicSuffix data file✨
- download-entities.pl(3pm)download and parse XML Entity definitions✨
- Doxygen::Filter::Perl(3pm)A perl code pre-filter for Doxygen✨
- Doxygen::Filter::Perl::POD(3pm)A perl code pre-filter for Doxygen✨
- Dpkg::Copyright::Scanner(3pm)Scan files to provide copyright data✨
- DPKG::Parse(3pm)Parse various dpkg files into Perl Objects✨
- DPKG::Parse::Available(3pm)Parse the "available" file✨
- DPKG::Parse::Entry(3pm)Parse a Package style entry✨
- DPKG::Parse::Packages(3pm)Parse the Packages file✨
- DPKG::Parse::Status(3pm)Parse the "status" file✨
- DR::SunDown(3pm)perl bindings for sundown✨
- DublinCore::Element(3pm)Class for representing a Dublin Core element✨
- DublinCore::Record(3pm)Container for Dublin Core metadata elements✨
- Dumbbench(3pm)More reliable benchmarking with the least amount of thinking✨
- Dumbbench::Instance(3pm)A benchmark instance within a Dumbbench✨
- Dumbbench::Instance::Cmd(3pm)Benchmarks an external command✨
- Dumbbench::Instance::PerlEval(3pm)Benchmarks a string of Perl code✨
- Dumbbench::Instance::PerlSub(3pm)Benchmarks a Perl code reference✨
- Dumpvalue(3pm)provides screen dump of Perl data.✨
- DynaLoader(3pm)Dynamically load C libraries into Perl code✨
- DynaLoader::Functions(3pm)deconstructed dynamic C library loading✨
E
- EB(3pm)EekBoek * Bookkeeping software for small and medium-size businesses✨
- EBook::EPUB(3pm)module for generating EPUB documents✨
- EBook::EPUB::Container(3pm)✨
- EBook::EPUB::Container::Zip(3pm)✨
- EBook::EPUB::Guide(3pm)✨
- EBook::EPUB::Guide::Reference(3pm)✨
- EBook::EPUB::Manifest(3pm)✨
- EBook::EPUB::Manifest::Item(3pm)✨
- EBook::EPUB::Metadata(3pm)✨
- EBook::EPUB::Metadata::Item(3pm)✨
- EBook::EPUB::NCX(3pm)✨
- EBook::EPUB::NCX::NavPoint(3pm)✨
- EBook::EPUB::Spine(3pm)✨
- EBook::EPUB::Spine::Itemref(3pm)✨
- EBook::Tools(3pm)Object class for manipulating and generating E-books✨
- EBook::Tools::BISG(3pm)Class for downloading information from the Book Industry Study Group webpages✨
- EBook::Tools::EReader(3pm)Palm::PDB handler for manipulating the Fictionwise/PeanutPress eReader format.✨
- EBook::Tools::IMP(3pm)Object class for manipulating the SoftBook/GEB/REB/eBookWise ".IMP" and ".RES" e-book formats✨
- EBook::Tools::LZSS(3pm)Lempel-Ziv-Storer-Szymanski compression and decompression✨
- EBook::Tools::Mobipocket(3pm)Palm::PDB handler for manipulating the Mobipocket format.✨
- EBook::Tools::MSReader(3pm)Helper code for working with Microsoft Reader (.lit) e-books.✨
- EBook::Tools::PalmDoc(3pm)Palm::PDB handler for manipulating the PalmDoc/PilotDoc/AportisDoc format✨
- EBook::Tools::Unpack(3pm)Object class for unpacking e-book files into their component parts and metadata✨
- ECMWF::ECaccess(3pm)Perl extension to access the ECMWF ECaccess Web Services (or ECaccess API)✨
- EekBoek(3pm)Bookkeeping software for small and medium-size businesses✨
- ElasticSearch::SearchBuilder(3pm)A Perlish compact query language for ElasticSearch✨
- ElixirFM(3pm)Interfaces to the ElixirFM system implementing Functional Arabic Morphology✨
- ElixirFM::Exec(3pm)Interface to the ElixirFM executable✨
- ElixirFM::Resolve(3pm)Interfaces to the ElixirFM system in Haskell✨
- Email::Abstract(3pm)unified interface to mail representations✨
- Email::Abstract::Courriel(3pm)Email::Abstract wrapper for Courriel✨
- Email::Abstract::EmailMIME(3pm)Email::Abstract wrapper for Email::MIME✨
- Email::Abstract::EmailSimple(3pm)Email::Abstract wrapper for Email::Simple✨
- Email::Abstract::MailInternet(3pm)Email::Abstract wrapper for Mail::Internet✨
- Email::Abstract::MailMessage(3pm)Email::Abstract wrapper for Mail::Message✨
- Email::Abstract::MIMEEntity(3pm)Email::Abstract wrapper for MIME::Entity✨
- Email::Abstract::Plugin(3pm)a base class for Email::Abstract plugins✨
- Email::Address(3pm)RFC 2822 Address Parsing and Creation✨
- Email::Address::List(3pm)RFC close address list parsing✨
- Email::Address::XS(3pm)Parse and format RFC 5322 email addresses and groups✨
- Email::Date(3pm)Find and Format Date Headers✨
- Email::Date::Format(3pm)produce RFC 2822 date strings✨
- Email::Filter(3pm)Library for creating easy email filters✨
- Email::Find(3pm)Find RFC 822 email addresses in plain text✨
- Email::Find::addrspec(3pm)exports $Addr_spec_re to Email::Find✨
- Email::Folder(3pm)read all the messages from a folder as Email::Simple objects✨
- Email::Folder::Ezmlm(3pm)reads raw RFC822 mails from an ezmlm archive✨
- Email::Folder::Maildir(3pm)reads raw RFC822 mails from a maildir✨
- Email::Folder::Mbox(3pm)reads raw RFC822 mails from an mbox file✨
- Email::Folder::MH(3pm)reads raw RFC822 mails from an mh folder✨
- Email::Folder::Reader(3pm)reads raw RFC822 mails from a box✨
- Email::FolderType(3pm)Email::FolderType - determine the type of a mail folder✨
- Email::FolderType::Ezmlm(3pm)class to help Email::FolderType recognise ezmlm archives✨
- Email::FolderType::Maildir(3pm)class to help Email::FolderType recognise maildirs✨
- Email::FolderType::Mbox(3pm)class to help Email::FolderType recognise MH mail directories✨
- Email::FolderType::MH(3pm)class to help Email::FolderType recognise MH mail directories✨
- Email::LocalDelivery(3pm)Deliver a piece of email - simply✨
- Email::LocalDelivery::Maildir(3pm)deliver mail to a Maildir✨
- Email::LocalDelivery::Mbox(3pm)deliver mail to an mbox✨
- Email::MessageID(3pm)Generate world unique message-ids.✨
- Email::MIME(3pm)easy MIME message handling✨
- Email::MIME::Attachment::Stripper(3pm)strip the attachments from an email✨
- Email::MIME::ContentType(3pm)Parse and build a MIME Content-Type or Content-Disposition Header✨
- Email::MIME::CreateHTML(3pm)Multipart HTML Email builder✨
- Email::MIME::CreateHTML::Resolver(3pm)provides the appropriate resource resolver✨
- Email::MIME::CreateHTML::Resolver::Cached(3pm)wraps caching around a resource resolver✨
- Email::MIME::CreateHTML::Resolver::Filesystem(3pm)finds resources via the filesystem✨
- Email::MIME::CreateHTML::Resolver::LWP(3pm)uses LWP as a resource resolver✨
- Email::MIME::Creator(3pm)obsolete do-nothing library✨
- Email::MIME::Encode(3pm)a private helper for MIME header encoding✨
- Email::MIME::Encodings(3pm)A unified interface to MIME encoding and decoding✨
- Email::MIME::Header(3pm)the header of a MIME message✨
- Email::MIME::Header::AddressList(3pm)MIME support for list of Email::Address::XS objects✨
- Email::MIME::Kit(3pm)build messages from templates✨
- Email::MIME::Kit::Assembler::Standard(3pm)the standard kit assembler✨
- Email::MIME::Kit::KitReader::Dir(3pm)read kit entries out of a directory✨
- Email::MIME::Kit::ManifestReader::JSON(3pm)read manifest.json files✨
- Email::MIME::Kit::ManifestReader::YAML(3pm)read manifest.yaml files✨
- Email::MIME::Kit::Renderer::TestRenderer(3pm)extremely simple renderer for testing purposes only✨
- Email::MIME::Kit::Role::Assembler(3pm)things that assemble messages (or parts)✨
- Email::MIME::Kit::Role::Component(3pm)things that are kit components✨
- Email::MIME::Kit::Role::KitReader(3pm)things that can read kit contents✨
- Email::MIME::Kit::Role::ManifestDesugarer(3pm)helper for desugaring manifests✨
- Email::MIME::Kit::Role::ManifestReader(3pm)things that read kit manifests✨
- Email::MIME::Kit::Role::Renderer(3pm)things that render templates into contents✨
- Email::MIME::Kit::Role::Validator(3pm)things that validate assembly parameters✨
- Email::MIME::Modifier(3pm)obsolete do-nothing library✨
- Email::Outlook::Message(3pm)Read Outlook .msg files✨
- Email::Outlook::Message::AddressInfo(3pm)Handle address data in .msg files✨
- Email::Outlook::Message::Attachment(3pm)Handle attachment data in .msg files✨
- Email::Outlook::Message::Base(3pm)Base parser for .msg files.✨
- Email::Received(3pm)Parse an email Received: header✨
- Email::Reply(3pm)reply to an email message✨
- Email::Send(3pm)Simply Sending Email✨
- Email::Send::NNTP(3pm)Post Messages to a News Server✨
- Email::Send::Qmail(3pm)Send Messages using qmail-inject✨
- Email::Send::Sendmail(3pm)Send Messages using sendmail✨
- Email::Send::SMTP(3pm)Send Messages using SMTP✨
- Email::Send::Test(3pm)Captures emails sent via Email::Send for testing✨
- Email::Sender(3pm)a library for sending email✨
- Email::Sender::Failure(3pm)a report of failure from an email sending transport✨
- Email::Sender::Failure::Multi(3pm)an aggregate of multiple failures✨
- Email::Sender::Failure::Permanent(3pm)a permanent delivery failure✨
- Email::Sender::Failure::Temporary(3pm)a temporary delivery failure✨
- Email::Sender::Manual(3pm)table of contents for the Email::Sender manual✨
- Email::Sender::Manual::QuickStart(3pm)how to start using Email::Sender right now✨
- Email::Sender::Role::CommonSending(3pm)the common sending tasks most Email::Sender classes will need✨
- Email::Sender::Role::HasMessage(3pm)an object that has a message✨
- Email::Sender::Simple(3pm)the simple interface for sending mail with Sender✨
- Email::Sender::Success(3pm)the result of successfully sending mail✨
- Email::Sender::Success::Partial(3pm)a report of partial success when delivering✨
- Email::Sender::Transport(3pm)a role for email transports✨
- Email::Sender::Transport::DevNull(3pm)happily throw away your mail✨
- Email::Sender::Transport::Failable(3pm)a wrapper to makes things fail predictably✨
- Email::Sender::Transport::Maildir(3pm)deliver mail to a maildir on disk✨
- Email::Sender::Transport::Mbox(3pm)deliver mail to an mbox on disk✨
- Email::Sender::Transport::Print(3pm)print email to a filehandle (like stdout)✨
- Email::Sender::Transport::Sendmail(3pm)send mail via sendmail(1)✨
- Email::Sender::Transport::SMTP(3pm)send email over SMTP✨
- Email::Sender::Transport::SMTP::Persistent(3pm)an SMTP client that stays online✨
- Email::Sender::Transport::Test(3pm)deliver mail in memory for testing✨
- Email::Sender::Transport::Wrapper(3pm)a mailer to wrap a mailer for mailing mail✨
- Email::Sender::Util(3pm)random stuff that makes Email::Sender go✨
- Email::Simple(3pm)simple parsing of RFC2822 message format and headers✨
- Email::Simple::Creator(3pm)private helper for building Email::Simple objects✨
- Email::Simple::Header(3pm)the header of an Email::Simple message✨
- Email::Stuffer(3pm)A more casual approach to creating and sending Email:: emails✨
- Email::Template(3pm)Send "multipart/alternative" (text & html) email from a Template✨
- Email::Thread(3pm)Use JWZ's mail threading algorithm with Email::Simple objects✨
- Email::Valid(3pm)Check validity of Internet email addresses✨
- Email::Valid::Loose(3pm)Email::Valid which allows dot before at mark✨
- EMBOSS::ACD(3pm)parse EMBOSS ACD (AJAX Command Definition) files✨
- EMBOSS::GUI(3pm)provide web-based access to EMBOSS✨
- EMBOSS::GUI::Conf(3pm)repository for EMBOSS::GUI site-specific configuration✨
- EMBOSS::GUI::XHTML(3pm)generate HTML for EMBOSS::GUI✨
- Embperl(3pm)Building dynamic Websites with Perl✨
- Embperl::App(3pm)Embperl base class for application objects✨
- Embperl::Config(3pm)Embperl configuration and calling✨
- Embperl::Faq(3pm)How to embed Perl code in your HTML docs✨
- Embperl::Features(3pm)Main features of Embperl 2.0✨
- Embperl::Form(3pm)Embperl Form class✨
- Embperl::Form::Control(3pm)Base class for controls inside an Embperl Form✨
- Embperl::Form::Control::addremove(3pm)A control to add and remove items from two select boxes inside an Embperl Form✨
- Embperl::Form::Control::age(3pm)A age input control with optional unit inside an Embperl Form✨
- Embperl::Form::Control::blank(3pm)A blank area inside an Embperl Form✨
- Embperl::Form::Control::button(3pm)A button inside an Embperl Form✨
- Embperl::Form::Control::checkbox(3pm)A checkbox control inside an Embperl Form✨
- Embperl::Form::Control::checkboxes(3pm)A multiple checkbox control inside an Embperl Form✨
- Embperl::Form::Control::datetime(3pm)A price input control with optional unit inside an Embperl Form✨
- Embperl::Form::Control::display(3pm)A text display control inside an Embperl Form✨
- Embperl::Form::Control::displaylink(3pm)A control to display links inside an Embperl Form✨
- Embperl::Form::Control::dump(3pm)A debug control inside an Embperl Form✨
- Embperl::Form::Control::duration(3pm)A price input control with optional unit inside an Embperl Form✨
💅
getting it ready, bestie…