section 3pm · Library functions 📚
34259 pages · page 141 of 172
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
S (continued)
- Sisimai::Lhost::AmazonSES(3pm)bounce mail decoder class for Amazon SES <https://aws.amazon.com/ses/>✨
- Sisimai::Lhost::AmazonWorkMail(3pm)bounce mail parser class for "Amazon WorkMail".✨
- Sisimai::Lhost::Aol(3pm)bounce mail parser class for "Aol Mail".✨
- Sisimai::Lhost::ApacheJames(3pm)bounce mail decoder class for Apache James <https://james.apache.org/>.✨
- Sisimai::Lhost::Barracuda(3pm)bounce mail parser class for "Barracuda".✨
- Sisimai::Lhost::Bigfoot(3pm)bounce mail parser class for "Bigfoot".✨
- Sisimai::Lhost::Biglobe(3pm)bounce mail decoder class for BIGLOBE (<https://www.biglobe.ne.jp/>).✨
- Sisimai::Lhost::Courier(3pm)bounce mail decoder class for Courier MTA <https://www.courier-mta.org/>.✨
- Sisimai::Lhost::DeutscheTelekom(3pm)bounce mail decoder class for Deutsche Telekom <https://www.telekom.com/>.✨
- Sisimai::Lhost::Domino(3pm)bounce mail decoder class for HCL Domino <https://www.hcl-software.com/domino>.✨
- Sisimai::Lhost::DragonFly(3pm)bounce mail decoder class for DMA: DragonFly Mail Agent <https://www.dragonflybsd.org/handbook/mta/>.✨
- Sisimai::Lhost::EinsUndEins(3pm)bounce mail decoder class for 1&1 <https://www.1und1.de/>.✨
- Sisimai::Lhost::Exchange2003(3pm)bounce mail decoder class for Microsft Exchange Server 2003 <https://www.microsoft.com/microsoft-365/exchange/email>.✨
- Sisimai::Lhost::Exchange2007(3pm)bounce mail decoder class for Microsft Exchange Server 2007 <https://www.microsoft.com/microsoft-365/exchange/email>.✨
- Sisimai::Lhost::Exim(3pm)bounce mail decoder class for Exim Internet Mailer <https://www.exim.org/>.✨
- Sisimai::Lhost::EZweb(3pm)bounce mail decoder class for au EZweb <https://www.au.com/mobile/>.✨
- Sisimai::Lhost::Facebook(3pm)bounce mail parser class for "Facebook".✨
- Sisimai::Lhost::FML(3pm)bounce mail decoder class for FML <https://www.fml.org/>.✨
- Sisimai::Lhost::Gmail(3pm)bounce mail decoder class for Gmail <https://mail.google.com/>.✨
- Sisimai::Lhost::GMX(3pm)bounce mail decoder class for GMX <https://gmx.net/> and mail.com.✨
- Sisimai::Lhost::GoogleGroups(3pm)bounce mail decoder class for Google Groups <https://groups.google.com>.✨
- Sisimai::Lhost::GoogleWorkspace(3pm)bounce mail decoder class for Google Workspace <https://workspace.google.com/>✨
- Sisimai::Lhost::GSuite(3pm)bounce mail parser class for "G Suite".✨
- Sisimai::Lhost::IMailServer(3pm)bounce mail decoder class for Progress iMail Server <https://community.progress.com/s/products/imailserver>.✨
- Sisimai::Lhost::InterScanMSS(3pm)bounce mail decoder class for Trend Micro InterScan Messaging Security Suite <https://www.trendmicro.com/en_us/business/products/user-protection/sps/email-and-collaboration/interscan-messaging.html>.✨
- Sisimai::Lhost::KDDI(3pm)bounce mail decoder class for au by KDDI <https://www.au.com/>✨
- Sisimai::Lhost::MailFoundry(3pm)bounce mail decoder class for MailFoundry <https://www.barracuda.com/>.✨
- Sisimai::Lhost::MailMarshal(3pm)bounce mail decoder class for Trustwave Secure Email Gateway <https://www.trustwave.com/en-us/services/email-security/>.✨
- Sisimai::Lhost::MailMarshalSMTP(3pm)bounce mail decoder class for Trustwave Secure Email Gateway <https://www.trustwave.com/en-us/services/email-security/>.✨
- Sisimai::Lhost::MailRu(3pm)bounce mail parser class for "@mail.ru".✨
- Sisimai::Lhost::McAfee(3pm)bounce mail parser class for "McAfee Email Appliance".✨
- Sisimai::Lhost::MessageLabs(3pm)bounce mail parser class for "MessageLabs".✨
- Sisimai::Lhost::MessagingServer(3pm)bounce mail decoder class for "Sun Java System Messaging Server" and "Oracle Communications Messaging Server" <https://docs.oracle.com/en/industries/communications/messaging-server/index.html>.✨
- Sisimai::Lhost::mFILTER(3pm)bounce mail decoder class for Digital Arts m-FILTER <https://www.daj.jp/bs/mf/>.✨
- Sisimai::Lhost::Mimecast(3pm)bounce mail decoder class for Mimecast <https://www.mimecast.com/>.✨
- Sisimai::Lhost::MXLogic(3pm)bounce mail parser class for "MX Logic".✨
- Sisimai::Lhost::Notes(3pm)bounce mail decoder class for HCL Notes (formerly Lotus Notes Server).✨
- Sisimai::Lhost::Office365(3pm)bounce mail parser class for Microsoft Office 365.✨
- Sisimai::Lhost::OpenSMTPD(3pm)bounce mail decoder class for OpenSMTPD <https://www.opensmtpd.org/>.✨
- Sisimai::Lhost::Outlook(3pm)bounce mail parser class for "Outlook.com".✨
- Sisimai::Lhost::Postfix(3pm)bounce mail decoder class for Postfix <https://www.postfix.org/>.✨
- Sisimai::Lhost::PowerMTA(3pm)bounce mail parser class for "PowerMTA".✨
- Sisimai::Lhost::qmail(3pm)bounce mail decoder class for qmail <https://cr.yp.to/qmail.html>.✨
- Sisimai::Lhost::ReceivingSES(3pm)bounce mail parser class for "Amazon SES".✨
- Sisimai::Lhost::SendGrid(3pm)bounce mail parser class for "SendGrid".✨
- Sisimai::Lhost::Sendmail(3pm)bounce mail decoder class for Sendmail Open Source <https://sendmail.org/>.✨
- Sisimai::Lhost::SurfControl(3pm)bounce mail parser class for "SurfControl".✨
- Sisimai::Lhost::TrendMicro(3pm)bounce mail decoder class for TREND VISION ONE: Email and Collaboration Security <https://www.trendmicro.com/en_us/business/products/email-and-collaboration.html>.✨
- Sisimai::Lhost::V5sendmail(3pm)bounce mail decoder class for V5 Sendmail.✨
- Sisimai::Lhost::Verizon(3pm)bounce mail decoder class for Verizon <https://www.verizon.com/>.✨
- Sisimai::Lhost::X1(3pm)bounce mail decoder class for X1.✨
- Sisimai::Lhost::X2(3pm)bounce mail decoder class for X2.✨
- Sisimai::Lhost::X3(3pm)bounce mail decoder class for X3.✨
- Sisimai::Lhost::X4(3pm)bounce mail parser class for Unknown MTA which is developed as a "qmail" clone.✨
- Sisimai::Lhost::X5(3pm)bounce mail parser class for unknown MTA #5.✨
- Sisimai::Lhost::X6(3pm)bounce mail decoder class for "X6".✨
- Sisimai::Lhost::Yahoo(3pm)bounce mail parser class for "Yahoo! MAIL".✨
- Sisimai::Lhost::Yandex(3pm)bounce mail parser class for "Yandex.Mail".✨
- Sisimai::Lhost::Zoho(3pm)bounce mail decoder class for Zoho Mail <https://www.zoho.com/mail/>.✨
- Sisimai::Mail(3pm)Handler of Mbox/Maildir for reading each mail.✨
- Sisimai::Mail::Maildir(3pm)Mailbox reader✨
- Sisimai::Mail::Mbox(3pm)Mailbox reader✨
- Sisimai::Mail::Memory(3pm)Mailbox reader✨
- Sisimai::Mail::STDIN(3pm)Mailbox reader✨
- Sisimai::MDA(3pm)Error message parser for MDA✨
- Sisimai::Message(3pm)Converts the bounce email text to the data structure.✨
- Sisimai::MIME(3pm)MIME Utilities✨
- Sisimai::Order(3pm)A Class for making an optimized order list for calling MTA modules in "Sisimai::Lhost::*"✨
- Sisimai::Reason(3pm)Detect the bounce reason✨
- Sisimai::Reason::AuthFailure(3pm)Bounce reason is "authfailure" or not.✨
- Sisimai::Reason::BadReputation(3pm)Bounce reason is "badreputation" or not.✨
- Sisimai::Reason::Blocked(3pm)Bounce reason is "blocked" or not.✨
- Sisimai::Reason::ContentError(3pm)Bounce reason is "contenterror" or not.✨
- Sisimai::Reason::Delivered(3pm)Email delivered successfully✨
- Sisimai::Reason::EmailTooLarge(3pm)Bounce reason is "emailtoolarge" or not.✨
- Sisimai::Reason::ExceedLimit(3pm)Bounce reason is "exceedlimit" or not.✨
- Sisimai::Reason::Expired(3pm)Bounce reason is "expired" or not.✨
- Sisimai::Reason::FailedSTARTTLS(3pm)Bounce reason is "FailedSTARTTLS" or not.✨
- Sisimai::Reason::Feedback(3pm)Email forwarded as a complaint message✨
- Sisimai::Reason::Filtered(3pm)Bounce reason is "filtered" or not.✨
- Sisimai::Reason::HasMoved(3pm)Bounce reason is "hasmoved" or not.✨
- Sisimai::Reason::HostUnknown(3pm)Bounce reason is "hostunknown" or not.✨
- Sisimai::Reason::MailboxFull(3pm)Bounce reason is "mailboxfull" or not.✨
- Sisimai::Reason::MailerError(3pm)Bounce reason is "mailererror" or not.✨
- Sisimai::Reason::MesgTooBig(3pm)Bounce reason is "mesgtoobig" or not.✨
- Sisimai::Reason::NetworkError(3pm)Bounce reason is "networkerror" or not.✨
- Sisimai::Reason::NoRelaying(3pm)Bounce reason is "norelaying" or not.✨
- Sisimai::Reason::NotAccept(3pm)Bounce reason is "notaccept" or not.✨
- Sisimai::Reason::NotCompliantRFC(3pm)Bounce reason is "notcompliantrfc" or not.✨
- Sisimai::Reason::OnHold(3pm)Bounce reason is "onhold" or not.✨
- Sisimai::Reason::PolicyViolation(3pm)Bounce reason is "policyviolation" or not.✨
- Sisimai::Reason::RateLimited(3pm)Bounced due to that too many connections.✨
- Sisimai::Reason::Rejected(3pm)Bounce reason is "rejected" or not.✨
- Sisimai::Reason::RequirePTR(3pm)Bounce reason is "requireptr" or not.✨
- Sisimai::Reason::SecurityError(3pm)Bounce reason is "securityerror" or not.✨
- Sisimai::Reason::SpamDetected(3pm)Bounce reason is "spamdetected" due to Spam content in the message or not.✨
- Sisimai::Reason::Speeding(3pm)Bounce reason is "speeding" or not.✨
- Sisimai::Reason::Suppressed(3pm)Bounce reason is "suppressed" or not.✨
- Sisimai::Reason::Suspend(3pm)Bounce reason is "suspend" or not.✨
- Sisimai::Reason::SyntaxError(3pm)Bounce reason is "syntaxerror" or not.✨
- Sisimai::Reason::SystemError(3pm)Bounce reason is "systemerror" or not.✨
- Sisimai::Reason::SystemFull(3pm)Bounce reason is "systemfull" or not.✨
- Sisimai::Reason::TooManyConn(3pm)Bounced due to that too many connections.✨
- Sisimai::Reason::Undefined(3pm)Sisimai could not detect the error reason.✨
- Sisimai::Reason::UserUnknown(3pm)Bounce reason is "userunknown" or not.✨
- Sisimai::Reason::Vacation(3pm)the recipient is out of the office✨
- Sisimai::Reason::VirusDetected(3pm)Bounce reason is "virusdetected" or not.✨
- Sisimai::RFC1123(3pm)Internet hostname related class✨
- Sisimai::RFC1894(3pm)DSN field defined in RFC3464 (obsoletes RFC1894)✨
- Sisimai::RFC2045(3pm)MIME Utilities✨
- Sisimai::RFC3464(3pm)bounce mail decoder class for a bounce mail which have fields defined in RFC3464✨
- Sisimai::RFC3464::ThirdParty(3pm)bounce mail decoder class for a bounce mail which have fields defined in RFC3464 and some fields begin with "X-"✨
- Sisimai::RFC3834(3pm)RFC3834 auto reply message detector✨
- Sisimai::RFC5322(3pm)Email address related utilities✨
- Sisimai::RFC5965(3pm)A class for An Extensible Format for Email Feedback Reports✨
- Sisimai::RFC791(3pm)IP related class✨
- Sisimai::Rhost(3pm)Detect the bounce reason returned from certain remote hosts.✨
- Sisimai::Rhost::Aol(3pm)Detect the bounce reason returned from Aol Mail: https://www.aol.com✨
- Sisimai::Rhost::Apple(3pm)Detect the bounce reason returned from Apple iCloud Mail✨
- Sisimai::Rhost::Cloudflare(3pm)Detect the bounce reason returned from Cloudflare Email Routing✨
- Sisimai::Rhost::Cox(3pm)Detect the bounce reason returned from Cox✨
- Sisimai::Rhost::ExchangeOnline(3pm)Detect the bounce reason returned from on-premises Exchange 2013 and Office 365.✨
- Sisimai::Rhost::Facebook(3pm)Detect the bounce reason returned from Facebook✨
- Sisimai::Rhost::FrancePTT(3pm)Detect the bounce reason returned from Orange and La Poste.✨
- Sisimai::Rhost::GoDaddy(3pm)Detect the bounce reason returned from GoDaddy.✨
- Sisimai::Rhost::Google(3pm)Detect the bounce reason returned from Google Workspace.✨
- Sisimai::Rhost::GoogleApps(3pm)Detect the bounce reason returned from Google Workspace✨
- Sisimai::Rhost::GSuite(3pm)Detect the bounce reason returned from Google Workspace (formerly G Suite)✨
- Sisimai::Rhost::IUA(3pm)Detect the bounce reason returned from https://www.i.ua/.✨
- Sisimai::Rhost::KDDI(3pm)Detect the bounce reason returned from au (KDDI).✨
- Sisimai::Rhost::MessageLabs(3pm)Detect the bounce reason returned from MessageLabs✨
- Sisimai::Rhost::Microsoft(3pm)Detect the bounce reason returned from on-premises Exchange 2019 or older and Office 365.✨
- Sisimai::Rhost::Mimecast(3pm)Detect the bounce reason returned from Mimecast✨
- Sisimai::Rhost::NTTDOCOMO(3pm)Detect the bounce reason returned from NTT docomo.✨
- Sisimai::Rhost::Outlook(3pm)Detect the bounce reason returned from Microsoft Outlook.com✨
- Sisimai::Rhost::Spectrum(3pm)Detect the bounce reason returned from Spectrum.✨
- Sisimai::Rhost::Tencent(3pm)Detect the bounce reason returned from Tencent.✨
- Sisimai::Rhost::TencentQQ(3pm)Detect the bounce reason returned from Tencent QQ.✨
- Sisimai::Rhost::YahooInc(3pm)Detect the bounce reason returned from Yahoo Inc.✨
- Sisimai::Rhost::Zoho(3pm)Detect the bounce reason returned from Zoho Mail✨
- Sisimai::SMTP(3pm)SMTP Status Codes related utilities✨
- Sisimai::SMTP::Command(3pm)SMTP Command related utilities✨
- Sisimai::SMTP::Error(3pm)SMTP Errors related utilities✨
- Sisimai::SMTP::Failure(3pm)SMTP Errors related utilities✨
- Sisimai::SMTP::Reply(3pm)SMTP reply code related class✨
- Sisimai::SMTP::Status(3pm)SMTP Enhanced Status Codes related utilities✨
- Sisimai::SMTP::Transcript(3pm)Transcript of the SMTP session decoder✨
- Sisimai::String(3pm)String related class✨
- Sisimai::Time(3pm)Child class of "Time::Piece" for "Sisimai::Fact"✨
- Slurm(3pm)Perl API for libslurm✨
- Slurm::Bitstr(3pm)Bitstring functions in libslurm✨
- Slurm::Constant(3pm)Constants for use with Slurm✨
- Slurm::Hostlist(3pm)Hostlist functions in libslurm✨
- Slurmdb(3pm)Perl extension for slurmdb library✨
- Smart::Comments(3pm)Comments that do more than just sit there✨
- smartmatch(3pm)pluggable smart matching backends✨
- SMIME(3pm)S/MIME message signing, verification, encryption and decryption✨
- SMIME::JA(3pm)S/MIMEの署名、検証、暗号化、復号✨
- SMS::AQL(3pm)Perl extension to send SMS text messages via AQL's SMS service✨
- SMS::Send(3pm)Driver-based API for sending SMS messages✨
- SMS::Send::AQL(3pm)SMS::Send driver to send messages via AQL (www.aql.com)✨
- SMS::Send::AU::Test(3pm)SMS::Send Regional-Class Testing Driver✨
- SMS::Send::Driver(3pm)Base class for SMS::Send drivers✨
- SMS::Send::Test(3pm)SMS::Send International-Class Testing Driver✨
- SNMP(3pm)The Perl5 'SNMP' Extension Module for the Net-SNMP SNMP package.✨
- SNMP::Extension::PassPersist(3pm)Generic pass/pass_persist extension framework for Net-SNMP✨
- SNMP::Info(3pm)OO Interface to Network devices and MIBs through SNMP✨
- SNMP::Info::AdslLine(3pm)SNMP Interface to the ADSL-LINE-MIB✨
- SNMP::Info::Aggregate(3pm)SNMP Interface to ifStackTable Aggregated Links✨
- SNMP::Info::Airespace(3pm)SNMP Interface to data from AIRESPACE-WIRELESS-MIB and AIRESPACE-SWITCHING-MIB✨
- SNMP::Info::AMAP(3pm)SNMP Interface to Alcatel Mapping Adjacency Protocol (AMAP)✨
- SNMP::Info::Bridge(3pm)SNMP Interface to SNMP data available through the BRIDGE-MIB (RFC1493)✨
- SNMP::Info::CDP(3pm)SNMP Interface to Cisco Discovery Protocol (CDP) using SNMP✨
- SNMP::Info::CiscoAgg(3pm)SNMP Interface to Cisco Aggregated Links✨
- SNMP::Info::CiscoBGP(3pm)SNMP Interface to Cisco's BGP MIBs✨
- SNMP::Info::CiscoConfig(3pm)SNMP Interface to Cisco Configuration Files✨
- SNMP::Info::CiscoPortSecurity(3pm)SNMP Interface to data from CISCO-PORT-SECURITY-MIB, CISCO-PAE-MIB and CISCO-ERR-DISABLE-MIB.✨
- SNMP::Info::CiscoPower(3pm)SNMP Interface to data stored in CISCO-POWER-ETHERNET-EXT-MIB.✨
- SNMP::Info::CiscoQOS(3pm)SNMP Interface to Cisco's Quality of Service MIBs✨
- SNMP::Info::CiscoRTT(3pm)SNMP Interface to Cisco's Round Trip Time MIBs✨
- SNMP::Info::CiscoStack(3pm)SNMP Interface to data from CISCO-STACK-MIB✨
- SNMP::Info::CiscoStats(3pm)Perl5 Interface to CPU and Memory stats for Cisco Devices✨
- SNMP::Info::CiscoStpExtensions(3pm)SNMP Interface to "CISCO-STP-EXTENSIONS-MIB"✨
- SNMP::Info::CiscoVTP(3pm)SNMP Interface to Cisco's VLAN Management MIBs✨
- SNMP::Info::DocsisCM(3pm)SNMP Interface for DOCSIS Cable Modems✨
- SNMP::Info::DocsisHE(3pm)SNMP Interface for DOCS-IF-MIB and DOCS-IF3-MIB✨
- SNMP::Info::EDP(3pm)SNMP Interface to the Extreme Discovery Protocol (EDP)✨
- SNMP::Info::Entity(3pm)SNMP Interface to data stored in ENTITY-MIB. RFC 2737✨
- SNMP::Info::EtherLike(3pm)SNMP Interface to SNMP ETHERLIKE-MIB RFC 1398✨
- SNMP::Info::FDP(3pm)SNMP Interface to Foundry Discovery Protocol (FDP) using SNMP✨
- SNMP::Info::IEEE802_Bridge(3pm)SNMP Interface to SNMP data available through the IEEE8021-Q-BRIDGE-MIB✨
- SNMP::Info::IEEE802dot11(3pm)SNMP Interface to data from IEEE802dot11-MIB✨
- SNMP::Info::IEEE802dot3ad(3pm)SNMP Interface to IEEE Aggregated Links✨
- SNMP::Info::IPv6(3pm)SNMP Interface for obtaining IPv6 addresses and IPv6 address mappings✨
- SNMP::Info::Layer1(3pm)SNMP Interface to network devices serving Layer1 only.✨
- SNMP::Info::Layer1::Allied(3pm)SNMP Interface to old Allied Hubs✨
- SNMP::Info::Layer1::Asante(3pm)SNMP Interface to old Asante 1012 Hubs✨
- SNMP::Info::Layer1::Bayhub(3pm)SNMP Interface to Bay/Nortel/Avaya Hubs✨
- SNMP::Info::Layer1::Cyclades(3pm)SNMP Interface to Cyclades/Avocent terminal servers✨
- SNMP::Info::Layer1::S3000(3pm)SNMP Interface to Synoptics / Nortel Hubs✨
💅
getting it ready, bestie…