section 3 · Library functions 📚
178720 pages · page 677 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
S (continued)
- Sisimai::Lhost::SendGrid(3pm)bounce mail parser class for "SendGrid".✨
- Sisimai::Lhost::Sendmail(3pm)bounce mail decoder class for Sendmail Open Source <https://sendmail.org/>.✨
- Sisimai::Lhost::SurfControl(3pm)bounce mail parser class for "SurfControl".✨
- Sisimai::Lhost::TrendMicro(3pm)bounce mail decoder class for TREND VISION ONE: Email and Collaboration Security <https://www.trendmicro.com/en_us/business/products/email-and-collaboration.html>.✨
- Sisimai::Lhost::V5sendmail(3pm)bounce mail decoder class for V5 Sendmail.✨
- Sisimai::Lhost::Verizon(3pm)bounce mail decoder class for Verizon <https://www.verizon.com/>.✨
- Sisimai::Lhost::X1(3pm)bounce mail decoder class for X1.✨
- Sisimai::Lhost::X2(3pm)bounce mail decoder class for X2.✨
- Sisimai::Lhost::X3(3pm)bounce mail decoder class for X3.✨
- Sisimai::Lhost::X4(3pm)bounce mail parser class for Unknown MTA which is developed as a "qmail" clone.✨
- Sisimai::Lhost::X5(3pm)bounce mail parser class for unknown MTA #5.✨
- Sisimai::Lhost::X6(3pm)bounce mail decoder class for "X6".✨
- Sisimai::Lhost::Yahoo(3pm)bounce mail parser class for "Yahoo! MAIL".✨
- Sisimai::Lhost::Yandex(3pm)bounce mail parser class for "Yandex.Mail".✨
- Sisimai::Lhost::Zoho(3pm)bounce mail decoder class for Zoho Mail <https://www.zoho.com/mail/>.✨
- Sisimai::Mail(3pm)Handler of Mbox/Maildir for reading each mail.✨
- Sisimai::Mail::Maildir(3pm)Mailbox reader✨
- Sisimai::Mail::Mbox(3pm)Mailbox reader✨
- Sisimai::Mail::Memory(3pm)Mailbox reader✨
- Sisimai::Mail::STDIN(3pm)Mailbox reader✨
- Sisimai::MDA(3pm)Error message parser for MDA✨
- Sisimai::Message(3pm)Converts the bounce email text to the data structure.✨
- Sisimai::MIME(3pm)MIME Utilities✨
- Sisimai::Order(3pm)A Class for making an optimized order list for calling MTA modules in "Sisimai::Lhost::*"✨
- Sisimai::Reason(3pm)Detect the bounce reason✨
- Sisimai::Reason::AuthFailure(3pm)Bounce reason is "authfailure" or not.✨
- Sisimai::Reason::BadReputation(3pm)Bounce reason is "badreputation" or not.✨
- Sisimai::Reason::Blocked(3pm)Bounce reason is "blocked" or not.✨
- Sisimai::Reason::ContentError(3pm)Bounce reason is "contenterror" or not.✨
- Sisimai::Reason::Delivered(3pm)Email delivered successfully✨
- Sisimai::Reason::EmailTooLarge(3pm)Bounce reason is "emailtoolarge" or not.✨
- Sisimai::Reason::ExceedLimit(3pm)Bounce reason is "exceedlimit" or not.✨
- Sisimai::Reason::Expired(3pm)Bounce reason is "expired" or not.✨
- Sisimai::Reason::FailedSTARTTLS(3pm)Bounce reason is "FailedSTARTTLS" or not.✨
- Sisimai::Reason::Feedback(3pm)Email forwarded as a complaint message✨
- Sisimai::Reason::Filtered(3pm)Bounce reason is "filtered" or not.✨
- Sisimai::Reason::HasMoved(3pm)Bounce reason is "hasmoved" or not.✨
- Sisimai::Reason::HostUnknown(3pm)Bounce reason is "hostunknown" or not.✨
- Sisimai::Reason::MailboxFull(3pm)Bounce reason is "mailboxfull" or not.✨
- Sisimai::Reason::MailerError(3pm)Bounce reason is "mailererror" or not.✨
- Sisimai::Reason::MesgTooBig(3pm)Bounce reason is "mesgtoobig" or not.✨
- Sisimai::Reason::NetworkError(3pm)Bounce reason is "networkerror" or not.✨
- Sisimai::Reason::NoRelaying(3pm)Bounce reason is "norelaying" or not.✨
- Sisimai::Reason::NotAccept(3pm)Bounce reason is "notaccept" or not.✨
- Sisimai::Reason::NotCompliantRFC(3pm)Bounce reason is "notcompliantrfc" or not.✨
- Sisimai::Reason::OnHold(3pm)Bounce reason is "onhold" or not.✨
- Sisimai::Reason::PolicyViolation(3pm)Bounce reason is "policyviolation" or not.✨
- Sisimai::Reason::RateLimited(3pm)Bounced due to that too many connections.✨
- Sisimai::Reason::Rejected(3pm)Bounce reason is "rejected" or not.✨
- Sisimai::Reason::RequirePTR(3pm)Bounce reason is "requireptr" or not.✨
- Sisimai::Reason::SecurityError(3pm)Bounce reason is "securityerror" or not.✨
- Sisimai::Reason::SpamDetected(3pm)Bounce reason is "spamdetected" due to Spam content in the message or not.✨
- Sisimai::Reason::Speeding(3pm)Bounce reason is "speeding" or not.✨
- Sisimai::Reason::Suppressed(3pm)Bounce reason is "suppressed" or not.✨
- Sisimai::Reason::Suspend(3pm)Bounce reason is "suspend" or not.✨
- Sisimai::Reason::SyntaxError(3pm)Bounce reason is "syntaxerror" or not.✨
- Sisimai::Reason::SystemError(3pm)Bounce reason is "systemerror" or not.✨
- Sisimai::Reason::SystemFull(3pm)Bounce reason is "systemfull" or not.✨
- Sisimai::Reason::TooManyConn(3pm)Bounced due to that too many connections.✨
- Sisimai::Reason::Undefined(3pm)Sisimai could not detect the error reason.✨
- Sisimai::Reason::UserUnknown(3pm)Bounce reason is "userunknown" or not.✨
- Sisimai::Reason::Vacation(3pm)the recipient is out of the office✨
- Sisimai::Reason::VirusDetected(3pm)Bounce reason is "virusdetected" or not.✨
- Sisimai::RFC1123(3pm)Internet hostname related class✨
- Sisimai::RFC1894(3pm)DSN field defined in RFC3464 (obsoletes RFC1894)✨
- Sisimai::RFC2045(3pm)MIME Utilities✨
- Sisimai::RFC3464(3pm)bounce mail decoder class for a bounce mail which have fields defined in RFC3464✨
- Sisimai::RFC3464::ThirdParty(3pm)bounce mail decoder class for a bounce mail which have fields defined in RFC3464 and some fields begin with "X-"✨
- Sisimai::RFC3834(3pm)RFC3834 auto reply message detector✨
- Sisimai::RFC5322(3pm)Email address related utilities✨
- Sisimai::RFC5965(3pm)A class for An Extensible Format for Email Feedback Reports✨
- Sisimai::RFC791(3pm)IP related class✨
- Sisimai::Rhost(3pm)Detect the bounce reason returned from certain remote hosts.✨
- Sisimai::Rhost::Aol(3pm)Detect the bounce reason returned from Aol Mail: https://www.aol.com✨
- Sisimai::Rhost::Apple(3pm)Detect the bounce reason returned from Apple iCloud Mail✨
- Sisimai::Rhost::Cloudflare(3pm)Detect the bounce reason returned from Cloudflare Email Routing✨
- Sisimai::Rhost::Cox(3pm)Detect the bounce reason returned from Cox✨
- Sisimai::Rhost::ExchangeOnline(3pm)Detect the bounce reason returned from on-premises Exchange 2013 and Office 365.✨
- Sisimai::Rhost::Facebook(3pm)Detect the bounce reason returned from Facebook✨
- Sisimai::Rhost::FrancePTT(3pm)Detect the bounce reason returned from Orange and La Poste.✨
- Sisimai::Rhost::GoDaddy(3pm)Detect the bounce reason returned from GoDaddy.✨
- Sisimai::Rhost::Google(3pm)Detect the bounce reason returned from Google Workspace.✨
- Sisimai::Rhost::GoogleApps(3pm)Detect the bounce reason returned from Google Workspace✨
- Sisimai::Rhost::GSuite(3pm)Detect the bounce reason returned from Google Workspace (formerly G Suite)✨
- Sisimai::Rhost::IUA(3pm)Detect the bounce reason returned from https://www.i.ua/.✨
- Sisimai::Rhost::KDDI(3pm)Detect the bounce reason returned from au (KDDI).✨
- Sisimai::Rhost::MessageLabs(3pm)Detect the bounce reason returned from MessageLabs✨
- Sisimai::Rhost::Microsoft(3pm)Detect the bounce reason returned from on-premises Exchange 2019 or older and Office 365.✨
- Sisimai::Rhost::Mimecast(3pm)Detect the bounce reason returned from Mimecast✨
- Sisimai::Rhost::NTTDOCOMO(3pm)Detect the bounce reason returned from NTT docomo.✨
- Sisimai::Rhost::Outlook(3pm)Detect the bounce reason returned from Microsoft Outlook.com✨
- Sisimai::Rhost::Spectrum(3pm)Detect the bounce reason returned from Spectrum.✨
- Sisimai::Rhost::Tencent(3pm)Detect the bounce reason returned from Tencent.✨
- Sisimai::Rhost::TencentQQ(3pm)Detect the bounce reason returned from Tencent QQ.✨
- Sisimai::Rhost::YahooInc(3pm)Detect the bounce reason returned from Yahoo Inc.✨
- Sisimai::Rhost::Zoho(3pm)Detect the bounce reason returned from Zoho Mail✨
- Sisimai::SMTP(3pm)SMTP Status Codes related utilities✨
- Sisimai::SMTP::Command(3pm)SMTP Command related utilities✨
- Sisimai::SMTP::Error(3pm)SMTP Errors related utilities✨
- Sisimai::SMTP::Failure(3pm)SMTP Errors related utilities✨
- Sisimai::SMTP::Reply(3pm)SMTP reply code related class✨
- Sisimai::SMTP::Status(3pm)SMTP Enhanced Status Codes related utilities✨
- Sisimai::SMTP::Transcript(3pm)Transcript of the SMTP session decoder✨
- Sisimai::String(3pm)String related class✨
- Sisimai::Time(3pm)Child class of "Time::Piece" for "Sisimai::Fact"✨
- sismember(3valkey)Determines whether a member belongs to a set.✨
- SISNAN(3)✨
- sisnan(3)✨
- sisnan.f(3)✨
- size(3)✨
- size_and_time(3)Progress Info for streaming read.✨
- SIZE_MAX(3)✨
- SIZE_MAX(3avr)<stdint.h>: Standard Integer Types✨
- size_t(3)overview of system data types✨
- size_t(3type)count of bytes✨
- sk(3)✨
- sk_delete(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_delete_ptr(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_dup(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_find(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_free(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_insert(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_is_sorted(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_new(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_new_null(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_new_session(3)create a new SNMPSESSION✨
- sk_num(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_pop(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_pop_free(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_push(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_set(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_set_cmp_func(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_shift(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_sort(3ssl)variable-sized arrays of void pointers, called OpenSSL stacks✨
- sk_TYPE_deep_copy(3)stack container✨
- sk_TYPE_deep_copy(33ssl)stack container✨
- sk_TYPE_deep_copy(3ossl)stack container✨
- sk_TYPE_deep_copy(3ssl)stack container✨
- sk_TYPE_delete(3)stack container✨
- sk_TYPE_delete(33ssl)stack container✨
- sk_TYPE_delete(3ossl)stack container✨
- sk_TYPE_delete(3ssl)stack container✨
- sk_TYPE_delete_ptr(3)stack container✨
- sk_TYPE_delete_ptr(33ssl)stack container✨
- sk_TYPE_delete_ptr(3ossl)stack container✨
- sk_TYPE_delete_ptr(3ssl)stack container✨
- sk_TYPE_dup(3)stack container✨
- sk_TYPE_dup(33ssl)stack container✨
- sk_TYPE_dup(3ossl)stack container✨
- sk_TYPE_dup(3ssl)stack container✨
- sk_TYPE_find(3)stack container✨
- sk_TYPE_find(33ssl)stack container✨
- sk_TYPE_find(3ossl)stack container✨
- sk_TYPE_find(3ssl)stack container✨
- sk_TYPE_find_all(3)stack container✨
- sk_TYPE_find_all(33ssl)stack container✨
- sk_TYPE_find_all(3ossl)stack container✨
- sk_TYPE_find_all(3ssl)stack container✨
- sk_TYPE_find_ex(3)stack container✨
- sk_TYPE_find_ex(33ssl)stack container✨
- sk_TYPE_find_ex(3ossl)stack container✨
- sk_TYPE_find_ex(3ssl)stack container✨
- sk_TYPE_free(3)stack container✨
- sk_TYPE_free(33ssl)stack container✨
- sk_TYPE_free(3ossl)stack container✨
- sk_TYPE_free(3ssl)stack container✨
- sk_TYPE_insert(3)stack container✨
- sk_TYPE_insert(33ssl)stack container✨
- sk_TYPE_insert(3ossl)stack container✨
- sk_TYPE_insert(3ssl)stack container✨
- sk_TYPE_is_sorted(3)stack container✨
- sk_TYPE_is_sorted(33ssl)stack container✨
- sk_TYPE_is_sorted(3ossl)stack container✨
- sk_TYPE_is_sorted(3ssl)stack container✨
- sk_TYPE_new(3)stack container✨
- sk_TYPE_new(33ssl)stack container✨
- sk_TYPE_new(3ossl)stack container✨
- sk_TYPE_new(3ssl)stack container✨
- sk_TYPE_new_null(3)stack container✨
- sk_TYPE_new_null(33ssl)stack container✨
- sk_TYPE_new_null(3ossl)stack container✨
- sk_TYPE_new_null(3ssl)stack container✨
- sk_TYPE_new_reserve(3)stack container✨
- sk_TYPE_new_reserve(33ssl)stack container✨
- sk_TYPE_new_reserve(3ossl)stack container✨
- sk_TYPE_new_reserve(3ssl)stack container✨
- sk_TYPE_num(3)stack container✨
- sk_TYPE_num(33ssl)stack container✨
- sk_TYPE_num(3ossl)stack container✨
- sk_TYPE_num(3ssl)stack container✨
- sk_TYPE_pop(3)stack container✨
- sk_TYPE_pop(33ssl)stack container✨
- sk_TYPE_pop(3ossl)stack container✨
- sk_TYPE_pop(3ssl)stack container✨
- sk_TYPE_pop_free(3)stack container✨
- sk_TYPE_pop_free(33ssl)stack container✨
- sk_TYPE_pop_free(3ossl)stack container✨
- sk_TYPE_pop_free(3ssl)stack container✨
- sk_TYPE_push(3)stack container✨
- sk_TYPE_push(33ssl)stack container✨
💅
getting it ready, bestie…