section 3 · Library functions 📚
178720 pages · page 318 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
I (continued)
- IO::Handle::Prototype::Fallback(3pm)Create IO::Handle like objects using a set of callbacks.✨
- IO::Handle::Util(3pm)Functions for working with IO::Handle like objects.✨
- IO::HTML(3pm)Open an HTML file with automatic charset detection✨
- IO::InnerFile(3pm)define a file inside another file✨
- IO::InSitu(3pm)Avoid clobbering files opened for both input and output✨
- IO::Interactive(3pm)Utilities for interactive I/O✨
- IO::Interactive::Tiny(3pm)is_interactive() without large deps✨
- IO::Interface(3pm)Perl extension for access to network card configuration information✨
- IO::Interface::Simple(3pm)Perl extension for access to network card configuration information✨
- IO::Lambda(3pm)non-blocking I/O as lambda calculus✨
- IO::Lambda::Backtrace(3pm)backtrace chains of events✨
- IO::Lambda::DBI(3pm)asynchronous DBI✨
- IO::Lambda::DNS(3pm)DNS queries lambda style✨
- IO::Lambda::Flock(3pm)lambda-style file locking✨
- IO::Lambda::Fork(3pm)wait for blocking code in children processes✨
- IO::Lambda::HTTP(3pm)http requests lambda style✨
- IO::Lambda::HTTP::Authen::NTLM(3pm)library for enabling NTLM authentication in IO::Lambda::HTTP✨
- IO::Lambda::HTTP::Client(3pm)http requests lambda style✨
- IO::Lambda::HTTP::HTTPS(3pm)https requests lambda style✨
- IO::Lambda::HTTP::Server(3pm)simple httpd server✨
- IO::Lambda::HTTP::UserAgent(3pm)common properties for http requests✨
- IO::Lambda::Loop::AnyEvent(3pm)AnyEvent event loop for IO::Lambda✨
- IO::Lambda::Loop::Glib(3pm)Glib event loop for IO::Lambda✨
- IO::Lambda::Loop::POE(3pm)POE event loop for IO::Lambda✨
- IO::Lambda::Loop::Prima(3pm)Prima-based event loop for IO::Lambda✨
- IO::Lambda::Loop::Select(3pm)select(2)-based event loop for IO::Lambda✨
- IO::Lambda::Message(3pm)message passing queue✨
- IO::Lambda::Mutex(3pm)wait for a shared resource✨
- IO::Lambda::Poll(3pm)emulate asynchronous behavior by polling✨
- IO::Lambda::Signal(3pm)wait for pids and signals✨
- IO::Lambda::SNMP(3pm)snmp requests lambda style✨
- IO::Lambda::Socket(3pm)wrapper condition for socket functions✨
- IO::Lambda::Thread(3pm)wait for blocking code using threads✨
- IO::Lambda::Throttle(3pm)rate-limiting facility✨
- IO::LCDproc(3pm)Perl extension to connect to an LCDproc ready display.✨
- IO::Lines(3pm)IO:: interface for reading/writing an array of lines✨
- IO::LockedFile(3pm)supply object methods for locking files✨
- IO::LockedFile::Flock(3pm)implements the IO::LockedFile class for the Flock scheme.✨
- IO::Multiplex(3pm)Manage IO on many file handles✨
- IO::Null(3pm)class for null filehandles✨
- IO::Pager(3pm)Select a pager (possibly perl-based) & pipe it text if a TTY✨
- IO::Pager::Buffered(3pm)Pipe deferred output to PAGER if destination is a TTY✨
- IO::Pager::less(3pm)No pager? Pipe output to Perl-based pager a TTY✨
- IO::Pager::Page(3pm)Emulate IO::Page, pipe STDOUT to a pager if STDOUT is a TTY✨
- IO::Pager::Perl(3pm)Page text a screenful at a time, like more or less✨
- IO::Pager::Unbuffered(3pm)Pipe output to PAGER if destination is a TTY✨
- IO::Pipe(3perl)supply object methods for pipes✨
- IO::Pipe(3pm)supply object methods for pipes✨
- IO::Pipely(3pm)Portably create pipe() or pipe-like handles, one way or another.✨
- IO::Poll(3perl)Object interface to system poll call✨
- IO::Poll(3pm)Object interface to system poll call✨
- IO::Prompt(3pm)Interactively prompt for user input✨
- IO::Prompt::Tiny(3pm)Prompt for user input with a default option✨
- IO::Prompter(3pm)Prompt for input, read it, clean it, return it.✨
- IO::Pty(3pm)Pseudo TTY object class✨
- IO::Pty::Easy(3pm)Easy interface to IO::Pty✨
- IO::Scalar(3pm)IO:: interface for reading/writing a scalar✨
- IO::ScalarArray(3pm)IO:: interface for reading/writing an array of scalars✨
- IO::Seekable(3perl)supply seek based methods for I/O objects✨
- IO::Seekable(3pm)supply seek based methods for I/O objects✨
- IO::Select(3perl)OO interface to the "select" system call✨
- IO::Select(3pm)OO interface to the "select" system call✨
- IO::Socket(3perl)Object interface to socket communications✨
- IO::Socket(3pm)Object interface to socket communications✨
- IO::Socket::INET(3perl)Object interface for AF_INET domain sockets✨
- IO::Socket::INET(3pm)Object interface for AF_INET domain sockets✨
- IO::Socket::INET6(3pm)[ DEPRECATED!! ] Object interface for AF_INET/AF_INET6 domain sockets✨
- IO::Socket::IP(3perl)Family-neutral IP socket supporting both IPv4 and IPv6✨
- IO::Socket::IP(3pm)Family-neutral IP socket supporting both IPv4 and IPv6✨
- IO::Socket::Multicast(3pm)Send and receive multicast messages✨
- IO::Socket::Netlink(3pm)Object interface to "PF_NETLINK" domain sockets✨
- IO::Socket::Netlink::Generic(3pm)Object interface to "NETLINK_GENERIC" netlink protocol sockets✨
- IO::Socket::Netlink::Route(3pm)Object interface to "NETLINK_ROUTE" netlink protocol sockets✨
- IO::Socket::PortState(3pm)Perl extension for checking the open or closed status of a port.✨
- IO::Socket::Socks(3pm)Provides a way to create socks client or server both 4 and 5 version.✨
- IO::Socket::SSL(3pm)SSL sockets with IO::Socket interface✨
- IO::Socket::SSL::Intercept(3pm)SSL interception (man in the middle)✨
- IO::Socket::SSL::PublicSuffix(3pm)provide access to Mozilla's list of effective TLD names✨
- IO::Socket::SSL::Utils(3pm)loading, storing, creating certificates and keys✨
- IO::Socket::Timeout(3pm)IO::Socket with read/write timeout✨
- IO::Socket::UNIX(3perl)Object interface for AF_UNIX domain sockets✨
- IO::Socket::UNIX(3pm)Object interface for AF_UNIX domain sockets✨
- IO::Stream(3pm)ease non-blocking I/O streams based on EV✨
- IO::String(3pm)Emulate file interface for in-core strings✨
- IO::Stringy(3pm)I/O on in-core objects like strings and arrays✨
- IO::Stty(3pm)Change and print terminal line settings✨
- IO::Tee(3pm)Multiplex output to multiple output handles✨
- IO::Termios(3pm)supply termios(3) methods to "IO::Handle" objects✨
- IO::TieCombine(3pm)produce tied (and other) separate but combined variables✨
- IO::TieCombine::Handle(3pm)tied filehandles for IO::TieCombine✨
- IO::TieCombine::Scalar(3pm)tied scalars for IO::TieCombine✨
- IO::Tty(3pm)Low-level allocate a pseudo-Tty, import constants.✨
- IO::Tty::Constant(3pm)Terminal Constants (autogenerated)✨
- IO::Uncompress::AnyInflate(3perl)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyInflate(3pm)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyInflate(3pmc)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyUncompress(3perl)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::AnyUncompress(3pm)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::AnyUncompress(3pmc)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::Base(3perl)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Base(3pm)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Base(3pmc)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Brotli(3pm)Read Brotli buffers/streams✨
- IO::Uncompress::Bunzip2(3perl)Read bzip2 files/buffers✨
- IO::Uncompress::Bunzip2(3pm)Read bzip2 files/buffers✨
- IO::Uncompress::Bunzip2(3pmc)Read bzip2 files/buffers✨
- IO::Uncompress::Gunzip(3perl)Read RFC 1952 files/buffers✨
- IO::Uncompress::Gunzip(3pm)Read RFC 1952 files/buffers✨
- IO::Uncompress::Gunzip(3pmc)Read RFC 1952 files/buffers✨
- IO::Uncompress::Inflate(3perl)Read RFC 1950 files/buffers✨
- IO::Uncompress::Inflate(3pm)Read RFC 1950 files/buffers✨
- IO::Uncompress::Inflate(3pmc)Read RFC 1950 files/buffers✨
- IO::Uncompress::RawInflate(3perl)Read RFC 1951 files/buffers✨
- IO::Uncompress::RawInflate(3pm)Read RFC 1951 files/buffers✨
- IO::Uncompress::RawInflate(3pmc)Read RFC 1951 files/buffers✨
- IO::Uncompress::UnLzip(3pm)Read lzip files/buffers✨
- IO::Uncompress::UnLzma(3pm)Read lzma files/buffers✨
- IO::Uncompress::UnXz(3pm)Read xz files/buffers✨
- IO::Uncompress::Unzip(3perl)Read zip files/buffers✨
- IO::Uncompress::Unzip(3pm)Read zip files/buffers✨
- IO::Uncompress::Unzip(3pmc)Read zip files/buffers✨
- IO::Uncompress::UnZstd(3pm)Read zstd files/buffers✨
- IO::Wrap(3pm)Wrap raw filehandles in the IO::Handle interface✨
- IO::WrapTie(3pm)wrap tieable objects in IO::Handle interface✨
- IO::Zlib(3perl)IO:: style interface to Compress::Zlib✨
- IO::Zlib(3pm)IO:: style interface to Compress::Zlib✨
- io_ansi(3)Controlling the terminal using virtual terminal sequences (aka [ANSI escape codes]).✨
- io_appendfile(3)open a file for appending✨
- io_block(3)switch to blocking I/O✨
- io_cancel(3)Cancel io requests✨
- io_canread(3)return a file descriptor that can be read from✨
- io_canwrite(3)return a file descriptor that can be written to✨
- io_check(3)check for new readable or writable descriptors✨
- io_close(3)close a file descriptor✨
- io_closeonexec(3)mark a file descriptor non-inheritable✨
- io_createfile(3)create a file✨
- io_destroy(3)destroy an asynchronous I/O context✨
- io_dontwantread(3)signal that you do not want to read from a descriptor✨
- io_dontwantwrite(3)signal that you do not want to write to a descriptor✨
- io_eagain(3)tell io_wait that you got an EAGAIN✨
- io_fd(3)prepare descriptor for io_wait✨
- io_fd_canwrite(3)prepare descriptor for io_wait✨
- io_fd_flags(3)prepare descriptor for io_wait✨
- io_finishandshutdown(3)deallocate internal data structures✨
- io_fsync(3)Synchronize a file's complete in-core state with that on disk✨
- io_getcookie(3)retrieve cookie✨
- io_getevents(3)Read resulting events from io requests✨
- io_layout(3)✨
- io_lib(3)I/O library functions.✨
- io_lib(3erl)I/O library functions.✨
- io_nonblock(3)switch to non-blocking I/O✨
- io_passfd(3)pass a file descriptor over a Unix Domain socket✨
- io_pipe(3)create a Unix pipe✨
- io_prep_fsync(3)Synchronize a file's complete in-core state with that on disk✨
- io_prep_pread(3)Set up asynchronous read✨
- io_prep_pwrite(3)Set up iocb for asynchronous writes✨
- io_queue_init(3)Initialize asynchronous io state machine✨
- io_queue_release(3)Release the context associated with the userspace handle✨
- io_queue_run(3)Handle completed io requests✨
- io_queue_wait(3)Wait for io requests to complete✨
- io_readfile(3)open a file for reading✨
- io_readwritefile(3)open a file for reading and writing✨
- io_receivefd(3)receive a file descriptor over a Unix Domain socket✨
- io_sendfile(3)send data from a file to a socket✨
- io_set_callback(3)Set up io completion callback function✨
- io_setcookie(3)associate cookie with descriptor✨
- io_setup(3)create an asynchronous I/O context✨
- io_socketpair(3)create a pair of sockets✨
- io_submit(3)Submit io requests✨
- io_timeout(3)set time limit on descriptor✨
- io_timeouted(3)return a file descriptor over deadline✨
- io_tryread(3)read from a descriptor without blocking✨
- io_tryreadtimeout(3)read from a descriptor without blocking✨
- io_trywrite(3)write to a descriptor without blocking✨
- io_trywritetimeout(3)write to a descriptor without blocking✨
- io_uring_buf_ring_add(3)add buffers to a shared buffer ring✨
- io_uring_buf_ring_advance(3)advance index of provided buffer in buffer ring✨
- io_uring_buf_ring_available(3)return number of unconsumed provided ring buffer entries✨
- io_uring_buf_ring_cq_advance(3)advance index of provided buffer and CQ ring✨
- io_uring_buf_ring_init(3)Initialise a buffer ring✨
- io_uring_buf_ring_mask(3)Calculate buffer ring mask size✨
- IO_URING_CHECK_VERSION(3)functions and macros to check the liburing version✨
- io_uring_check_version(3)functions and macros to check the liburing version✨
- io_uring_clone_buffers(3)Clones registered buffers between rings✨
- io_uring_clone_buffers_offset(3)Clones registered buffers between rings✨
- io_uring_close_ring_fd(3)close a ring file descriptor and use it only via registered index✨
- io_uring_cq_advance(3)mark one or more io_uring completion events as consumed✨
- io_uring_cq_eventfd_enabled(3)check if eventfd notifications are enabled✨
- io_uring_cq_eventfd_toggle(3)toggle eventfd notifications on or off✨
- io_uring_cq_has_overflow(3)returns if there are overflow entries waiting to move to the CQ ring✨
- io_uring_cq_ready(3)returns number of unconsumed ready entries in the CQ ring✨
- io_uring_cqe_get_data(3)get user data for completion event✨
- io_uring_cqe_get_data64(3)get user data for completion event✨
- io_uring_cqe_nr(3)return the number of CQ ring slots consumed by a CQE✨
- io_uring_cqe_seen(3)mark io_uring completion event as consumed✨
- io_uring_enable_rings(3)enable a disabled ring✨
- io_uring_for_each_cqe(3)iterate pending completion events✨
- io_uring_free_buf_ring(3)register and free a buffer ring for provided buffers✨
- io_uring_free_probe(3)free probe instance✨
- io_uring_free_reg_wait(3)Frees a previously registered wait region✨
💅
getting it ready, bestie…