section 3 · Library functions 📚
178720 pages · page 317 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
I (continued)
- integrate(3rheolef)expression integration (rheolef-7.2)✨
- integrate_option(3rheolef)expression integration options (rheolef-7.2)✨
- intel_security_metee(3)C++ class to access CSE/CSME/GSC firmware via a mei interface.✨
- intel_security_metee_exception(3)✨
- Interactor(3I)base class for interactive objects✨
- interceptors(3erl)Describe the functions which must be exported by any supplied Orber native interceptor.✨
- Interface::TNC::IMC(3pm)Perl extension for blah blah blah✨
- Interface::TNC::IMV(3pm)Perl extension for blah blah blah✨
- internal_rng(3)✨
- internal_v_smechname(3)Internal names and mechanism names✨
- internals(3)The libmtp internals API.✨
- Internals(3perl)Reserved special namespace for internals related functions✨
- Internals(3pm)Reserved special namespace for internals related functions✨
- internalvsmechname(3)Internal names and mechanism names✨
- interp(3tcl)Create and manipulate Tcl interpreters✨
- interp_opt(3)Header file for NCEPLIBS-g2c library.✨
- interpolate(3rheolef)function or expression interpolation (rheolef-7.2)✨
- interpolate(3tcl)Interpolation routines✨
- interpolateAtCentroid(3G)sample a varying at the centroid of a pixel✨
- interpolateAtOffset(3G)sample a varying at specified offset from the center of a pixel✨
- interpolateAtSample(3G)sample a varying at the location of a specified sample✨
- INTERRUPT(3)✨
- INTERRUPT(3avr)<compat/deprecated.h>: Deprecated items✨
- interrupt.h(3)✨
- interrupt.h(3avr)✨
- intersectbddnode(3)tests for an intersection between two bdd nodes.✨
- intersectbddnode(3alc)tests for an intersection between two bdd nodes.✨
- intersection_overview(3coin2)Intersection Detection See the documentation for the SoIntersectionDetectionAction class for example code on how to do intersection detection in a Coin scene. See also SoIntersectionDetectionAction…✨
- intl:gettext(3)message handling functions✨
- intlen(3)Cdk miscellaneous routines✨
- INTMAX_C(3)✨
- INTMAX_C(3avr)<stdint.h>: Standard Integer Types✨
- INTMAX_MAX(3)✨
- INTMAX_MAX(3avr)<stdint.h>: Standard Integer Types✨
- INTMAX_MIN(3)✨
- INTMAX_MIN(3avr)<stdint.h>: Standard Integer Types✨
- intmax_t(3)✨
- intmax_t(3avr)<stdint.h>: Standard Integer Types✨
- intmax_t(3type)greatest-width basic integer types✨
- intN_t(3)overview of system data types✨
- intN_t(3type)fixed-width basic integer types✨
- INTPTR_MAX(3)✨
- INTPTR_MAX(3avr)<stdint.h>: Standard Integer Types✨
- INTPTR_MIN(3)✨
- INTPTR_MIN(3avr)<stdint.h>: Standard Integer Types✨
- intptr_t(3)✨
- intptr_t(3avr)<stdint.h>: Standard Integer Types✨
- intptr_t(3type)integer types wide enough to hold pointers✨
- intr_conf(3)✨
- intr_enable(3)✨
- intrflush(3)get and set curses terminal input options✨
- intrflush(3ncurses)get and set curses terminal input options✨
- intrflush(3x)get and set curses terminal input options✨
- intrflush_sp(3)curses screen-pointer extension✨
- intrflush_sp(3ncurses)curses screen-pointer extension✨
- intrflush_sp(3x)curses screen-pointer extension✨
- intro(3)introduction to library functions✨
- intro(3attr)C/C++ attributes✨
- intro(3hal)Introduction to the HAL API✨
- intro(3lua)introduction to the Lua modules for flua (FreeBSD Lua)✨
- intro(3monocypher)introduction to Monocypher✨
- intro(3rtapi)Introduction to the RTAPI API✨
- intro_shmem(3)✨
- intro_shmem.openmpi(3)✨
- IntroEmbperlObject(3pm)Introduction to EmbperlObject✨
- inttypes(3)standard fixed-size integer types✨
- inttypes.h(3)✨
- inttypes.h(3avr)✨
- INVALID(3)✨
- inverse(3G)calculate the inverse of a matrix✨
- inversesqrt(3G)return the inverse of the square root of the parameter✨
- inwstr(3)get a wide-character string from a curses window✨
- inwstr(3ncurses)get a wide-character string from a curses window✨
- inwstr(3x)get a wide-character string from a curses window✨
- io(3)Asynchronous IO✨
- io(3erl)Standard I/O server interface functions.✨
- IO(3perl)load various IO modules✨
- IO(3pm)load various IO modules✨
- io.h(3)✨
- io.h(3avr)✨
- IO::AIO(3pm)Asynchronous/Advanced Input/Output✨
- IO::All(3pm)IO::All to Larry Wall!✨
- IO::All::DBM(3pm)DBM Support for IO::All✨
- IO::All::Dir(3pm)Directory Support for IO::All✨
- IO::All::File(3pm)File Support for IO::All✨
- IO::All::Filesys(3pm)File System Methods Mixin for IO::All✨
- IO::All::FTP(3pm)Extends IO::All to FTP URLs✨
- IO::All::HTTP(3pm)Extends IO::All to HTTP URLs✨
- IO::All::HTTPS(3pm)Extends IO::All for HTTPS URLs✨
- IO::All::Link(3pm)Link Support for IO::All✨
- IO::All::LWP(3pm)IO::All interface to LWP✨
- IO::All::MLDBM(3pm)MLDBM Support for IO::All✨
- IO::All::Pipe(3pm)Pipe Support for IO::All✨
- IO::All::Socket(3pm)Socket Support for IO::All✨
- IO::All::STDIO(3pm)STDIO Support for IO::All✨
- IO::All::String(3pm)String Support for IO::All✨
- IO::All::Temp(3pm)Temporary File Support for IO::All✨
- IO::Any(3pm)open anything✨
- IO::Async(3pm)Asynchronous event-driven programming✨
- IO::Async::Channel(3pm)pass values into or out from an IO::Async::Routine✨
- IO::Async::Debug(3pm)debugging control and support for IO::Async✨
- IO::Async::File(3pm)watch a file for changes✨
- IO::Async::FileStream(3pm)read the tail of a file✨
- IO::Async::Function(3pm)call a function asynchronously✨
- IO::Async::Future(3pm)use Future with IO::Async✨
- IO::Async::Handle(3pm)event callbacks for a non-blocking file descriptor✨
- IO::Async::Listener(3pm)listen on network sockets for incoming connections✨
- IO::Async::Loop(3pm)core loop of the "IO::Async" framework✨
- IO::Async::Loop::Epoll(3pm)use "IO::Async" with "epoll" on Linux✨
- IO::Async::Loop::EV(3pm)use "IO::Async" with "EV"✨
- IO::Async::Loop::Glib(3pm)use "IO::Async" with Glib or GTK✨
- IO::Async::Loop::Mojo(3pm)use "IO::Async" with "Mojolicious"✨
- IO::Async::Loop::Poll(3pm)use "IO::Async" with "poll(2)"✨
- IO::Async::Loop::Select(3pm)use IO::Async with "select(2)"✨
- IO::Async::LoopTests(3pm)acceptance testing for IO::Async::Loop subclasses✨
- IO::Async::Metrics(3pm)report metrics about "IO::Async" to "Metrics::Any"✨
- IO::Async::Notifier(3pm)base class for IO::Async event objects✨
- IO::Async::OS(3pm)operating system abstractions for "IO::Async"✨
- IO::Async::OS::cygwin(3pm)operating system abstractions on "cygwin" for "IO::Async"✨
- IO::Async::OS::linux(3pm)operating system abstractions on "Linux" for IO::Async✨
- IO::Async::OS::MSWin32(3pm)operating system abstractions on "MSWin32" for "IO::Async"✨
- IO::Async::PID(3pm)event callback on exit of a child process✨
- IO::Async::Process(3pm)start and manage a child process✨
- IO::Async::Protocol(3pm)base class for transport-based protocols✨
- IO::Async::Protocol::LineStream(3pm)stream-based protocols using lines of text✨
- IO::Async::Protocol::Stream(3pm)base class for stream-based protocols✨
- IO::Async::Resolver(3pm)performing name resolutions asynchronously✨
- IO::Async::Resolver::DNS(3pm)resolve DNS queries using "IO::Async"✨
- IO::Async::Routine(3pm)execute code in an independent sub-process or thread✨
- IO::Async::Signal(3pm)event callback on receipt of a POSIX signal✨
- IO::Async::Socket(3pm)event callbacks and send buffering for a socket filehandle✨
- IO::Async::SSL(3pm)use SSL/TLS with IO::Async✨
- IO::Async::SSLStream(3pm)read and write buffers around an SSL connection✨
- IO::Async::Stream(3pm)event callbacks and write bufering for a stream filehandle✨
- IO::Async::Test(3pm)utility functions for use in test scripts✨
- IO::Async::Timer(3pm)base class for Notifiers that use timed delays✨
- IO::Async::Timer::Absolute(3pm)event callback at a fixed future time✨
- IO::Async::Timer::Countdown(3pm)event callback after a fixed delay✨
- IO::Async::Timer::Periodic(3pm)event callback at regular intervals✨
- IO::AtomicFile(3pm)write a file which is updated atomically✨
- IO::BufferedSelect(3pm)Line-buffered select interface✨
- IO::Callback(3pm)Emulate file interface for a code reference✨
- IO::Capture(3pm)Abstract Base Class to build modules to capture output.✨
- IO::Capture::Extended(3pm)Extend functionality of IO::Capture✨
- IO::Capture::Extended::Overview(3pm)Extend functionality of IO::Capture✨
- IO::Capture::Overview(3pm)Overview of "IO::Capture" Module, and classes derived from it.✨
- IO::Capture::Sayfix(3pm)Fix ::Tie_STDx vs say() issue✨
- IO::Capture::Stderr(3pm)Capture all output sent to "STDERR"✨
- IO::Capture::Stderr::Extended(3pm)Extend functionality of IO::Capture::Stderr✨
- IO::Capture::Stdout(3pm)Capture any output sent to STDOUT✨
- IO::Capture::Stdout::Extended(3pm)Extend functionality of IO::Capture::Stdout✨
- IO::Capture::Tellfix(3pm)Fix ::Tie_STDx TELL() issue✨
- IO::Capture::Tie_STDx(3pm)tie STDOUT or STDERR;✨
- IO::CaptureOutput(3pm)(DEPRECATED) capture STDOUT and STDERR from Perl code, subprocesses or XS✨
- IO::Compress(3perl)read/write compressed data in multiple formats✨
- IO::Compress(3pm)read/write compressed data in multiple formats✨
- IO::Compress(3pmc)read/write compressed data in multiple formats✨
- IO::Compress::Base(3perl)Base Class for IO::Compress modules✨
- IO::Compress::Base(3pm)Base Class for IO::Compress modules✨
- IO::Compress::Base(3pmc)Base Class for IO::Compress modules✨
- IO::Compress::Brotli(3pm)Write Brotli buffers/streams✨
- IO::Compress::Bzip2(3perl)Write bzip2 files/buffers✨
- IO::Compress::Bzip2(3pm)Write bzip2 files/buffers✨
- IO::Compress::Bzip2(3pmc)Write bzip2 files/buffers✨
- IO::Compress::Deflate(3perl)Write RFC 1950 files/buffers✨
- IO::Compress::Deflate(3pm)Write RFC 1950 files/buffers✨
- IO::Compress::Deflate(3pmc)Write RFC 1950 files/buffers✨
- IO::Compress::FAQ(3perl)Frequently Asked Questions about IO::Compress✨
- IO::Compress::FAQ(3pm)Frequently Asked Questions about IO::Compress✨
- IO::Compress::FAQ(3pmc)Frequently Asked Questions about IO::Compress✨
- IO::Compress::Gzip(3perl)Write RFC 1952 files/buffers✨
- IO::Compress::Gzip(3pm)Write RFC 1952 files/buffers✨
- IO::Compress::Gzip(3pmc)Write RFC 1952 files/buffers✨
- IO::Compress::Lzip(3pm)Write lzip files/buffers✨
- IO::Compress::Lzma(3pm)Write lzma files/buffers✨
- IO::Compress::RawDeflate(3perl)Write RFC 1951 files/buffers✨
- IO::Compress::RawDeflate(3pm)Write RFC 1951 files/buffers✨
- IO::Compress::RawDeflate(3pmc)Write RFC 1951 files/buffers✨
- IO::Compress::Xz(3pm)Write xz files/buffers✨
- IO::Compress::Zip(3perl)Write zip files/buffers✨
- IO::Compress::Zip(3pm)Write zip files/buffers✨
- IO::Compress::Zip(3pmc)Write zip files/buffers✨
- IO::Compress::Zstd(3pm)Write zstd files/buffers✨
- IO::Detect(3pm)is this a frickin' filehandle or what?!✨
- IO::Digest(3pm)Calculate digests while reading or writing✨
- IO::Dir(3perl)supply object methods for directory handles✨
- IO::Dir(3pm)supply object methods for directory handles✨
- IO::Dirent(3pm)Access to dirent structs returned by readdir✨
- IO::Epoll(3pm)Scalable IO Multiplexing for Linux 2.5.44 and higher✨
- IO::Event(3pm)Tied Filehandles for Nonblocking IO with Object Callbacks✨
- IO::Event::Callback(3pm)A closure based API for IO::Event✨
- IO::FDPass(3pm)pass a file descriptor over a socket✨
- IO::File(3perl)supply object methods for filehandles✨
- IO::File(3pm)supply object methods for filehandles✨
- IO::File::WithFilename(3pm)filehandles that know their origin✨
- IO::File::WithPath(3pm)An IO::File extension that keeps the pathname✨
- IO::Handle(3perl)supply object methods for I/O handles✨
- IO::Handle(3pm)supply object methods for I/O handles✨
- IO::Handle::Iterator(3pm)Iterator based read handle✨
- IO::Handle::Prototype(3pm)base class for callback based handles.✨
💅
getting it ready, bestie…