section 3pm · Library functions 📚
34259 pages · page 80 of 172
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
M (continued)
- Mail::DKIM::ARC::Seal(3pm)represents a ARC-Seal header✨
- Mail::DKIM::ARC::Signer(3pm)generates a DKIM signature for a message✨
- Mail::DKIM::ARC::Verifier(3pm)verifies an ARC-Sealed message✨
- Mail::DKIM::AuthorDomainPolicy(3pm)represents an Author Domain Signing Practices (ADSP) record✨
- Mail::DKIM::Canonicalization::Base(3pm)base class for canonicalization methods✨
- Mail::DKIM::Canonicalization::dk_nofws(3pm)nofws canonicalization✨
- Mail::DKIM::Canonicalization::dk_simple(3pm)dk simple canonicalization✨
- Mail::DKIM::Canonicalization::DkCommon(3pm)dk common canonicalization✨
- Mail::DKIM::Canonicalization::DkimCommon(3pm)common canonicalization✨
- Mail::DKIM::Canonicalization::nowsp(3pm)nowsp canonicalization✨
- Mail::DKIM::Canonicalization::relaxed(3pm)common canonicalization✨
- Mail::DKIM::Canonicalization::seal(3pm)arc seal canonicalization✨
- Mail::DKIM::Canonicalization::simple(3pm)simple canonicalization✨
- Mail::DKIM::Common(3pm)Common class for Mail::DKIM✨
- Mail::DKIM::DkimPolicy(3pm)represents a DKIM Sender Signing Practices record✨
- Mail::DKIM::DkPolicy(3pm)represents a DomainKeys Sender Signing Policy record✨
- Mail::DKIM::DkSignature(3pm)represents a DomainKeys-Signature header✨
- Mail::DKIM::DNS(3pm)performs DNS queries for Mail::DKIM✨
- Mail::DKIM::Key(3pm)Represents a DKIM Key✨
- Mail::DKIM::KeyValueList(3pm)Represents a Key/Value list✨
- Mail::DKIM::MessageParser(3pm)Signs/verifies Internet mail with DKIM/DomainKey signatures✨
- Mail::DKIM::Policy(3pm)abstract base class for originator "signing" policies✨
- Mail::DKIM::PrivateKey(3pm)a private key loaded in memory for DKIM signing✨
- Mail::DKIM::PublicKey(3pm)Represents a DKIM key✨
- Mail::DKIM::Signature(3pm)represents a DKIM-Signature header✨
- Mail::DKIM::Signer(3pm)generates a DKIM signature for a message✨
- Mail::DKIM::SignerPolicy(3pm)determines signing parameters for a message✨
- Mail::DKIM::TextWrap(3pm)text wrapping module written for use with DKIM✨
- Mail::DKIM::Verifier(3pm)verifies a DKIM-signed message✨
- Mail::DMARC(3pm)Perl implementation of DMARC✨
- Mail::DMARC::Base(3pm)DMARC utility functions✨
- Mail::DMARC::ConfigData(3pm)Configuration for Mail::DMARC✨
- Mail::DMARC::HTTP(3pm)view stored reports via HTTP✨
- Mail::DMARC::Policy(3pm)a DMARC policy in object format✨
- Mail::DMARC::PurePerl(3pm)Pure Perl implementation of DMARC✨
- Mail::DMARC::Report(3pm)A DMARC report interface✨
- Mail::DMARC::Report::Aggregate(3pm)aggregate report object✨
- Mail::DMARC::Report::Aggregate::Metadata(3pm)metadata section of aggregate report✨
- Mail::DMARC::Report::Aggregate::Record(3pm)record section of aggregate report✨
- Mail::DMARC::Report::Aggregate::Record::Auth_Results(3pm)auth_results section of a DMARC aggregate record✨
- Mail::DMARC::Report::Aggregate::Record::Auth_Results::DKIM(3pm)auth_results/dkim section of a DMARC aggregate record✨
- Mail::DMARC::Report::Aggregate::Record::Auth_Results::SPF(3pm)auth_results/spf section of a DMARC aggregate record✨
- Mail::DMARC::Report::Aggregate::Record::Identifiers(3pm)identifiers section of a DMARC aggregate record✨
- Mail::DMARC::Report::Aggregate::Record::Row(3pm)row section of a DMARC aggregate record✨
- Mail::DMARC::Report::Aggregate::Record::Row::Policy_Evaluated(3pm)row/policy_evaluated section of a DMARC aggregate record✨
- Mail::DMARC::Report::Receive(3pm)process incoming DMARC reports✨
- Mail::DMARC::Report::Send(3pm)report sending dispatch class✨
- Mail::DMARC::Report::Send::HTTP(3pm)utility methods to send reports by HTTP✨
- Mail::DMARC::Report::Send::SMTP(3pm)utility methods for sending reports via SMTP✨
- Mail::DMARC::Report::Store(3pm)persistent storage broker for reports✨
- Mail::DMARC::Report::Store::SQL(3pm)store and retrieve reports from a SQL RDBMS✨
- Mail::DMARC::Report::Store::SQL::Grammars::MySQL(3pm)Grammar for working with mysql databases.✨
- Mail::DMARC::Report::Store::SQL::Grammars::PostgreSQL(3pm)Grammar for working with pgsql databases.✨
- Mail::DMARC::Report::Store::SQL::Grammars::SQLite(3pm)Grammar for working with sqlite databases.✨
- Mail::DMARC::Report::URI(3pm)a DMARC report URI✨
- Mail::DMARC::Result(3pm)an aggregate report result object✨
- Mail::DMARC::Result::Reason(3pm)policy override reason✨
- Mail::DomainKeys(3pm)A perl implementation of DomainKeys✨
- Mail::Field(3pm)base-class for manipulation of mail header fields✨
- Mail::Field::AddrList(3pm)object representation of e-mail address lists✨
- Mail::Field::Date(3pm)a date header field✨
- Mail::Field::Generic(3pm)implementation for inspecific fields✨
- Mail::Field::Received(3pm)mostly RFC822-compliant parser of Received headers✨
- Mail::Filter(3pm)filter mail through multiple subroutines✨
- Mail::GnuPG(3pm)Process email with GPG.✨
- Mail::Header(3pm)manipulate MIME headers✨
- Mail::Identity(3pm)an e-mail role✨
- Mail::IMAPClient(3pm)An IMAP Client API✨
- Mail::IMAPClient::BodyStructure(3pm)parse fetched results✨
- Mail::IMAPClient::BodyStructure::Parse(3pm)used internally by Mail::IMAPClient::BodyStructure✨
- Mail::IMAPClient::MessageSet(3pm)ranges of message sequence numbers✨
- Mail::IMAPClient::Thread(3pm)used internally by Mail::IMAPClient->thread✨
- Mail::IMAPTalk(3pm)IMAP client interface with lots of features✨
- Mail::Internet(3pm)manipulate email messages✨
- Mail::JMAPTalk(3pm)Basic interface to talk to JMAP Servers✨
- Mail::ListDetector(3pm)Perl extension for detecting mailing list messages✨
- Mail::ListDetector::Detector::AutoShare(3pm)AutoShare message detector✨
- Mail::ListDetector::Detector::Base(3pm)base class for mailing list detectors✨
- Mail::ListDetector::Detector::CommuniGate(3pm)CommuniGate message detector✨
- Mail::ListDetector::Detector::CommuniGatePro(3pm)CommuniGate Pro message detector✨
- Mail::ListDetector::Detector::Ecartis(3pm)Ecartis message detector✨
- Mail::ListDetector::Detector::Ezmlm(3pm)Ezmlm message detector✨
- Mail::ListDetector::Detector::Fml(3pm)FML message detector✨
- Mail::ListDetector::Detector::GoogleGroups(3pm)Google Groups message detector✨
- Mail::ListDetector::Detector::LetterRip(3pm)LetterRip message detector✨
- Mail::ListDetector::Detector::Listar(3pm)Listar message detector✨
- Mail::ListDetector::Detector::Listbox(3pm)Listbox message detector✨
- Mail::ListDetector::Detector::Listserv(3pm)Listserv message detector✨
- Mail::ListDetector::Detector::ListSTAR(3pm)ListSTAR message detector✨
- Mail::ListDetector::Detector::Lyris(3pm)Lyris message detector✨
- Mail::ListDetector::Detector::Mailman(3pm)Mailman message detector✨
- Mail::ListDetector::Detector::Majordomo(3pm)Majordomo message detector✨
- Mail::ListDetector::Detector::Onelist(3pm)ONElist message detector✨
- Mail::ListDetector::Detector::RFC2369(3pm)RFC2369 message detector✨
- Mail::ListDetector::Detector::RFC2919(3pm)RFC2919 message detector✨
- Mail::ListDetector::Detector::Smartlist(3pm)Smartlist message detector✨
- Mail::ListDetector::Detector::Yahoogroups(3pm)Yahoo! Groups message detector✨
- Mail::ListDetector::List(3pm)an object representing a mailing list✨
- Mail::Mailer(3pm)send simple emails✨
- Mail::Mbox::MessageParser(3pm)A fast and simple mbox folder reader✨
- Mail::Mbox::MessageParser::Cache(3pm)A cache-based mbox folder reader✨
- Mail::Mbox::MessageParser::Config(3pm)An internal configuration class✨
- Mail::Mbox::MessageParser::Grep(3pm)A GNU grep-based mbox folder reader✨
- Mail::Mbox::MessageParser::MetaInfo(3pm)A cache for folder metadata✨
- Mail::Mbox::MessageParser::Perl(3pm)A Perl-based mbox folder reader✨
- Mail::MboxParser(3pm)read-only access to UNIX-mailboxes✨
- Mail::MboxParser::Base(3pm)base clase for all other classes✨
- Mail::MboxParser::Mail(3pm)Provide mail-objects and methods upon✨
- Mail::MboxParser::Mail::Body(3pm)rudimentary mail-body object✨
- Mail::MboxParser::Mail::Convertable(3pm)convert mail for sending etc.✨
- Mail::Message(3pm)general message object✨
- Mail::Message::Body(3pm)the data of a body in a message✨
- Mail::Message::Body::Construct(3pm)adds functionality to Mail::Message::Body✨
- Mail::Message::Body::Delayed(3pm)body of a Mail::Message but not read yet.✨
- Mail::Message::Body::Encode(3pm)organize general message encodings✨
- Mail::Message::Body::File(3pm)body of a message temporarily stored in a file✨
- Mail::Message::Body::Lines(3pm)body of a Mail::Message stored as array of lines✨
- Mail::Message::Body::Multipart(3pm)body of a message with attachments✨
- Mail::Message::Body::Nested(3pm)body of a message which contains a message✨
- Mail::Message::Body::String(3pm)body of a Mail::Message stored as single string✨
- Mail::Message::Construct(3pm)extends the functionality of a Mail::Message✨
- Mail::Message::Construct::Bounce(3pm)bounce a Mail::Message✨
- Mail::Message::Construct::Build(3pm)building a Mail::Message from components✨
- Mail::Message::Construct::Forward(3pm)forwarding a Mail::Message✨
- Mail::Message::Construct::Read(3pm)read a Mail::Message from a file handle✨
- Mail::Message::Construct::Rebuild(3pm)modify a Mail::Message✨
- Mail::Message::Construct::Reply(3pm)reply to a Mail::Message✨
- Mail::Message::Construct::Text(3pm)capture a Mail::Message as text✨
- Mail::Message::Convert(3pm)conversions between message types✨
- Mail::Message::Convert::EmailSimple(3pm)translate Mail::Message to Email::Simple vv✨
- Mail::Message::Convert::Html(3pm)Format messages in HTML✨
- Mail::Message::Convert::HtmlFormatPS(3pm)Convert HTML into PostScript✨
- Mail::Message::Convert::HtmlFormatText(3pm)Convert HTML into Text✨
- Mail::Message::Convert::MailInternet(3pm)translate Mail::Message to Mail::Internet vv✨
- Mail::Message::Convert::MimeEntity(3pm)translate Mail::Message to MIME::Entity vv✨
- Mail::Message::Convert::TextAutoformat(3pm)Reformat plain text messages✨
- Mail::Message::Dummy(3pm)a placeholder for a missing messages✨
- Mail::Message::Field(3pm)one line of a message header✨
- Mail::Message::Field::Address(3pm)One e-mail address✨
- Mail::Message::Field::Addresses(3pm)Fields with e-mail addresses✨
- Mail::Message::Field::AddrGroup(3pm)A group of Mail::Message::Field::Address objects✨
- Mail::Message::Field::Attribute(3pm)one attribute of a full field✨
- Mail::Message::Field::AuthResults(3pm)message header field authentication result✨
- Mail::Message::Field::Date(3pm)message header field with uris✨
- Mail::Message::Field::DKIM(3pm)message header field for dkim signatures✨
- Mail::Message::Field::Fast(3pm)one line of a message header✨
- Mail::Message::Field::Flex(3pm)one line of a message header✨
- Mail::Message::Field::Full(3pm)construct one smart line in a message header✨
- Mail::Message::Field::Structured(3pm)one line of a structured message header✨
- Mail::Message::Field::Unstructured(3pm)smart unstructured field✨
- Mail::Message::Field::URIs(3pm)message header field with uris✨
- Mail::Message::Head(3pm)the header of one message✨
- Mail::Message::Head::Complete(3pm)the header of one message✨
- Mail::Message::Head::Delayed(3pm)a not-read header of a Mail::Message✨
- Mail::Message::Head::FieldGroup(3pm)a sub set of fields in a header✨
- Mail::Message::Head::ListGroup(3pm)mailinglist related header fields✨
- Mail::Message::Head::Partial(3pm)subset of header information of a message✨
- Mail::Message::Head::ResentGroup(3pm)header fields tracking message delivery✨
- Mail::Message::Head::SpamGroup(3pm)spam fighting related header fields✨
- Mail::Message::Head::Subset(3pm)subset of header information of a message✨
- Mail::Message::Part(3pm)a part of a message, but a message by itself✨
- Mail::Message::Replace::MailHeader(3pm)fake Mail::Header✨
- Mail::Message::Replace::MailInternet(3pm)fake Mail::Internet✨
- Mail::Message::TransferEnc(3pm)message transfer encoder/decoder✨
- Mail::Message::TransferEnc::Base64(3pm)encode/decode base64 message bodies✨
- Mail::Message::TransferEnc::Binary(3pm)encode/decode binary message bodies✨
- Mail::Message::TransferEnc::EightBit(3pm)encode/decode 8bit message bodies✨
- Mail::Message::TransferEnc::QuotedPrint(3pm)handle quoted-printable message bodies✨
- Mail::Message::TransferEnc::SevenBit(3pm)encode/decode 7bit message bodies✨
- Mail::Message::Wrapper::SpamAssassin(3pm)Connect a Mail::Message with Mail::SpamAssassin✨
- Mail::Milter(3pm)Perl extension modules for mail filtering via milter✨
- Mail::Milter::Chain(3pm)Perl extension for chaining milter callbacks✨
- Mail::Milter::ContextWrapper(3pm)Perl extension for wrappering the milter context✨
- Mail::Milter::Module::AccessDB(3pm)emulator for Sendmail "access_db" in a milter✨
- Mail::Milter::Module::ConnectDNSBL(3pm)milter to accept/reject connecting hosts matching DNSBLs✨
- Mail::Milter::Module::ConnectMatchesHostname(3pm)milter to accept/reject connecting hosts matching regex(es)✨
- Mail::Milter::Module::ConnectRegex(3pm)milter to accept/reject connecting hosts matching regex(es)✨
- Mail::Milter::Module::HeaderFromMissing(3pm)milter to reject messages missing a From: header✨
- Mail::Milter::Module::HeaderRegex(3pm)milter to accept/reject messages with certain headers✨
- Mail::Milter::Module::HeaderValidateMIME(3pm)enforce MIME header conformance✨
- Mail::Milter::Module::HeloRawLiteral(3pm)milter to check for an IP literal without brackets in HELO✨
- Mail::Milter::Module::HeloRegex(3pm)milter to accept/reject connections with certain HELO values✨
- Mail::Milter::Module::HeloUnqualified(3pm)milter to check for an unqualified HELO name✨
- Mail::Milter::Module::MailBogusNull(3pm)milter to reject null-sender mail to multiple recipients✨
- Mail::Milter::Module::MailDomainDNSBL(3pm)milter to accept/reject mail whose sender domain matches a DNSBL✨
- Mail::Milter::Module::MailDomainDotMX(3pm)milter to reject mail whose sender domain publishes a null MX record✨
- Mail::Milter::Module::SPF(3pm)milter to use Sender Policy Framework for accept/reject✨
- Mail::Milter::Module::VirusBounceSpew(3pm)milter to reject antivirus messages typically sent to forged "senders"✨
- Mail::Milter::Object(3pm)Perl extension to encapsulate a milter in an object✨
- Mail::Milter::Wrapper(3pm)Perl extension for wrappering milter objects✨
- Mail::Milter::Wrapper::DecodeSRS(3pm)milter wrapper to decode SRS-encoded return path✨
- Mail::Milter::Wrapper::DeferToRCPT(3pm)milter wrapper to delay failure returns✨
- Mail::Milter::Wrapper::RejectMsgEditor(3pm)milter wrapper to edit rejection messages✨
- Mail::MtPolicyd(3pm)a modular policy daemon for postfix✨
- Mail::MtPolicyd::AddressList(3pm)a class for IP address lists✨
- Mail::MtPolicyd::Client(3pm)a policyd client class✨
- Mail::MtPolicyd::Client::App(3pm)application interface class for Mail::MtPolicyd::Client✨
- Mail::MtPolicyd::Client::Request(3pm)a postfix policyd client request class✨
- Mail::MtPolicyd::Client::Response(3pm)a postfix policyd client response class✨
- Mail::MtPolicyd::Connection(3pm)base class for mtpolicyd connection modules✨
💅
getting it ready, bestie…