section 3pm · Library functions 📚
34259 pages · page 30 of 172
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
C (continued)
- Crypt::Cipher::SAFERP(3pm)Symmetric cipher SAFER+, key size: 128/192/256 bits✨
- Crypt::Cipher::SEED(3pm)Symmetric cipher SEED, key size: 128 bits✨
- Crypt::Cipher::Serpent(3pm)Symmetric cipher Serpent, key size: 128/192/256 bits✨
- Crypt::Cipher::Skipjack(3pm)Symmetric cipher Skipjack, key size: 80 bits✨
- Crypt::Cipher::SM4(3pm)Symmetric cipher SM4, key size: 128 bits✨
- Crypt::Cipher::Twofish(3pm)Symmetric cipher Twofish, key size: 128/192/256 bits✨
- Crypt::Cipher::XTEA(3pm)Symmetric cipher XTEA, key size: 128 bits✨
- Crypt::CipherSaber(3pm)Perl module implementing CipherSaber encryption.✨
- Crypt::Cracklib(3pm)Perl interface to Alec Muffett's Cracklib.✨
- Crypt::Curve25519(3pm)Generate shared secret using elliptic-curve Diffie-Hellman function✨
- Crypt::DES(3pm)Perl DES encryption module✨
- Crypt::DES_EDE3(3pm)Triple-DES EDE encryption/decryption✨
- Crypt::DH(3pm)Diffie-Hellman key exchange system✨
- Crypt::DH::GMP(3pm)Crypt::DH Using GMP Directly✨
- Crypt::DH::GMP::Compat(3pm)Compatibility Mode For Crypt::DH✨
- Crypt::Digest(3pm)Generic interface to hash/digest functions✨
- Crypt::Digest::BLAKE2b_160(3pm)Hash function BLAKE2b [size: 160 bits]✨
- Crypt::Digest::BLAKE2b_256(3pm)Hash function BLAKE2b [size: 256 bits]✨
- Crypt::Digest::BLAKE2b_384(3pm)Hash function BLAKE2b [size: 384 bits]✨
- Crypt::Digest::BLAKE2b_512(3pm)Hash function BLAKE2b [size: 512 bits]✨
- Crypt::Digest::BLAKE2s_128(3pm)Hash function BLAKE2s [size: 128 bits]✨
- Crypt::Digest::BLAKE2s_160(3pm)Hash function BLAKE2s [size: 160 bits]✨
- Crypt::Digest::BLAKE2s_224(3pm)Hash function BLAKE2s [size: 224 bits]✨
- Crypt::Digest::BLAKE2s_256(3pm)Hash function BLAKE2s [size: 256 bits]✨
- Crypt::Digest::BLAKE3(3pm)Hash function BLAKE3 [size: 256 bits]✨
- Crypt::Digest::CHAES(3pm)Hash function - CipherHash based on AES [size: 128 bits]✨
- Crypt::Digest::KangarooTwelve(3pm)XOF (extendable output) hash function KangarooTwelve✨
- Crypt::Digest::Keccak224(3pm)Hash function Keccak-224 [size: 224 bits]✨
- Crypt::Digest::Keccak256(3pm)Hash function Keccak-256 [size: 256 bits]✨
- Crypt::Digest::Keccak384(3pm)Hash function Keccak-384 [size: 384 bits]✨
- Crypt::Digest::Keccak512(3pm)Hash function Keccak-512 [size: 512 bits]✨
- Crypt::Digest::MD2(3pm)Hash function MD2 [size: 128 bits]✨
- Crypt::Digest::MD4(3pm)Hash function MD4 [size: 128 bits]✨
- Crypt::Digest::MD5(3pm)Hash function MD5 [size: 128 bits]✨
- Crypt::Digest::RIPEMD128(3pm)Hash function RIPEMD-128 [size: 128 bits]✨
- Crypt::Digest::RIPEMD160(3pm)Hash function RIPEMD-160 [size: 160 bits]✨
- Crypt::Digest::RIPEMD256(3pm)Hash function RIPEMD-256 [size: 256 bits]✨
- Crypt::Digest::RIPEMD320(3pm)Hash function RIPEMD-320 [size: 320 bits]✨
- Crypt::Digest::SHA1(3pm)Hash function SHA-1 [size: 160 bits]✨
- Crypt::Digest::SHA224(3pm)Hash function SHA-224 [size: 224 bits]✨
- Crypt::Digest::SHA256(3pm)Hash function SHA-256 [size: 256 bits]✨
- Crypt::Digest::SHA384(3pm)Hash function SHA-384 [size: 384 bits]✨
- Crypt::Digest::SHA3_224(3pm)Hash function SHA3-224 [size: 224 bits]✨
- Crypt::Digest::SHA3_256(3pm)Hash function SHA3-256 [size: 256 bits]✨
- Crypt::Digest::SHA3_384(3pm)Hash function SHA3-384 [size: 384 bits]✨
- Crypt::Digest::SHA3_512(3pm)Hash function SHA3-512 [size: 512 bits]✨
- Crypt::Digest::SHA512(3pm)Hash function SHA-512 [size: 512 bits]✨
- Crypt::Digest::SHA512_224(3pm)Hash function SHA-512/224 [size: 224 bits]✨
- Crypt::Digest::SHA512_256(3pm)Hash function SHA-512/256 [size: 256 bits]✨
- Crypt::Digest::SHAKE(3pm)Hash functions SHAKE128, SHAKE256 from SHA3 family✨
- Crypt::Digest::SM3(3pm)Hash function SM3 [size: 256 bits]✨
- Crypt::Digest::Tiger192(3pm)Hash function Tiger-192 [size: 192 bits]✨
- Crypt::Digest::TurboSHAKE(3pm)XOF (extendable output) hash functions TurboSHAKE128 and TurboSHAKE256✨
- Crypt::Digest::Whirlpool(3pm)Hash function Whirlpool [size: 512 bits]✨
- Crypt::DSA(3pm)DSA Signatures and Key Generation✨
- Crypt::DSA::Key(3pm)DSA key✨
- Crypt::DSA::Key::PEM(3pm)Read/write DSA PEM files✨
- Crypt::DSA::Key::SSH2(3pm)Read/write DSA SSH2 files✨
- Crypt::DSA::KeyChain(3pm)DSA key generation system✨
- Crypt::DSA::Signature(3pm)DSA signature object✨
- Crypt::DSA::Util(3pm)DSA Utility functions✨
- Crypt::ECB(3pm)Use block ciphers using ECB mode✨
- Crypt::Eksblowfish(3pm)the Eksblowfish block cipher✨
- Crypt::Eksblowfish::Bcrypt(3pm)Blowfish-based Unix crypt() password hash✨
- Crypt::Eksblowfish::Blowfish(3pm)Blowfish block cipher via Eksblowfish engine✨
- Crypt::Eksblowfish::Family(3pm)Eksblowfish cipher family✨
- Crypt::Eksblowfish::Subkeyed(3pm)Blowfish/Eksblowfish with access to subkeys✨
- Crypt::Eksblowfish::Uklblowfish(3pm)Blowfish cipher with unrestricted key length✨
- Crypt::Format(3pm)Conversion utilities for encryption applications✨
- Crypt::GCrypt(3pm)Perl interface to the GNU Cryptographic library✨
- Crypt::GCrypt::MPI(3pm)Perl interface to multi-precision integers from the GNU Cryptographic library✨
- Crypt::GeneratePassword(3pm)generate secure random pronounceable passwords✨
- Crypt::GPG(3pm)An Object Oriented Interface to GnuPG.✨
- Crypt::HCE_SHA(3pm)Perl extension implementing one way hash chaining encryption using SHA✨
- Crypt::HSXKPasswd(3pm)A secure memorable password generator inspired by Steve Gibson's Passord Haystacks (<https://www.grc.com/haystack.htm>), and the famous XKCD password cartoon (<https://xkcd.com/936/>).✨
- Crypt::IDEA(3pm)Perl interface to IDEA block cipher✨
- Crypt::JWT(3pm)JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516✨
- Crypt::KeyDerivation(3pm)PBKDF1, PBKDF2, HKDF, Bcrypt, Scrypt, Argon2 key derivation functions✨
- Crypt::KeyWrap(3pm)Key management/wrapping algorithms defined in RFC7518 (JWA)✨
- Crypt::Mac(3pm)[internal only]✨
- Crypt::Mac::BLAKE2b(3pm)Message authentication code BLAKE2b MAC (RFC 7693)✨
- Crypt::Mac::BLAKE2s(3pm)Message authentication code BLAKE2s MAC (RFC 7693)✨
- Crypt::Mac::F9(3pm)Message authentication code F9✨
- Crypt::Mac::HMAC(3pm)Message authentication code HMAC✨
- Crypt::Mac::KMAC(3pm)Message authentication code KMAC (NIST SP 800-185)✨
- Crypt::Mac::OMAC(3pm)Message authentication code OMAC✨
- Crypt::Mac::Pelican(3pm)Message authentication code Pelican (AES based MAC)✨
- Crypt::Mac::PMAC(3pm)Message authentication code PMAC✨
- Crypt::Mac::Poly1305(3pm)Message authentication code Poly1305 (RFC 7539)✨
- Crypt::Mac::XCBC(3pm)Message authentication code XCBC (RFC 3566)✨
- Crypt::Misc(3pm)miscellaneous functions related to (or used by) CryptX✨
- Crypt::Mode(3pm)[internal only]✨
- Crypt::Mode::CBC(3pm)Block cipher mode CBC [Cipher-block chaining]✨
- Crypt::Mode::CFB(3pm)Block cipher mode CFB [Cipher feedback]✨
- Crypt::Mode::CTR(3pm)Block cipher mode CTR [Counter mode]✨
- Crypt::Mode::ECB(3pm)Block cipher mode ECB [Electronic codebook]✨
- Crypt::Mode::OFB(3pm)Block cipher mode OFB [Output feedback]✨
- Crypt::Mode::XTS(3pm)Block cipher mode XTS [XEX-based tweaked-codebook mode with ciphertext stealing]✨
- Crypt::MySQL(3pm)emulate MySQL PASSWORD() function.✨
- Crypt::OpenSSL::AES(3pm)A Perl wrapper around OpenSSL's AES library✨
- Crypt::OpenSSL::Bignum(3pm)OpenSSL's multiprecision integer arithmetic✨
- Crypt::OpenSSL::Bignum::CTX(3pm)Perl interface to the OpenSSL BN_CTX structure.✨
- Crypt::OpenSSL::DSA(3pm)Digital Signature Algorithm using OpenSSL✨
- Crypt::OpenSSL::DSA::Signature(3pm)Digital Signature Object✨
- Crypt::OpenSSL::EC(3pm)Perl extension for OpenSSL EC (Elliptic Curves) library✨
- Crypt::OpenSSL::ECDSA(3pm)Perl extension for OpenSSL ECDSA (Elliptic Curve Digital Signature Algorithm)✨
- Crypt::OpenSSL::Guess(3pm)Guess OpenSSL include path✨
- Crypt::OpenSSL::PKCS10(3pm)Perl extension to OpenSSL's PKCS10 API.✨
- Crypt::OpenSSL::PKCS12(3pm)Perl extension to OpenSSL's PKCS12 API.✨
- Crypt::OpenSSL::Random(3pm)OpenSSL/LibreSSL pseudo-random number generator access✨
- Crypt::OpenSSL::RSA(3pm)RSA encoding and decoding, using the openSSL libraries✨
- Crypt::OpenSSL::Verify(3pm)OpenSSL Verify certificate verification in XS.✨
- Crypt::OpenSSL::VerifyX509(3pm)simple certificate verification✨
- Crypt::OpenSSL::X509(3pm)Perl extension to OpenSSL's X509 API.✨
- Crypt::PasswdMD5(3pm)Provide interoperable MD5-based crypt() functions✨
- Crypt::Password(3pm)Unix-style, Variously Hashed Passwords✨
- Crypt::PBKDF2(3pm)The PBKDF2 password hashing algorithm.✨
- Crypt::PBKDF2::Hash(3pm)Abstract role for PBKDF2 hashing algorithms.✨
- Crypt::PBKDF2::Hash::DigestHMAC(3pm)Digest::HMAC hash support for Crypt::PBKDF2.✨
- Crypt::PBKDF2::Hash::HMACSHA1(3pm)HMAC-SHA1 support for Crypt::PBKDF2 using Digest::SHA✨
- Crypt::PBKDF2::Hash::HMACSHA2(3pm)HMAC-SHA2 support for Crypt::PBKDF2 using Digest::SHA✨
- Crypt::PBKDF2::Hash::HMACSHA3(3pm)HMAC-SHA3 support for Crypt::PBKDF2 using Digest::SHA✨
- Crypt::PK(3pm)[internal only]✨
- Crypt::PK::DH(3pm)Public key cryptography based on Diffie-Hellman✨
- Crypt::PK::DSA(3pm)Public key cryptography based on DSA✨
- Crypt::PK::ECC(3pm)Public key cryptography based on EC✨
- Crypt::PK::Ed25519(3pm)Digital signature based on Ed25519✨
- Crypt::PK::Ed448(3pm)Digital signature based on Ed448✨
- Crypt::PK::RSA(3pm)Public key cryptography based on RSA✨
- Crypt::PK::X25519(3pm)Asymmetric cryptography based on X25519✨
- Crypt::PK::X448(3pm)Asymmetric cryptography based on X448✨
- Crypt::PRNG(3pm)Cryptographically secure random number generator✨
- Crypt::PRNG::ChaCha20(3pm)Cryptographically secure PRNG based on ChaCha20 (stream cipher) algorithm✨
- Crypt::PRNG::Fortuna(3pm)Cryptographically secure PRNG based on Fortuna algorithm✨
- Crypt::PRNG::RC4(3pm)Legacy RC4-based PRNG wrapper✨
- Crypt::PRNG::Sober128(3pm)Cryptographically secure PRNG based on Sober128 (stream cipher) algorithm✨
- Crypt::PRNG::Yarrow(3pm)Cryptographically secure PRNG based on Yarrow algorithm✨
- Crypt::PWSafe3(3pm)Read and write Passwordsafe v3 files✨
- Crypt::PWSafe3::Databaseformat(3pm)✨
- Crypt::PWSafe3::Field(3pm)represent a passwordsafe v3 record field.✨
- Crypt::PWSafe3::HeaderField(3pm)represent a passwordsafe v3 header field.✨
- Crypt::PWSafe3::PasswordPolicy(3pm)represent a passwordsafe v3 passwprd policy entry of a record.✨
- Crypt::PWSafe3::Record(3pm)Represents a Passwordsafe v3 data record✨
- Crypt::PWSafe3::SHA256(3pm)HMAC Helper Class✨
- Crypt::Random(3pm)Cryptographically Secure, True Random Number Generator.✨
- Crypt::Random::Seed(3pm)Simple method to get strong randomness✨
- Crypt::Random::Source(3pm)Get weak or strong random data from pluggable sources✨
- Crypt::Random::Source::Base(3pm)Abstract base class for Crypt::Random::Source classes✨
- Crypt::Random::Source::Base::File(3pm)File (or device) random data sources✨
- Crypt::Random::Source::Base::Handle(3pm)IO::Handle based random data sources✨
- Crypt::Random::Source::Base::Proc(3pm)Base class for helper processes (e.g. "openssl")✨
- Crypt::Random::Source::Base::RandomDevice(3pm)Base class for random devices✨
- Crypt::Random::Source::Factory(3pm)Load and instantiate sources of random data✨
- Crypt::Random::Source::Strong(3pm)Abstract base class for strong random data sources✨
- Crypt::Random::Source::Strong::devrandom(3pm)A strong random data source using /dev/random✨
- Crypt::Random::Source::Weak(3pm)Abstract base class for weak random data sources✨
- Crypt::Random::Source::Weak::devurandom(3pm)A weak random data source using /dev/urandom✨
- Crypt::RandPasswd(3pm)random password generator based on FIPS-181✨
- Crypt::RC4(3pm)Perl implementation of the RC4 encryption algorithm✨
- Crypt::RC4::XS(3pm)Perl implementation of the RC4 encryption algorithm✨
- Crypt::Rijndael(3pm)Crypt::CBC compliant Rijndael encryption module✨
- Crypt::RSA::Parse(3pm)Parse RSA keys✨
- Crypt::Salsa20(3pm)Encrypt data with the Salsa20 cipher✨
- Crypt::SaltedHash(3pm)Perl interface to functions that assist in working with salted hashes.✨
- Crypt::ScryptKDF(3pm)Scrypt password based key derivation function✨
- Crypt::Simple(3pm)encrypt stuff simply✨
- Crypt::SmbHash(3pm)Perl-only implementation of lanman and nt md4 hash functions, for use in Samba style smbpasswd entries✨
- Crypt::SSLeay(3pm)OpenSSL support for LWP✨
- Crypt::SSLeay::Version(3pm)Obtain OpenSSL version information✨
- Crypt::Stream::ChaCha(3pm)Stream cipher ChaCha✨
- Crypt::Stream::Rabbit(3pm)Stream cipher Rabbit✨
- Crypt::Stream::RC4(3pm)Stream cipher RC4✨
- Crypt::Stream::Salsa20(3pm)Stream cipher Salsa20✨
- Crypt::Stream::Sober128(3pm)Stream cipher Sober128✨
- Crypt::Stream::Sosemanuk(3pm)Stream cipher Sosemanuk✨
- Crypt::Stream::XChaCha(3pm)Stream cipher XChaCha20✨
- Crypt::Stream::XSalsa20(3pm)Stream cipher XSalsa20✨
- Crypt::SysRandom(3pm)Perl interface to system randomness✨
- Crypt::SysRandom::XS(3pm)Perl interface to system randomness, XS version✨
- Crypt::Twofish(3pm)The Twofish Encryption Algorithm✨
- Crypt::U2F::Server(3pm)Low level wrapper around the U2F two factor authentication C library (server side)✨
- Crypt::U2F::Server::Simple(3pm)Register and Authenticate U2F compatible security devices✨
- Crypt::UnixCrypt(3pm)perl-only implementation of the "crypt" function.✨
- Crypt::UnixCrypt_XS(3pm)perl xs interface for a portable traditional crypt function.✨
- Crypt::URandom(3pm)Provide non blocking randomness✨
- Crypt::URandom::MonkeyPatch(3pm)override core rand function to use system random sources✨
- Crypt::URandom::Token(3pm)Generate secure strings for passwords, secrets and similar✨
- Crypt::Util(3pm)A lightweight Crypt/Digest convenience API✨
- Crypt::X509(3pm)Parse a X.509 certificate✨
- Crypt::xxHash(3pm)xxHash implementation for Perl✨
- CryptX(3pm)Cryptographic toolkit✨
- CSAF(3pm)Common Security Advisory Framework✨
- CSAF::Base(3pm)CSAF base class✨
- CSAF::Builder(3pm)Build the CSAF document✨
- CSAF::Document(3pm)CSAF Document✨
- CSAF::Downloader(3pm)Download CSAF documents✨
- CSAF::Options::Common(3pm)CSAF::Common configurator✨
- CSAF::Options::Downloader(3pm)CSAF::Downloader configurator✨
- CSAF::Options::ROLIE(3pm)CSAF::ROLIE::Feed configurator✨
- CSAF::Options::Writer(3pm)CSAF::Writer configurator✨
💅
getting it ready, bestie…