section 3pm · Library functions 📚
34259 pages · page 136 of 172
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
R (continued)
- Redis::Hash(3pm)tie Perl hashes to Redis hashes✨
- Redis::List(3pm)tie Perl arrays to Redis lists✨
- Redis::Sentinel(3pm)Redis Sentinel interface✨
- Ref::Util(3pm)Utility functions for checking references✨
- Ref::Util::PP(3pm)pure-Perl version of Ref::Util✨
- Ref::Util::XS(3pm)XS implementation for Ref::Util✨
- Reg::Asused(3pm)Perl module for asused.✨
- Regexp::Assemble(3pm)Assemble multiple Regular Expressions into a single RE✨
- Regexp::Assemble::Compressed(3pm)Assemble more compressed Regular Expression✨
- Regexp::Common(3pm)Provide commonly requested regular expressions✨
- Regexp::Common::_support(3pm)Support functions for Regexp::Common.✨
- Regexp::Common::balanced(3pm)provide regexes for strings with balanced parenthesized delimiters or arbitrary delimiters.✨
- Regexp::Common::CC(3pm)provide patterns for credit card numbers.✨
- Regexp::Common::comment(3pm)provide regexes for comments.✨
- Regexp::Common::delimited(3pm)provides a regex for delimited strings✨
- Regexp::Common::Email::Address(3pm)Returns a pattern for Email Addresses✨
- Regexp::Common::lingua(3pm)provide regexes for language related stuff.✨
- Regexp::Common::list(3pm)provide regexes for lists✨
- Regexp::Common::net(3pm)provide regexes for IPv4, IPv6, and MAC addresses.✨
- Regexp::Common::net::CIDR(3pm)provide patterns for CIDR blocks.✨
- Regexp::Common::number(3pm)provide regexes for numbers✨
- Regexp::Common::profanity(3pm)provide regexes for profanity✨
- Regexp::Common::SEN(3pm)provide regexes for Social-Economical Numbers.✨
- Regexp::Common::time(3pm)Date and time regexps.✨
- Regexp::Common::URI(3pm)provide patterns for URIs.✨
- Regexp::Common::URI::fax(3pm)Returns a pattern for fax URIs.✨
- Regexp::Common::URI::file(3pm)Returns a pattern for file URIs.✨
- Regexp::Common::URI::ftp(3pm)Returns a pattern for FTP URIs.✨
- Regexp::Common::URI::gopher(3pm)Returns a pattern for gopher URIs.✨
- Regexp::Common::URI::http(3pm)Returns a pattern for HTTP URIs.✨
- Regexp::Common::URI::news(3pm)Returns a pattern for file URIs.✨
- Regexp::Common::URI::pop(3pm)Returns a pattern for POP URIs.✨
- Regexp::Common::URI::prospero(3pm)Returns a pattern for prospero URIs.✨
- Regexp::Common::URI::RFC1035(3pm)Definitions from RFC1035;✨
- Regexp::Common::URI::RFC1738(3pm)Definitions from RFC1738;✨
- Regexp::Common::URI::RFC1808(3pm)Definitions from RFC1808;✨
- Regexp::Common::URI::RFC2384(3pm)Definitions from RFC2384;✨
- Regexp::Common::URI::RFC2396(3pm)Definitions from RFC2396;✨
- Regexp::Common::URI::RFC2806(3pm)Definitions from RFC2806;✨
- Regexp::Common::URI::tel(3pm)Returns a pattern for telephone URIs.✨
- Regexp::Common::URI::telnet(3pm)Returns a pattern for telnet URIs.✨
- Regexp::Common::URI::tv(3pm)Returns a pattern for tv URIs.✨
- Regexp::Common::URI::wais(3pm)Returns a pattern for WAIS URIs.✨
- Regexp::Common::whitespace(3pm)provides a regex for leading or trailing whitescape✨
- Regexp::Common::zip(3pm)provide regexes for postal codes.✨
- Regexp::Debugger(3pm)Visually debug regexes in-place✨
- Regexp::Grammars(3pm)Add grammatical parsing features to Perl 5.10 regexes✨
- Regexp::IPv6(3pm)Regular expression for IPv6 addresses✨
- Regexp::List(3pm)Assemble multiple Regular Expressions into a single RE✨
- Regexp::Log(3pm)A base class for log files regexp builders✨
- Regexp::Optimizer(3pm)optimizes regular expressions✨
- Regexp::Pattern(3pm)Convention/framework for modules that contain collection of regexes✨
- Regexp::Pattern::DefHash(3pm)Regexp patterns related to DefHash✨
- Regexp::Pattern::Example(3pm)An example Regexp::Pattern::* module✨
- Regexp::Pattern::License(3pm)Regular expressions for legal licenses✨
- Regexp::Pattern::License::Parts(3pm)Regular expressions for licensing sub-parts✨
- Regexp::Pattern::Perl(3pm)Regexp patterns related to Perl✨
- Regexp::Pattern::Perl::Dist(3pm)Regexp patterns related to Perl distribution✨
- Regexp::Pattern::Perl::Module(3pm)Regexp patterns related to Perl modules✨
- Regexp::Pattern::Perl::Release(3pm)Regexp patterns related to Perl release✨
- Regexp::RegGrp(3pm)Groups a regular expressions collection✨
- Regexp::Shellish(3pm)Shell-like regular expressions✨
- Regexp::Stringify(3pm)Stringify a Regexp object✨
- Regexp::Tr(3pm)Run-time-compiled tr/// objects.✨
- Regexp::Trie(3pm)builds trie-ized regexp✨
- Regexp::Wildcards(3pm)Converts wildcard expressions to Perl regular expressions.✨
- relative(3pm)Load modules with relative names✨
- Religion::Islam::PrayerTimes(3pm)Calculates Muslim Prayers Times and Sunrise✨
- Remind::PDF(3pm)Render a month's worth of Remind data to PDF✨
- Remind::PDF::Entry(3pm)Representation of one calendar entry✨
- Reply(3pm)read, eval, print, loop, yay!✨
- Reply::App(3pm)command line app runner for Reply✨
- Reply::Config(3pm)config loading for Reply✨
- Reply::Plugin(3pm)base class for Reply plugins✨
- Reply::Plugin::Autocomplete::Commands(3pm)tab completion for reply commands✨
- Reply::Plugin::Autocomplete::Functions(3pm)tab completion for function names✨
- Reply::Plugin::Autocomplete::Globals(3pm)tab completion for global variables✨
- Reply::Plugin::Autocomplete::Keywords(3pm)tab completion for perl keywords✨
- Reply::Plugin::Autocomplete::Lexicals(3pm)tab completion for lexical variables✨
- Reply::Plugin::Autocomplete::Methods(3pm)tab completion for methods✨
- Reply::Plugin::Autocomplete::Packages(3pm)tab completion for package names✨
- Reply::Plugin::AutoRefresh(3pm)automatically refreshes the external code you use✨
- Reply::Plugin::CollapseStack(3pm)display error stack traces only on demand✨
- Reply::Plugin::Colors(3pm)colorize output✨
- Reply::Plugin::DataDump(3pm)format results using Data::Dump✨
- Reply::Plugin::DataDumper(3pm)format results using Data::Dumper✨
- Reply::Plugin::DataPrinter(3pm)format results using Data::Printer✨
- Reply::Plugin::Editor(3pm)command to edit the current line in a text editor✨
- Reply::Plugin::FancyPrompt(3pm)provides a more informative prompt✨
- Reply::Plugin::Hints(3pm)persists lexical hints across input lines✨
- Reply::Plugin::Interrupt(3pm)allows using Ctrl+C to interrupt long-running lines✨
- Reply::Plugin::LexicalPersistence(3pm)persists lexical variables between lines✨
- Reply::Plugin::LoadClass(3pm)attempts to load classes implicitly if possible✨
- Reply::Plugin::Nopaste(3pm)command to nopaste a transcript of the current session✨
- Reply::Plugin::Packages(3pm)persist the current package between lines✨
- Reply::Plugin::Pager(3pm)command to automatically open long results in a pager✨
- Reply::Plugin::ReadLine(3pm)use Term::ReadLine for user input✨
- Reply::Plugin::ResultCache(3pm)retain previous results to be able to refer to them later✨
- Reply::Plugin::Timer(3pm)time commands✨
- Reply::Plugin::TypeTiny(3pm)improved type constraint exceptions in Reply✨
- REST::Application(3pm)A framework for building RESTful web-applications.✨
- REST::Application::Routes(3pm)An implementation of Ruby on Rails type routes.✨
- REST::Client(3pm)A simple client for interacting with RESTful http/https resources✨
- Retry(3pm)✨
- Return::MultiLevel(3pm)Return across multiple call levels✨
- Return::Type(3pm)specify a return type for a function (optionally with coercion)✨
- Return::Value(3pm)(deprecated) polymorphic return values✨
- ReverseProxy::FormFiller(3pm)Let Apache fill and submit any html form in place of the user✨
- Rex(3pm)the friendly automation framework✨
- Rex::Box::Amazon(3pm)Rex/Boxes Amazon Module✨
- Rex::Box::Base(3pm)Rex/Boxes Base Module✨
- Rex::Box::Docker(3pm)Rex/Boxes Docker Module✨
- Rex::Box::KVM(3pm)Rex/Boxes KVM Module✨
- Rex::Box::VBox(3pm)Rex/Boxes VirtualBox Module✨
- Rex::CMDB(3pm)Function to access the CMDB (configuration management database)✨
- Rex::CMDB::YAML(3pm)YAML-based CMDB provider for Rex✨
- Rex::Commands(3pm)All the basic commands✨
- Rex::Commands::Augeas(3pm)An augeas module for (R)?ex✨
- Rex::Commands::Box(3pm)Functions / Class to manage Virtual Machines✨
- Rex::Commands::Cloud(3pm)Cloud Management Commands✨
- Rex::Commands::Cron(3pm)Simple Cron Management✨
- Rex::Commands::DB(3pm)Simple Database Access✨
- Rex::Commands::Download(3pm)Download remote files✨
- Rex::Commands::File(3pm)Transparent File Manipulation✨
- Rex::Commands::Fs(3pm)File system commands✨
- Rex::Commands::Gather(3pm)Hardware and Information gathering✨
- Rex::Commands::Host(3pm)Edit /etc/hosts✨
- Rex::Commands::Inventory(3pm)Get an inventory of your systems✨
- Rex::Commands::Iptables(3pm)Iptable Management Commands✨
- Rex::Commands::Kernel(3pm)Load/Unload Kernel Modules✨
- Rex::Commands::LVM(3pm)Get LVM Information✨
- Rex::Commands::MD5(3pm)Calculate MD5 sum of files✨
- Rex::Commands::Mkfs(3pm)Create filesystems✨
- Rex::Commands::Network(3pm)Network Module✨
- Rex::Commands::Notify(3pm)Notify a resource to execute.✨
- Rex::Commands::Partition(3pm)Partition module✨
- Rex::Commands::Pkg(3pm)Install/Remove Software packages✨
- Rex::Commands::PkgConf(3pm)Configure packages✨
- Rex::Commands::Process(3pm)Process management commands✨
- Rex::Commands::Rsync(3pm)Simple Rsync Frontend✨
- Rex::Commands::Run(3pm)Execute a remote command✨
- Rex::Commands::SCM(3pm)Sourcecontrol for Subversion and Git.✨
- Rex::Commands::Service(3pm)Manage System Services✨
- Rex::Commands::SimpleCheck(3pm)Simple tcp/alive checks✨
- Rex::Commands::Sync(3pm)Sync directories✨
- Rex::Commands::Sysctl(3pm)Manipulate sysctl✨
- Rex::Commands::Tail(3pm)Tail a file Version <= 1.0: All these functions will not be reported. All these functions are not idempotent.✨
- Rex::Commands::Upload(3pm)Upload a local file to a remote server✨
- Rex::Commands::User(3pm)Manipulate users and groups✨
- Rex::Commands::Virtualization(3pm)Virtualization module✨
- Rex::Config(3pm)Handles Rex configuration✨
- Rex::FS::File(3pm)File Class✨
- Rex::Group::Lookup::Command(3pm)read hostnames from a command.✨
- Rex::Group::Lookup::DBI(3pm)read hostnames and groups from a DBI source✨
- Rex::Group::Lookup::File(3pm)read hostnames from a file.✨
- Rex::Group::Lookup::INI(3pm)read host names and groups from an INI style file✨
- Rex::Group::Lookup::XML(3pm)read hostnames and groups from a XML file✨
- Rex::Group::Lookup::YAML(3pm)read hostnames and groups from a YAML file✨
- Rex::Hardware(3pm)Base Class for hardware / information gathering✨
- Rex::Helper::Rexfile::ParamLookup(3pm)A command to manage task parameters. A command to manage task parameters. Additionally it register the parameters as template values. This module also looks inside a CMDB (if present) for a valid key.✨
- Rex::Helper::SSH2::Expect(3pm)An Expect like module for Net::SSH2✨
- Rex::Hook(3pm)manage Rex hooks✨
- Rex::Logger(3pm)Logging Module✨
- Rex::Resource::Common(3pm)✨
- Rex::Resource::firewall(3pm)Firewall functions✨
- Rex::Shared::Var(3pm)Share variables across Rex tasks✨
- Rex::Task(3pm)The Task Object✨
- Rex::Template(3pm)simple template engine✨
- Rex::Template::NG(3pm)simple template engine (replacing Rex::Template)✨
- Rex::Test::Base(3pm)Basic Test Module✨
- Rex::Transaction(3pm)Transaction support✨
- Rex::Virtualization::Docker(3pm)Docker Virtualization Module✨
- Rex::Virtualization::LibVirt(3pm)LibVirt Virtualization Module✨
- Rex::Virtualization::Lxc(3pm)Linux Containers Virtualization Module✨
- Rex::Virtualization::VBox(3pm)VirtualBox Virtualization Module✨
- RG::Blast::Parser(3pm)fast NCBI BLAST parser✨
- RG::Reprof(3pm)protein secondary structure and accessibility predictor✨
- RG::Utils::Conv_hssp2saf(3pm)Rost Lab perl utilities✨
- RG::Utils::Copf(3pm)Rost Lab perl utilities✨
- RG::Utils::Hssp_filter(3pm)Rost Lab perl utilities✨
- Rinci(3pm)Language-neutral metadata for your code✨
- Rinci::FAQ(3pm)FAQ on Rinci✨
- Rinci::function(3pm)Metadata for your functions/methods✨
- Rinci::package(3pm)Metadata for your namespaces/packages✨
- Rinci::resmeta(3pm)Function/method result metadata✨
- Rinci::Transaction(3pm)A transactional system based on functions✨
- Rinci::Upgrading(3pm)Upgrading from previous version of specification✨
- Rinci::variable(3pm)Metadata for your variables✨
- RipeWhois(3pm)Perl extension to retrieve information from RIPE Whois database.✨
- RiveScript(3pm)Rendering Intelligence Very Easily✨
- RiveScript::WD(3pm)RiveScript 2.00 Working Draft (2014/11/30)✨
- RlwrapFilter(3pm)Perl class for rlwrap filters✨
- Role::Basic(3pm)Just roles. Nothing else.✨
- Role::Basic::Philosophy(3pm)Why Role::Basic exists.✨
- Role::Commons(3pm)roles that can be commonly used, for the mutual benefit of all✨
- Role::Commons::Authority(3pm)a class method indicating who published the package✨
- Role::Commons::ObjectID(3pm)an object method providing a unique identifier✨
- Role::Commons::Tap(3pm)an object method which helps with chaining, inspired by Ruby✨
- Role::EventEmitter(3pm)Event emitter role✨
- Role::HasMessage(3pm)a thing with a message method✨
💅
getting it ready, bestie…