section 3 · Library functions 📚
178720 pages · page 459 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
N (continued)
- Net::Server(3pm)Extensible, general Perl server engine✨
- Net::Server::Coro(3pm)A co-operative multithreaded server using Coro✨
- Net::Server::Daemonize(3pm)Safe fork and daemonization utilities✨
- Net::Server::Fork(3pm)Net::Server personality✨
- Net::Server::HTTP(3pm)very basic Net::Server based HTTP server class✨
- Net::Server::INET(3pm)Net::Server personality✨
- Net::Server::IP(3pm)IPv4 / IPv6 compatibility module✨
- Net::Server::Log::Log::Log4perl(3pm)log via Log4perl✨
- Net::Server::Log::Sys::Syslog(3pm)log via Syslog✨
- Net::Server::Mail(3pm)Class to easily create a mail server✨
- Net::Server::Mail::ESMTP(3pm)A module to implement the ESMTP protocol✨
- Net::Server::Mail::ESMTP::Extension(3pm)The base class for ESMTP extension system✨
- Net::Server::Mail::ESMTP::STARTTLS(3pm)A module to support the STARTTLS command in Net::Server::Mail::ESMTP✨
- Net::Server::Mail::ESMTP::XFORWARD(3pm)A module to add support to the XFORWARD command in Net::Server::Mail::ESMTP✨
- Net::Server::Mail::LMTP(3pm)A module to implement the LMTP protocol✨
- Net::Server::Mail::SMTP(3pm)A module to implement the SMTP protocol✨
- Net::Server::Multiplex(3pm)Multiplex several connections within one process✨
- Net::Server::MultiType(3pm)Net::Server personality✨
- Net::Server::PreFork(3pm)Net::Server personality✨
- Net::Server::PreForkSimple(3pm)Net::Server personality✨
- Net::Server::Proto(3pm)Net::Server Protocol compatibility layer✨
- Net::Server::Proto::SSL(3pm)Net::Server SSL protocol.✨
- Net::Server::Proto::SSLEAY(3pm)Custom Net::Server SSL protocol handler based on Net::SSLeay.✨
- Net::Server::Proto::TCP(3pm)Net::Server TCP protocol.✨
- Net::Server::Proto::UDP(3pm)Net::Server UDP protocol.✨
- Net::Server::Proto::UNIX(3pm)Net::Server UNIX protocol.✨
- Net::Server::Proto::UNIXDGRAM(3pm)Net::Server UNIXDGRAM protocol.✨
- Net::Server::PSGI(3pm)basic Net::Server based PSGI HTTP server class✨
- Net::Server::SIG(3pm)adpf - Safer signal handling✨
- Net::Server::Single(3pm)Net::Server personality✨
- Net::Server::SS::PreFork(3pm)a hot-deployable variant of Net::Server::PreFork✨
- Net::Server::Thread(3pm)Net::Server personality✨
- Net::SFTP(3pm)Secure File Transfer Protocol client✨
- Net::SFTP::Attributes(3pm)File/directory attribute container✨
- Net::SFTP::Buffer(3pm)Read/write buffer class✨
- Net::SFTP::Constants(3pm)Exportable SFTP constants✨
- Net::SFTP::Foreign(3pm)SSH File Transfer Protocol client✨
- Net::SFTP::Foreign::Attributes(3pm)File/directory attribute container✨
- Net::SFTP::Foreign::Attributes::Compat(3pm)adapter for Net::SFTP::Attributes compatibility✨
- Net::SFTP::Foreign::Buffer(3pm)Read/write buffer class✨
- Net::SFTP::Foreign::Compat(3pm)Adapter for Net::SFTP compatibility✨
- Net::SFTP::Foreign::Constants(3pm)Constant definitions for Net::SFTP::Foreign✨
- Net::SFTP::Foreign::Local(3pm)access local file system through Net::SFTP::Foreign API.✨
- Net::SFTP::SftpServer(3pm)A Perl implementation of the SFTP subsystem with user access controls✨
- Net::SFTP::Util(3pm)SFTP utility methods✨
- Net::Sieve(3pm)Implementation of managesieve protocol to manage sieve scripts✨
- Net::Sieve::Script(3pm)Parse and write sieve scripts✨
- Net::Sieve::Script::Action(3pm)parse and write actions in sieve scripts✨
- Net::Sieve::Script::Condition(3pm)parse and write conditions in sieve scripts✨
- Net::Sieve::Script::Rule(3pm)parse and write rules in sieve scripts✨
- Net::SIP(3pm)Framework SIP (Voice Over IP, RFC3261)✨
- Net::SIP::Authorize(3pm)enforce authorization of packets✨
- Net::SIP::Blocker(3pm)blocks SIP requests based on method name✨
- Net::SIP::Debug(3pm)debugging of Net::SIP✨
- Net::SIP::Dispatcher(3pm)dispatch SIP packets between legs and endpoint✨
- Net::SIP::Dispatcher::Eventloop(3pm)simple event loop for Net::SIP::Dispatcher✨
- Net::SIP::Dropper(3pm)drops SIP messages based on callback✨
- Net::SIP::Dropper::ByField(3pm)drops SIP messages based on fields in SIP header✨
- Net::SIP::Dropper::ByIPPort(3pm)drops SIP messages based on senders IP and port✨
- Net::SIP::DTMF(3pm)DTMF RTP packet generating and extracting✨
- Net::SIP::Endpoint(3pm)Endpoint for SIP packets (UAC,UAS)✨
- Net::SIP::Endpoint::Context(3pm)Call context for endpoint✨
- Net::SIP::Leg(3pm)Wrapper around Socket for sending and receiving SIP packets✨
- Net::SIP::NATHelper::Base(3pm)rewrite SDP and transport RTP for NAT✨
- Net::SIP::NATHelper::Client(3pm)handle NAT/RTP forwarding using remote process✨
- Net::SIP::NATHelper::Local(3pm)handle NAT/RTP forwarding in local event loop.✨
- Net::SIP::NATHelper::Server(3pm)server for Net::SIP::NATHelper::Client✨
- Net::SIP::Packet(3pm)handling of SIP packets✨
- Net::SIP::ReceiveChain(3pm)handle incoming packet by multiple receivers✨
- Net::SIP::Redirect(3pm)Send redirect to Requests based on lookup at a registrar✨
- Net::SIP::Registrar(3pm)Endpoint for registering SIP clients✨
- Net::SIP::Request(3pm)handling of SIP request packets✨
- Net::SIP::Response(3pm)handling of SIP response packets✨
- Net::SIP::SDP(3pm)Parsing and manipulation of SDP data for SIP✨
- Net::SIP::Simple(3pm)Simple interface for using Net::SIP✨
- Net::SIP::Simple::Call(3pm)call context for Net::SIP::Simple✨
- Net::SIP::Simple::RTP(3pm)simple RTP handling for Net::SIP::Simple✨
- Net::SIP::SocketPool(3pm)manage sockets related to a leg✨
- Net::SIP::StatelessProxy(3pm)Simple implementation of a stateless proxy✨
- Net::SIP::Util(3pm)utility functions used by all of Net::SIP✨
- Net::SMPP(3pm)pure Perl implementation of SMPP 3.4 over TCP✨
- Net::SMTP(3perl)Simple Mail Transfer Protocol Client✨
- Net::SMTP(3pm)Simple Mail Transfer Protocol Client✨
- Net::SMTP::Server(3pm)A native Perl SMTP Server implementation for Perl.✨
- Net::SMTP::Server::Client(3pm)Client session handling for Net::SMTP::Server.✨
- Net::SMTP::Server::Relay(3pm)A simple relay module for Net::SMTP::Server.✨
- Net::SMTP::SSL(3pm)SSL support for Net::SMTP✨
- Net::SMTP::TLS(3pm)An SMTP client supporting TLS and AUTH✨
- Net::SMTP::TLS::ButMaintained(3pm)An SMTP client supporting TLS and AUTH (DEPRECATED, use Net::SMTPS instead)✨
- Net::SMTP_auth(3pm)Simple Mail Transfer Protocol Client with AUTHentication✨
- Net::SMTPS(3pm)SSL/STARTTLS support for Net::SMTP✨
- Net::SNMP(3pm)Object oriented interface to SNMP✨
- Net::SNMP::Interfaces(3pm)provide simple methods to gain interface data via SNMP✨
- Net::SNMP::Interfaces::Details(3pm)Object methods to obtain interface data.✨
- Net::SNPP(3pm)Simple Network Pager Protocol Client✨
- Net::SNPP::Server(3pm)SNPP server library✨
- Net::SOCKS(3pm)a SOCKS client class✨
- Net::SSH(3pm)Perl extension for secure shell✨
- Net::SSH2(3pm)Support for the SSH 2 protocol via libssh2.✨
- Net::SSH2::Channel(3pm)SSH2 channel object✨
- Net::SSH2::Dir(3pm)SSH 2 SFTP directory object✨
- Net::SSH2::File(3pm)SSH2 SFTP file object✨
- Net::SSH2::KnownHosts(3pm)SSH 2 knownhosts object✨
- Net::SSH2::Listener(3pm)SSH 2 listener object✨
- Net::SSH2::PublicKey(3pm)SSH 2 public key object✨
- Net::SSH2::SFTP(3pm)SSH 2 Secure FTP object✨
- Net::SSH::AuthorizedKey(3pm)Virtual Base Class for SSH Public Keys✨
- Net::SSH::AuthorizedKey::Base(3pm)Virtual Base Class for ssh keys✨
- Net::SSH::AuthorizedKey::SSH1(3pm)Net::SSH::AuthorizedKey subclass for ssh-1✨
- Net::SSH::AuthorizedKey::SSH2(3pm)Net::SSH::AuthorizedKey subclass for ssh-2✨
- Net::SSH::AuthorizedKeysFile(3pm)Read and modify ssh's authorized_keys files✨
- Net::SSH::Perl(3pm)Perl client Interface to SSH✨
- Net::SSH::Perl::Agent(3pm)Client for agent authentication✨
- Net::SSH::Perl::Auth(3pm)Base authentication class, plus utility methods✨
- Net::SSH::Perl::Auth::KeyboardInt(3pm)Keyboard-interactive auth plugin✨
- Net::SSH::Perl::Auth::Password(3pm)Password authentication plugin✨
- Net::SSH::Perl::Auth::PublicKey(3pm)Perform publickey authentication✨
- Net::SSH::Perl::Auth::Rhosts(3pm)Perform Rhosts authentication✨
- Net::SSH::Perl::Auth::Rhosts_RSA(3pm)Perform Rhosts-RSA authentication✨
- Net::SSH::Perl::Auth::RSA(3pm)Perform RSA authentication✨
- Net::SSH::Perl::AuthMgr(3pm)Authentication manager/context for SSH-2✨
- Net::SSH::Perl::Buffer(3pm)Low-level read/write buffer class✨
- Net::SSH::Perl::Channel(3pm)SSH2 channel object✨
- Net::SSH::Perl::ChannelMgr(3pm)Manages a list of open channels✨
- Net::SSH::Perl::Cipher(3pm)Base cipher class, plus utility methods✨
- Net::SSH::Perl::Cipher::AES128_CBC(3pm)Wrapper for SSH AES128 CBC support✨
- Net::SSH::Perl::Cipher::AES128_CTR(3pm)Wrapper for SSH AES128 support✨
- Net::SSH::Perl::Cipher::AES192_CBC(3pm)Wrapper for SSH AES128 CBC support✨
- Net::SSH::Perl::Cipher::AES192_CTR(3pm)Wrapper for SSH AES192 support✨
- Net::SSH::Perl::Cipher::AES256_CBC(3pm)Wrapper for SSH AES256 CBC support✨
- Net::SSH::Perl::Cipher::AES256_CTR(3pm)Wrapper for SSH AES256 support✨
- Net::SSH::Perl::Cipher::AES_CBC(3pm)Base class for SSH AES CBC support✨
- Net::SSH::Perl::Cipher::AES_CTR(3pm)Base class for AES support using CTR (counter) mode.✨
- Net::SSH::Perl::Cipher::Blowfish(3pm)Wrapper for SSH Blowfish support✨
- Net::SSH::Perl::Cipher::CBC(3pm)CBC Implementation✨
- Net::SSH::Perl::Cipher::CFB(3pm)CFB Implementation✨
- Net::SSH::Perl::Cipher::ChachaPoly(3pm)provides Chacha20 encryption with Poly1305 Authentication support for Net::SSH::Perl.✨
- Net::SSH::Perl::Cipher::CTR(3pm)Counter Mode Implementation✨
- Net::SSH::Perl::Cipher::DES(3pm)Wrapper for SSH DES support✨
- Net::SSH::Perl::Cipher::DES3(3pm)Wrapper for SSH 3DES support✨
- Net::SSH::Perl::Cipher::IDEA(3pm)Wrapper for SSH IDEA support✨
- Net::SSH::Perl::Cipher::RC4(3pm)RC4 encryption/decryption✨
- Net::SSH::Perl::Comp(3pm)Compression/Decompression base class✨
- Net::SSH::Perl::Comp::Zlib(3pm)Wrapper for SSH Zlib Compression✨
- Net::SSH::Perl::Config(3pm)Load and manage SSH configuration✨
- Net::SSH::Perl::Constants(3pm)Exportable constants✨
- Net::SSH::Perl::Handle(3pm)✨
- Net::SSH::Perl::Kex(3pm)SSH2 Key Exchange✨
- Net::SSH::Perl::Kex::C25519(3pm)Elliptical Curve 25519 Key Exchange using SHA256 hashing.✨
- Net::SSH::Perl::Kex::DH(3pm)Diffie-Hellman Group Agnostic Key Exchange✨
- Net::SSH::Perl::Kex::DH1(3pm)Diffie-Hellman Group 1 Key Exchange (RFC2409 "Second Oakley Group" 1024-bit)✨
- Net::SSH::Perl::Kex::DH14SHA1(3pm)Diffie-Hellman Group 14 Key Exchange (RFC3526 "2048-bit MODP Group")✨
- Net::SSH::Perl::Kex::DH14SHA256(3pm)Diffie-Hellman Group 14 SHA256 Key Exchange (RFC3526 "2048-bit MODP Group")✨
- Net::SSH::Perl::Kex::DH16SHA512(3pm)Diffie-Hellman Group 16 SHA512 Key Exchange (RFC3526 "4096-bit MODP Group")✨
- Net::SSH::Perl::Kex::DH18SHA512(3pm)Diffie-Hellman Group 18 SHA512 Key Exchange (RFC3526 Group 18 "8192-bit MODP Group")✨
- Net::SSH::Perl::Kex::DHGEX(3pm)Diffie-Hellman Group Exchange Base Class.✨
- Net::SSH::Perl::Kex::DHGEXSHA1(3pm)Diffie-Hellman Group Exchange using SHA1 hashing.✨
- Net::SSH::Perl::Kex::DHGEXSHA256(3pm)Diffie-Hellman Group Exchange using SHA256 hashing.✨
- Net::SSH::Perl::Key(3pm)Public or private key abstraction✨
- Net::SSH::Perl::Key::DSA(3pm)DSA key object✨
- Net::SSH::Perl::Key::ECDSA(3pm)Elliptical Curve DSA key object base class✨
- Net::SSH::Perl::Key::Ed25519(3pm)Ed25519 key object✨
- Net::SSH::Perl::Key::RSA(3pm)RSA key object✨
- Net::SSH::Perl::Key::RSA1(3pm)RSA SSH1 key object✨
- Net::SSH::Perl::Mac(3pm)MAC support for SSH2✨
- Net::SSH::Perl::Packet(3pm)Packet layer of SSH protocol✨
- Net::SSH::Perl::Proxy(3pm)Use TCP proxy to connect to a host via SSH✨
- Net::SSH::Perl::SSH1(3pm)SSH1 implementation✨
- Net::SSH::Perl::SSH2(3pm)SSH2 implementation✨
- Net::SSH::Perl::Subsystem::Client(3pm)Subsystem client base class✨
- Net::SSH::Perl::Subsystem::Server(3pm)Server infrastructure for SSH subsystems✨
- Net::SSH::Perl::Util(3pm)Shared utility functions✨
- Net::SSL(3pm)support for Secure Sockets Layer✨
- Net::SSL::ExpireDate(3pm)obtain expiration date of certificate✨
- Net::SSLeay(3pm)Perl bindings for OpenSSL and LibreSSL✨
- Net::SSLeay::Handle(3pm)Perl module that lets SSL (HTTPS) sockets be handled as standard file handles.✨
- Net::SSLGlue(3pm)add/extend SSL support for common perl modules✨
- Net::SSLGlue::FTP(3pm)extend Net::FTP for FTPS (SSL) and IPv6✨
- Net::SSLGlue::LDAP(3pm)proper certificate checking for ldaps in Net::LDAP✨
- Net::SSLGlue::LWP(3pm)proper certificate checking for https in LWP✨
- Net::SSLGlue::POP3(3pm)make Net::POP3 able to use SSL✨
- Net::SSLGlue::SMTP(3pm)make Net::SMTP able to use SSL✨
- Net::SSLGlue::Socket(3pm)socket which can be either SSL or plain IP (IPv4/IPv6)✨
- Net::Statsd(3pm)Perl client for Etsy's statsd daemon✨
- Net::Statsd::Server(3pm)a Perl port of Flickr/Etsy's statsd metrics daemon✨
- Net::Statsd::Server::Changes(3pm)Change history for Net::Statsd::Server Changes in Net::Statsd::Server 0.17 13th June 2014 Fixed percentThreshold configuration directive. It was being ignored, falling back to the default 90%. Added…✨
- Net::Stomp(3pm)A Streaming Text Orientated Messaging Protocol Client✨
- Net::STOMP::Client(3pm)STOMP object oriented client module✨
- Net::STOMP::Client::Auth(3pm)Authentication support for Net::STOMP::Client✨
- Net::STOMP::Client::Connection(3pm)Connection support for Net::STOMP::Client✨
- Net::STOMP::Client::Frame(3pm)Frame support for Net::STOMP::Client✨
- Net::STOMP::Client::HeartBeat(3pm)Heart-beat support for Net::STOMP::Client✨
- Net::STOMP::Client::IO(3pm)Input/Output support for Net::STOMP::Client✨
- Net::STOMP::Client::Peer(3pm)Peer support for Net::STOMP::Client✨
- Net::STOMP::Client::Receipt(3pm)Receipt support for Net::STOMP::Client✨
- Net::STOMP::Client::Tutorial(3pm)Getting started with STOMP and Net::STOMP::Client✨
- Net::STOMP::Client::Version(3pm)Version support for Net::STOMP::Client✨
- Net::Stomp::Frame(3pm)A STOMP Frame✨
- Net::Stomp::StupidLogger(3pm)stub logger✨
- Net::Subnet(3pm)Fast IP-in-subnet matcher for IPv4 and IPv6, CIDR or mask.✨
💅
getting it ready, bestie…