section 3 · Library functions 📚
178720 pages · page 400 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
M (continued)
- Mail::DMARC::Report::Store::SQL::Grammars::MySQL(3pm)Grammar for working with mysql databases.✨
- Mail::DMARC::Report::Store::SQL::Grammars::PostgreSQL(3pm)Grammar for working with pgsql databases.✨
- Mail::DMARC::Report::Store::SQL::Grammars::SQLite(3pm)Grammar for working with sqlite databases.✨
- Mail::DMARC::Report::URI(3pm)a DMARC report URI✨
- Mail::DMARC::Result(3pm)an aggregate report result object✨
- Mail::DMARC::Result::Reason(3pm)policy override reason✨
- Mail::DomainKeys(3pm)A perl implementation of DomainKeys✨
- Mail::Field(3pm)base-class for manipulation of mail header fields✨
- Mail::Field::AddrList(3pm)object representation of e-mail address lists✨
- Mail::Field::Date(3pm)a date header field✨
- Mail::Field::Generic(3pm)implementation for inspecific fields✨
- Mail::Field::Received(3pm)mostly RFC822-compliant parser of Received headers✨
- Mail::Filter(3pm)filter mail through multiple subroutines✨
- Mail::GnuPG(3pm)Process email with GPG.✨
- Mail::Header(3pm)manipulate MIME headers✨
- Mail::Identity(3pm)an e-mail role✨
- Mail::IMAPClient(3pm)An IMAP Client API✨
- Mail::IMAPClient::BodyStructure(3pm)parse fetched results✨
- Mail::IMAPClient::BodyStructure::Parse(3pm)used internally by Mail::IMAPClient::BodyStructure✨
- Mail::IMAPClient::MessageSet(3pm)ranges of message sequence numbers✨
- Mail::IMAPClient::Thread(3pm)used internally by Mail::IMAPClient->thread✨
- Mail::IMAPTalk(3pm)IMAP client interface with lots of features✨
- Mail::Internet(3pm)manipulate email messages✨
- Mail::JMAPTalk(3pm)Basic interface to talk to JMAP Servers✨
- Mail::ListDetector(3pm)Perl extension for detecting mailing list messages✨
- Mail::ListDetector::Detector::AutoShare(3pm)AutoShare message detector✨
- Mail::ListDetector::Detector::Base(3pm)base class for mailing list detectors✨
- Mail::ListDetector::Detector::CommuniGate(3pm)CommuniGate message detector✨
- Mail::ListDetector::Detector::CommuniGatePro(3pm)CommuniGate Pro message detector✨
- Mail::ListDetector::Detector::Ecartis(3pm)Ecartis message detector✨
- Mail::ListDetector::Detector::Ezmlm(3pm)Ezmlm message detector✨
- Mail::ListDetector::Detector::Fml(3pm)FML message detector✨
- Mail::ListDetector::Detector::GoogleGroups(3pm)Google Groups message detector✨
- Mail::ListDetector::Detector::LetterRip(3pm)LetterRip message detector✨
- Mail::ListDetector::Detector::Listar(3pm)Listar message detector✨
- Mail::ListDetector::Detector::Listbox(3pm)Listbox message detector✨
- Mail::ListDetector::Detector::Listserv(3pm)Listserv message detector✨
- Mail::ListDetector::Detector::ListSTAR(3pm)ListSTAR message detector✨
- Mail::ListDetector::Detector::Lyris(3pm)Lyris message detector✨
- Mail::ListDetector::Detector::Mailman(3pm)Mailman message detector✨
- Mail::ListDetector::Detector::Majordomo(3pm)Majordomo message detector✨
- Mail::ListDetector::Detector::Onelist(3pm)ONElist message detector✨
- Mail::ListDetector::Detector::RFC2369(3pm)RFC2369 message detector✨
- Mail::ListDetector::Detector::RFC2919(3pm)RFC2919 message detector✨
- Mail::ListDetector::Detector::Smartlist(3pm)Smartlist message detector✨
- Mail::ListDetector::Detector::Yahoogroups(3pm)Yahoo! Groups message detector✨
- Mail::ListDetector::List(3pm)an object representing a mailing list✨
- Mail::Mailer(3pm)send simple emails✨
- Mail::Mbox::MessageParser(3pm)A fast and simple mbox folder reader✨
- Mail::Mbox::MessageParser::Cache(3pm)A cache-based mbox folder reader✨
- Mail::Mbox::MessageParser::Config(3pm)An internal configuration class✨
- Mail::Mbox::MessageParser::Grep(3pm)A GNU grep-based mbox folder reader✨
- Mail::Mbox::MessageParser::MetaInfo(3pm)A cache for folder metadata✨
- Mail::Mbox::MessageParser::Perl(3pm)A Perl-based mbox folder reader✨
- Mail::MboxParser(3pm)read-only access to UNIX-mailboxes✨
- Mail::MboxParser::Base(3pm)base clase for all other classes✨
- Mail::MboxParser::Mail(3pm)Provide mail-objects and methods upon✨
- Mail::MboxParser::Mail::Body(3pm)rudimentary mail-body object✨
- Mail::MboxParser::Mail::Convertable(3pm)convert mail for sending etc.✨
- Mail::Message(3pm)general message object✨
- Mail::Message::Body(3pm)the data of a body in a message✨
- Mail::Message::Body::Construct(3pm)adds functionality to Mail::Message::Body✨
- Mail::Message::Body::Delayed(3pm)body of a Mail::Message but not read yet.✨
- Mail::Message::Body::Encode(3pm)organize general message encodings✨
- Mail::Message::Body::File(3pm)body of a message temporarily stored in a file✨
- Mail::Message::Body::Lines(3pm)body of a Mail::Message stored as array of lines✨
- Mail::Message::Body::Multipart(3pm)body of a message with attachments✨
- Mail::Message::Body::Nested(3pm)body of a message which contains a message✨
- Mail::Message::Body::String(3pm)body of a Mail::Message stored as single string✨
- Mail::Message::Construct(3pm)extends the functionality of a Mail::Message✨
- Mail::Message::Construct::Bounce(3pm)bounce a Mail::Message✨
- Mail::Message::Construct::Build(3pm)building a Mail::Message from components✨
- Mail::Message::Construct::Forward(3pm)forwarding a Mail::Message✨
- Mail::Message::Construct::Read(3pm)read a Mail::Message from a file handle✨
- Mail::Message::Construct::Rebuild(3pm)modify a Mail::Message✨
- Mail::Message::Construct::Reply(3pm)reply to a Mail::Message✨
- Mail::Message::Construct::Text(3pm)capture a Mail::Message as text✨
- Mail::Message::Convert(3pm)conversions between message types✨
- Mail::Message::Convert::EmailSimple(3pm)translate Mail::Message to Email::Simple vv✨
- Mail::Message::Convert::Html(3pm)Format messages in HTML✨
- Mail::Message::Convert::HtmlFormatPS(3pm)Convert HTML into PostScript✨
- Mail::Message::Convert::HtmlFormatText(3pm)Convert HTML into Text✨
- Mail::Message::Convert::MailInternet(3pm)translate Mail::Message to Mail::Internet vv✨
- Mail::Message::Convert::MimeEntity(3pm)translate Mail::Message to MIME::Entity vv✨
- Mail::Message::Convert::TextAutoformat(3pm)Reformat plain text messages✨
- Mail::Message::Dummy(3pm)a placeholder for a missing messages✨
- Mail::Message::Field(3pm)one line of a message header✨
- Mail::Message::Field::Address(3pm)One e-mail address✨
- Mail::Message::Field::Addresses(3pm)Fields with e-mail addresses✨
- Mail::Message::Field::AddrGroup(3pm)A group of Mail::Message::Field::Address objects✨
- Mail::Message::Field::Attribute(3pm)one attribute of a full field✨
- Mail::Message::Field::AuthResults(3pm)message header field authentication result✨
- Mail::Message::Field::Date(3pm)message header field with uris✨
- Mail::Message::Field::DKIM(3pm)message header field for dkim signatures✨
- Mail::Message::Field::Fast(3pm)one line of a message header✨
- Mail::Message::Field::Flex(3pm)one line of a message header✨
- Mail::Message::Field::Full(3pm)construct one smart line in a message header✨
- Mail::Message::Field::Structured(3pm)one line of a structured message header✨
- Mail::Message::Field::Unstructured(3pm)smart unstructured field✨
- Mail::Message::Field::URIs(3pm)message header field with uris✨
- Mail::Message::Head(3pm)the header of one message✨
- Mail::Message::Head::Complete(3pm)the header of one message✨
- Mail::Message::Head::Delayed(3pm)a not-read header of a Mail::Message✨
- Mail::Message::Head::FieldGroup(3pm)a sub set of fields in a header✨
- Mail::Message::Head::ListGroup(3pm)mailinglist related header fields✨
- Mail::Message::Head::Partial(3pm)subset of header information of a message✨
- Mail::Message::Head::ResentGroup(3pm)header fields tracking message delivery✨
- Mail::Message::Head::SpamGroup(3pm)spam fighting related header fields✨
- Mail::Message::Head::Subset(3pm)subset of header information of a message✨
- Mail::Message::Part(3pm)a part of a message, but a message by itself✨
- Mail::Message::Replace::MailHeader(3pm)fake Mail::Header✨
- Mail::Message::Replace::MailInternet(3pm)fake Mail::Internet✨
- Mail::Message::TransferEnc(3pm)message transfer encoder/decoder✨
- Mail::Message::TransferEnc::Base64(3pm)encode/decode base64 message bodies✨
- Mail::Message::TransferEnc::Binary(3pm)encode/decode binary message bodies✨
- Mail::Message::TransferEnc::EightBit(3pm)encode/decode 8bit message bodies✨
- Mail::Message::TransferEnc::QuotedPrint(3pm)handle quoted-printable message bodies✨
- Mail::Message::TransferEnc::SevenBit(3pm)encode/decode 7bit message bodies✨
- Mail::Message::Wrapper::SpamAssassin(3pm)Connect a Mail::Message with Mail::SpamAssassin✨
- Mail::Milter(3pm)Perl extension modules for mail filtering via milter✨
- Mail::Milter::Chain(3pm)Perl extension for chaining milter callbacks✨
- Mail::Milter::ContextWrapper(3pm)Perl extension for wrappering the milter context✨
- Mail::Milter::Module::AccessDB(3pm)emulator for Sendmail "access_db" in a milter✨
- Mail::Milter::Module::ConnectDNSBL(3pm)milter to accept/reject connecting hosts matching DNSBLs✨
- Mail::Milter::Module::ConnectMatchesHostname(3pm)milter to accept/reject connecting hosts matching regex(es)✨
- Mail::Milter::Module::ConnectRegex(3pm)milter to accept/reject connecting hosts matching regex(es)✨
- Mail::Milter::Module::HeaderFromMissing(3pm)milter to reject messages missing a From: header✨
- Mail::Milter::Module::HeaderRegex(3pm)milter to accept/reject messages with certain headers✨
- Mail::Milter::Module::HeaderValidateMIME(3pm)enforce MIME header conformance✨
- Mail::Milter::Module::HeloRawLiteral(3pm)milter to check for an IP literal without brackets in HELO✨
- Mail::Milter::Module::HeloRegex(3pm)milter to accept/reject connections with certain HELO values✨
- Mail::Milter::Module::HeloUnqualified(3pm)milter to check for an unqualified HELO name✨
- Mail::Milter::Module::MailBogusNull(3pm)milter to reject null-sender mail to multiple recipients✨
- Mail::Milter::Module::MailDomainDNSBL(3pm)milter to accept/reject mail whose sender domain matches a DNSBL✨
- Mail::Milter::Module::MailDomainDotMX(3pm)milter to reject mail whose sender domain publishes a null MX record✨
- Mail::Milter::Module::SPF(3pm)milter to use Sender Policy Framework for accept/reject✨
- Mail::Milter::Module::VirusBounceSpew(3pm)milter to reject antivirus messages typically sent to forged "senders"✨
- Mail::Milter::Object(3pm)Perl extension to encapsulate a milter in an object✨
- Mail::Milter::Wrapper(3pm)Perl extension for wrappering milter objects✨
- Mail::Milter::Wrapper::DecodeSRS(3pm)milter wrapper to decode SRS-encoded return path✨
- Mail::Milter::Wrapper::DeferToRCPT(3pm)milter wrapper to delay failure returns✨
- Mail::Milter::Wrapper::RejectMsgEditor(3pm)milter wrapper to edit rejection messages✨
- Mail::MIMEDefang(3)email filtering milter✨
- Mail::MIMEDefang::Actions(3)actions methods for email filters✨
- Mail::MIMEDefang::Antispam(3)antispam related methods for email filters✨
- Mail::MIMEDefang::Antivirus(3)Antivirus interface methods for email filters✨
- Mail::MIMEDefang::Async(3)Asynchronous I/O engine for MIMEDefang external checks✨
- Mail::MIMEDefang::Async::Checks(3)Pre-built check descriptors for Mail::MIMEDefang::Async✨
- Mail::MIMEDefang::Async::Results(3)Interpret async check output for MIMEDefang✨
- Mail::MIMEDefang::Authres(3)Authentication Results interface for MIMEDefang✨
- Mail::MIMEDefang::BIMI(3)Brand Indicators for Message Identification support for MIMEDefang✨
- Mail::MIMEDefang::DKIM(3)DKIM interface for MIMEDefang✨
- Mail::MIMEDefang::DKIM::ARC(3)ARC interface for MIMEDefang✨
- Mail::MIMEDefang::Mail(3)Mail and SMTP related methods for email filters✨
- Mail::MIMEDefang::MIME(3)MIME objects interface methods for email filters✨
- Mail::MIMEDefang::Net(3)Network related methods for email filters✨
- Mail::MIMEDefang::RFC2822(3)Dates related methods for email filters✨
- Mail::MIMEDefang::SPF(3)Sender Policy Framework interface for MIMEDefang✨
- Mail::MIMEDefang::TLSPolicy(3)MTA-STS and DANE/TLSA policy checks for MIMEDefang✨
- Mail::MIMEDefang::Unit(3)Methods used by MIMEDefang regression tests✨
- Mail::MIMEDefang::Utils(3)Support methods used internally or by email filters✨
- Mail::MtPolicyd(3pm)a modular policy daemon for postfix✨
- Mail::MtPolicyd::AddressList(3pm)a class for IP address lists✨
- Mail::MtPolicyd::Client(3pm)a policyd client class✨
- Mail::MtPolicyd::Client::App(3pm)application interface class for Mail::MtPolicyd::Client✨
- Mail::MtPolicyd::Client::Request(3pm)a postfix policyd client request class✨
- Mail::MtPolicyd::Client::Response(3pm)a postfix policyd client response class✨
- Mail::MtPolicyd::Connection(3pm)base class for mtpolicyd connection modules✨
- Mail::MtPolicyd::Connection::Ldap(3pm)a LDAP connection plugin for mtpolicyd✨
- Mail::MtPolicyd::Connection::Memcached(3pm)a memcached connection plugin for mtpolicyd✨
- Mail::MtPolicyd::Connection::Redis(3pm)a mtpolicy connection for redis databases✨
- Mail::MtPolicyd::Connection::Sql(3pm)Connection pool sql connection object✨
- Mail::MtPolicyd::ConnectionPool(3pm)a singleton to hold all configure connections✨
- Mail::MtPolicyd::Cookbook(3pm)How to cook with mtpolicyd✨
- Mail::MtPolicyd::Cookbook::BasicPlugin(3pm)how to write your own mtpolicyd plugin✨
- Mail::MtPolicyd::Cookbook::ExtendedPlugin(3pm)how to achieve certain tasks within a plugin✨
- Mail::MtPolicyd::Cookbook::HowtoAccountingQuota(3pm)How to setup smtp level accounting and quotas✨
- Mail::MtPolicyd::Cookbook::Installation(3pm)How to install mtpolicyd✨
- Mail::MtPolicyd::Plugin(3pm)a base class for plugins✨
- Mail::MtPolicyd::Plugin::Accounting(3pm)mtpolicyd plugin for accounting in sql tables✨
- Mail::MtPolicyd::Plugin::Action(3pm)mtpolicyd plugin which just returns an action✨
- Mail::MtPolicyd::Plugin::AddScoreHeader(3pm)mtpolicyd plugin for adding the score as header to the mail✨
- Mail::MtPolicyd::Plugin::ClearFields(3pm)mtpolicyd plugin to unset session variables✨
- Mail::MtPolicyd::Plugin::Condition(3pm)mtpolicyd plugin for conditions based on session values✨
- Mail::MtPolicyd::Plugin::CtIpRep(3pm)mtpolicyd plugin for the Commtouch IP reputation service (ctipd)✨
- Mail::MtPolicyd::Plugin::DBL(3pm)mtpolicyd plugin for checking helo,sender domain,rdns against an DBL✨
- Mail::MtPolicyd::Plugin::Eval(3pm)mtpolicyd plugin to capture the output of plugins✨
- Mail::MtPolicyd::Plugin::Fail2Ban(3pm)mtpolicyd plugin to block an address with fail2ban✨
- Mail::MtPolicyd::Plugin::GeoIPAction(3pm)mtpolicyd plugin for checking geo information of an ip✨
- Mail::MtPolicyd::Plugin::GeoIPLookup(3pm)mtpolicyd plugin for checking geo information of an client_address✨
- Mail::MtPolicyd::Plugin::Greylist(3pm)This plugin implements a greylisting mechanism with an auto whitelist.✨
- Mail::MtPolicyd::Plugin::Greylist::AWL::Base(3pm)base class for grelisting AWL storage backends✨
- Mail::MtPolicyd::Plugin::Greylist::AWL::Redis(3pm)backend for redis greylisting awl storage✨
- Mail::MtPolicyd::Plugin::Greylist::AWL::Sql(3pm)backend for SQL greylisting awl storage✨
- Mail::MtPolicyd::Plugin::Greylist::Ticket::Base(3pm)base class for greylisting ticket storage backends✨
- Mail::MtPolicyd::Plugin::Greylist::Ticket::Memcached(3pm)greylisting ticket storage backend for memcached✨
- Mail::MtPolicyd::Plugin::Greylist::Ticket::Redis(3pm)greylisting ticket storage backend for redis✨
- Mail::MtPolicyd::Plugin::Honeypot(3pm)mtpolicyd plugin for creating an honeypot✨
- Mail::MtPolicyd::Plugin::LdapUserConfig(3pm)mtpolicyd plugin for retrieving per user configuration from LDAP✨
- Mail::MtPolicyd::Plugin::PostfixMap(3pm)mtpolicyd plugin for accessing a postfix access map✨
💅
getting it ready, bestie…