section 3 · Library functions 📚
178720 pages · page 117 of 894
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
C (continued)
- critcl_sources(3tcl)Critcl - How To Get The Sources✨
- critcl_tcl9(3tcl)How To Adapt Critcl Packages for Tcl 9✨
- critcl_usingit(3tcl)Using Critcl✨
- critcl_util(3tcl)CriTcl - Utilities✨
- critical(3)✨
- criticism(3pm)Perl pragma to enforce coding standards and best-practices✨
- critnib(3)an ordered map data structure with lock-free reads✨
- CRL_DIST_POINTS_free(3)ASN1 object utilities✨
- CRL_DIST_POINTS_free(33ssl)ASN1 object utilities✨
- CRL_DIST_POINTS_free(3ossl)ASN1 object utilities✨
- CRL_DIST_POINTS_free(3ssl)ASN1 object utilities✨
- CRL_DIST_POINTS_new(3)ASN1 object utilities✨
- CRL_DIST_POINTS_new(33ssl)ASN1 object utilities✨
- CRL_DIST_POINTS_new(3ossl)ASN1 object utilities✨
- CRL_DIST_POINTS_new(3ssl)ASN1 object utilities✨
- cron(3tcl)Tool for automating the period callback of commands✨
- crop_image(3)Crop image to specific dimensions✨
- cropen(3)the extended API of QDBM✨
- cross(3G)calculate the cross product of two vectors✨
- cross(3clc)Cross product. float4 cross(float4 p0, float4 p1); float3 cross(float3 p0, float3 p1); double4 cross(double4 p0, double4 p1); double3 cross(double3 p0, double3 p1); half4 cross (half4 p0, half4 p1)…✨
- cross_buf_id(3)✨
- cross_buf_ptr(3)✨
- cross_product(3)Calculates the cross product. Allegro game programming library.✨
- cross_product(3alleg4)Calculates the cross product. Allegro game programming library.✨
- cross_product_f(3)Calculates the cross product. Allegro game programming library.✨
- cross_product_f(3alleg4)Calculates the cross product. Allegro game programming library.✨
- crosshair(3tk)Crosshairs for Tk canvas✨
- CROT(3)✨
- crot(3)✨
- crot.f(3)✨
- CROTG(3)✨
- crotg(3)✨
- crotg.f(3)✨
- crotg.f90(3)✨
- CRQT01(3)✨
- crqt01(3)✨
- crqt01.f(3)✨
- CRQT02(3)✨
- crqt02(3)✨
- crqt02.f(3)✨
- CRQT03(3)✨
- crqt03(3)✨
- crqt03.f(3)✨
- CRSCL(3)✨
- crscl(3)✨
- crscl.f(3)✨
- crypt(3)passphrase hashing✨
- crypt(3p)string encoding function (CRYPT)✨
- crypt(3posix)string encoding function (CRYPT)✨
- crypt(3trf)Password hashing based on "crypt"✨
- Crypt::Argon2(3pm)Perl interface to the Argon2 key derivation functions✨
- Crypt::ASN1(3pm)DER ASN.1 parser and encoder based on libtomcrypt✨
- Crypt::AuthEnc(3pm)[internal only]✨
- Crypt::AuthEnc::CCM(3pm)Authenticated encryption in CCM mode✨
- Crypt::AuthEnc::ChaCha20Poly1305(3pm)Authenticated encryption in ChaCha20-Poly1305 mode✨
- Crypt::AuthEnc::EAX(3pm)Authenticated encryption in EAX mode✨
- Crypt::AuthEnc::GCM(3pm)Authenticated encryption in GCM mode✨
- Crypt::AuthEnc::GCMSIV(3pm)Authenticated encryption in AES-GCM-SIV mode (RFC 8452)✨
- Crypt::AuthEnc::OCB(3pm)Authenticated encryption in OCBv3 mode✨
- Crypt::AuthEnc::SIV(3pm)Authenticated encryption in SIV mode✨
- Crypt::AuthEnc::XChaCha20Poly1305(3pm)Authenticated encryption in XChaCha20-Poly1305 mode✨
- Crypt::Bcrypt(3pm)A modern bcrypt implementation✨
- Crypt::Blowfish(3pm)Perl Blowfish encryption module✨
- Crypt::Blowfish_PP(3pm)Blowfish encryption algorithm implemented purely in Perl✨
- Crypt::CAST5(3pm)CAST5 block cipher✨
- Crypt::CAST5_PP(3pm)CAST5 block cipher in pure Perl✨
- Crypt::CBC(3pm)Encrypt Data with Cipher Block Chaining Mode✨
- Crypt::Checksum(3pm)[internal only]✨
- Crypt::Checksum::Adler32(3pm)Compute Adler32 checksum✨
- Crypt::Checksum::CRC32(3pm)Compute CRC32 checksum✨
- Crypt::Cipher(3pm)Generic interface to cipher functions✨
- Crypt::Cipher::AES(3pm)Symmetric cipher AES (aka Rijndael), key size: 128/192/256 bits✨
- Crypt::Cipher::Anubis(3pm)Symmetric cipher Anubis, key size: 128-320 bits✨
- Crypt::Cipher::ARIA(3pm)Symmetric cipher ARIA, key size: 128/192/256 bits✨
- Crypt::Cipher::Blowfish(3pm)Symmetric cipher Blowfish, key size: 64-576 bits✨
- Crypt::Cipher::Camellia(3pm)Symmetric cipher Camellia, key size: 128/192/256 bits✨
- Crypt::Cipher::CAST5(3pm)Symmetric cipher CAST5 (aka CAST-128), key size: 40-128 bits✨
- Crypt::Cipher::DES(3pm)Symmetric cipher DES, key size: 64[56] bits✨
- Crypt::Cipher::DES_EDE(3pm)Symmetric cipher DES_EDE (aka Triple-DES, 3DES), key size: 192[168] bits✨
- Crypt::Cipher::IDEA(3pm)Symmetric cipher IDEA, key size: 128 bits✨
- Crypt::Cipher::KASUMI(3pm)Symmetric cipher KASUMI, key size: 128 bits✨
- Crypt::Cipher::Khazad(3pm)Symmetric cipher Khazad, key size: 128 bits✨
- Crypt::Cipher::MULTI2(3pm)Symmetric cipher MULTI2, key size: 320 bits✨
- Crypt::Cipher::Noekeon(3pm)Symmetric cipher Noekeon, key size: 128 bits✨
- Crypt::Cipher::RC2(3pm)Symmetric cipher RC2, key size: 40-1024 bits✨
- Crypt::Cipher::RC5(3pm)Symmetric cipher RC5, key size: 64-1024 bits✨
- Crypt::Cipher::RC6(3pm)Symmetric cipher RC6, key size: 64-1024 bits✨
- Crypt::Cipher::SAFER_K128(3pm)Symmetric cipher SAFER_K128, key size: 128 bits✨
- Crypt::Cipher::SAFER_K64(3pm)Symmetric cipher SAFER_K64, key size: 64 bits✨
- Crypt::Cipher::SAFER_SK128(3pm)Symmetric cipher SAFER_SK128, key size: 128 bits✨
- Crypt::Cipher::SAFER_SK64(3pm)Symmetric cipher SAFER_SK64, key size: 64 bits✨
- Crypt::Cipher::SAFERP(3pm)Symmetric cipher SAFER+, key size: 128/192/256 bits✨
- Crypt::Cipher::SEED(3pm)Symmetric cipher SEED, key size: 128 bits✨
- Crypt::Cipher::Serpent(3pm)Symmetric cipher Serpent, key size: 128/192/256 bits✨
- Crypt::Cipher::Skipjack(3pm)Symmetric cipher Skipjack, key size: 80 bits✨
- Crypt::Cipher::SM4(3pm)Symmetric cipher SM4, key size: 128 bits✨
- Crypt::Cipher::Twofish(3pm)Symmetric cipher Twofish, key size: 128/192/256 bits✨
- Crypt::Cipher::XTEA(3pm)Symmetric cipher XTEA, key size: 128 bits✨
- Crypt::CipherSaber(3pm)Perl module implementing CipherSaber encryption.✨
- Crypt::Cracklib(3pm)Perl interface to Alec Muffett's Cracklib.✨
- Crypt::Curve25519(3pm)Generate shared secret using elliptic-curve Diffie-Hellman function✨
- Crypt::DES(3pm)Perl DES encryption module✨
- Crypt::DES_EDE3(3pm)Triple-DES EDE encryption/decryption✨
- Crypt::DH(3pm)Diffie-Hellman key exchange system✨
- Crypt::DH::GMP(3pm)Crypt::DH Using GMP Directly✨
- Crypt::DH::GMP::Compat(3pm)Compatibility Mode For Crypt::DH✨
- Crypt::Digest(3pm)Generic interface to hash/digest functions✨
- Crypt::Digest::BLAKE2b_160(3pm)Hash function BLAKE2b [size: 160 bits]✨
- Crypt::Digest::BLAKE2b_256(3pm)Hash function BLAKE2b [size: 256 bits]✨
- Crypt::Digest::BLAKE2b_384(3pm)Hash function BLAKE2b [size: 384 bits]✨
- Crypt::Digest::BLAKE2b_512(3pm)Hash function BLAKE2b [size: 512 bits]✨
- Crypt::Digest::BLAKE2s_128(3pm)Hash function BLAKE2s [size: 128 bits]✨
- Crypt::Digest::BLAKE2s_160(3pm)Hash function BLAKE2s [size: 160 bits]✨
- Crypt::Digest::BLAKE2s_224(3pm)Hash function BLAKE2s [size: 224 bits]✨
- Crypt::Digest::BLAKE2s_256(3pm)Hash function BLAKE2s [size: 256 bits]✨
- Crypt::Digest::BLAKE3(3pm)Hash function BLAKE3 [size: 256 bits]✨
- Crypt::Digest::CHAES(3pm)Hash function - CipherHash based on AES [size: 128 bits]✨
- Crypt::Digest::KangarooTwelve(3pm)XOF (extendable output) hash function KangarooTwelve✨
- Crypt::Digest::Keccak224(3pm)Hash function Keccak-224 [size: 224 bits]✨
- Crypt::Digest::Keccak256(3pm)Hash function Keccak-256 [size: 256 bits]✨
- Crypt::Digest::Keccak384(3pm)Hash function Keccak-384 [size: 384 bits]✨
- Crypt::Digest::Keccak512(3pm)Hash function Keccak-512 [size: 512 bits]✨
- Crypt::Digest::MD2(3pm)Hash function MD2 [size: 128 bits]✨
- Crypt::Digest::MD4(3pm)Hash function MD4 [size: 128 bits]✨
- Crypt::Digest::MD5(3pm)Hash function MD5 [size: 128 bits]✨
- Crypt::Digest::RIPEMD128(3pm)Hash function RIPEMD-128 [size: 128 bits]✨
- Crypt::Digest::RIPEMD160(3pm)Hash function RIPEMD-160 [size: 160 bits]✨
- Crypt::Digest::RIPEMD256(3pm)Hash function RIPEMD-256 [size: 256 bits]✨
- Crypt::Digest::RIPEMD320(3pm)Hash function RIPEMD-320 [size: 320 bits]✨
- Crypt::Digest::SHA1(3pm)Hash function SHA-1 [size: 160 bits]✨
- Crypt::Digest::SHA224(3pm)Hash function SHA-224 [size: 224 bits]✨
- Crypt::Digest::SHA256(3pm)Hash function SHA-256 [size: 256 bits]✨
- Crypt::Digest::SHA384(3pm)Hash function SHA-384 [size: 384 bits]✨
- Crypt::Digest::SHA3_224(3pm)Hash function SHA3-224 [size: 224 bits]✨
- Crypt::Digest::SHA3_256(3pm)Hash function SHA3-256 [size: 256 bits]✨
- Crypt::Digest::SHA3_384(3pm)Hash function SHA3-384 [size: 384 bits]✨
- Crypt::Digest::SHA3_512(3pm)Hash function SHA3-512 [size: 512 bits]✨
- Crypt::Digest::SHA512(3pm)Hash function SHA-512 [size: 512 bits]✨
- Crypt::Digest::SHA512_224(3pm)Hash function SHA-512/224 [size: 224 bits]✨
- Crypt::Digest::SHA512_256(3pm)Hash function SHA-512/256 [size: 256 bits]✨
- Crypt::Digest::SHAKE(3pm)Hash functions SHAKE128, SHAKE256 from SHA3 family✨
- Crypt::Digest::SM3(3pm)Hash function SM3 [size: 256 bits]✨
- Crypt::Digest::Tiger192(3pm)Hash function Tiger-192 [size: 192 bits]✨
- Crypt::Digest::TurboSHAKE(3pm)XOF (extendable output) hash functions TurboSHAKE128 and TurboSHAKE256✨
- Crypt::Digest::Whirlpool(3pm)Hash function Whirlpool [size: 512 bits]✨
- Crypt::DSA(3pm)DSA Signatures and Key Generation✨
- Crypt::DSA::Key(3pm)DSA key✨
- Crypt::DSA::Key::PEM(3pm)Read/write DSA PEM files✨
- Crypt::DSA::Key::SSH2(3pm)Read/write DSA SSH2 files✨
- Crypt::DSA::KeyChain(3pm)DSA key generation system✨
- Crypt::DSA::Signature(3pm)DSA signature object✨
- Crypt::DSA::Util(3pm)DSA Utility functions✨
- Crypt::ECB(3pm)Use block ciphers using ECB mode✨
- Crypt::Eksblowfish(3pm)the Eksblowfish block cipher✨
- Crypt::Eksblowfish::Bcrypt(3pm)Blowfish-based Unix crypt() password hash✨
- Crypt::Eksblowfish::Blowfish(3pm)Blowfish block cipher via Eksblowfish engine✨
- Crypt::Eksblowfish::Family(3pm)Eksblowfish cipher family✨
- Crypt::Eksblowfish::Subkeyed(3pm)Blowfish/Eksblowfish with access to subkeys✨
- Crypt::Eksblowfish::Uklblowfish(3pm)Blowfish cipher with unrestricted key length✨
- Crypt::Format(3pm)Conversion utilities for encryption applications✨
- Crypt::GCrypt(3pm)Perl interface to the GNU Cryptographic library✨
- Crypt::GCrypt::MPI(3pm)Perl interface to multi-precision integers from the GNU Cryptographic library✨
- Crypt::GeneratePassword(3pm)generate secure random pronounceable passwords✨
- Crypt::GPG(3pm)An Object Oriented Interface to GnuPG.✨
- Crypt::HCE_SHA(3pm)Perl extension implementing one way hash chaining encryption using SHA✨
- Crypt::HSXKPasswd(3pm)A secure memorable password generator inspired by Steve Gibson's Passord Haystacks (<https://www.grc.com/haystack.htm>), and the famous XKCD password cartoon (<https://xkcd.com/936/>).✨
- Crypt::IDEA(3pm)Perl interface to IDEA block cipher✨
- Crypt::JWT(3pm)JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516✨
- Crypt::KeyDerivation(3pm)PBKDF1, PBKDF2, HKDF, Bcrypt, Scrypt, Argon2 key derivation functions✨
- Crypt::KeyWrap(3pm)Key management/wrapping algorithms defined in RFC7518 (JWA)✨
- Crypt::Mac(3pm)[internal only]✨
- Crypt::Mac::BLAKE2b(3pm)Message authentication code BLAKE2b MAC (RFC 7693)✨
- Crypt::Mac::BLAKE2s(3pm)Message authentication code BLAKE2s MAC (RFC 7693)✨
- Crypt::Mac::F9(3pm)Message authentication code F9✨
- Crypt::Mac::HMAC(3pm)Message authentication code HMAC✨
- Crypt::Mac::KMAC(3pm)Message authentication code KMAC (NIST SP 800-185)✨
- Crypt::Mac::OMAC(3pm)Message authentication code OMAC✨
- Crypt::Mac::Pelican(3pm)Message authentication code Pelican (AES based MAC)✨
- Crypt::Mac::PMAC(3pm)Message authentication code PMAC✨
- Crypt::Mac::Poly1305(3pm)Message authentication code Poly1305 (RFC 7539)✨
- Crypt::Mac::XCBC(3pm)Message authentication code XCBC (RFC 3566)✨
- Crypt::Misc(3pm)miscellaneous functions related to (or used by) CryptX✨
- Crypt::Mode(3pm)[internal only]✨
- Crypt::Mode::CBC(3pm)Block cipher mode CBC [Cipher-block chaining]✨
- Crypt::Mode::CFB(3pm)Block cipher mode CFB [Cipher feedback]✨
- Crypt::Mode::CTR(3pm)Block cipher mode CTR [Counter mode]✨
- Crypt::Mode::ECB(3pm)Block cipher mode ECB [Electronic codebook]✨
- Crypt::Mode::OFB(3pm)Block cipher mode OFB [Output feedback]✨
- Crypt::Mode::XTS(3pm)Block cipher mode XTS [XEX-based tweaked-codebook mode with ciphertext stealing]✨
- Crypt::MySQL(3pm)emulate MySQL PASSWORD() function.✨
- Crypt::OpenSSL::AES(3pm)A Perl wrapper around OpenSSL's AES library✨
- Crypt::OpenSSL::Bignum(3pm)OpenSSL's multiprecision integer arithmetic✨
- Crypt::OpenSSL::Bignum::CTX(3pm)Perl interface to the OpenSSL BN_CTX structure.✨
- Crypt::OpenSSL::DSA(3pm)Digital Signature Algorithm using OpenSSL✨
- Crypt::OpenSSL::DSA::Signature(3pm)Digital Signature Object✨
- Crypt::OpenSSL::EC(3pm)Perl extension for OpenSSL EC (Elliptic Curves) library✨
- Crypt::OpenSSL::ECDSA(3pm)Perl extension for OpenSSL ECDSA (Elliptic Curve Digital Signature Algorithm)✨
- Crypt::OpenSSL::Guess(3pm)Guess OpenSSL include path✨
- Crypt::OpenSSL::PKCS10(3pm)Perl extension to OpenSSL's PKCS10 API.✨
- Crypt::OpenSSL::PKCS12(3pm)Perl extension to OpenSSL's PKCS12 API.✨
💅
getting it ready, bestie…