section 3perl · Library functions 📚
820 pages · page 2 of 5
all3 (100762)33ssl (6156)3B (42)3G (1100)3I (51)3LIBIIO (1)3NCARG (834)3OpenMPI (1)3PVM (71)3Sympa (164)3U (96)3WN (5)3alc (212)3alleg4 (923)3alleg5 (1063)3am (31)3ast (63)3attr (4)3avr (983)3bobcat (143)3brotli (4)3bsd (239)3caca (346)3cl (1)3clc (322)3cocci (1)3coin2 (588)3coin3 (753)3coin4 (918)3compat (22)3const (18)3ctype (1)3curses (18)3cvc (2)3cxx (1060)3debug (15)3edit (1)3em (198)3embree3 (113)3embree4 (127)3erl (623)3f (128)3form (106)3freebsd (1)3fun (1)3gl (467)3gle (14)3go (1)3guile (1)3gv (7)3hal (49)3head (3)3http (66)3itcl (17)3itk (6)3iv (354)3iwidget (52)3java (1)3libmawk (10)3libunwind (29)3lua (13)3m17n (257)3m_cli2 (8)3menu (88)3monocypher (73)3nas (130)3ncurses (703)3nx (5)3o (437)3ossl (6166)3ossp (2)3p (882)3pcap (75)3perl (820)3pg13 (68)3pg14 (72)3pg15 (72)3pg16 (72)3pg17 (72)3pg18 (72)3php (1)3plplot (175)3pm (34259)3pmc (296)3posix (882)3pub (150)3python (1)3qt (832)3r (1)3readline (2)3rheolef (13)3rtapi (66)3ruby (1)3scm (459)3sharp (1)3so (8)3ssl (6930)3stap (807)3str (19)3supp (19)3t (35)3tcl (1477)3tcllib (1)3tclx (25)3tiff (60)3tk (513)3tls (13)3trf (28)3ts (239)3type (466)3valkey (395)3visa (2)3x (1069)
E (continued)
- Encode::CJKConstants(3perl)Internally used by Encode::??::ISO_2022_*✨
- Encode::CN(3perl)China-based Chinese Encodings✨
- Encode::CN::HZ(3perl)internally used by Encode::CN✨
- Encode::Config(3perl)internally used by Encode✨
- Encode::EBCDIC(3perl)EBCDIC Encodings✨
- Encode::Encoder(3perl)Object Oriented Encoder✨
- Encode::Encoding(3perl)Encode Implementation Base Class✨
- Encode::GSM0338(3perl)ETSI GSM 03.38 Encoding✨
- Encode::Guess(3perl)Guesses encoding from data✨
- Encode::JP(3perl)Japanese Encodings✨
- Encode::JP::H2Z(3perl)internally used by Encode::JP::2022_JP*✨
- Encode::JP::JIS7(3perl)internally used by Encode::JP✨
- Encode::KR(3perl)Korean Encodings✨
- Encode::KR::2022_KR(3perl)internally used by Encode::KR✨
- Encode::MIME::Header(3perl)MIME encoding for an unstructured email header✨
- Encode::MIME::Name(3perl)internally used by Encode✨
- Encode::PerlIO(3perl)a detailed document on Encode and PerlIO✨
- Encode::Supported(3perl)Encodings supported by Encode✨
- Encode::Symbol(3perl)Symbol Encodings✨
- Encode::TW(3perl)Taiwan-based Chinese Encodings✨
- Encode::Unicode(3perl)Various Unicode Transformation Formats✨
- Encode::Unicode::UTF7(3perl)UTF-7 encoding✨
- encoding(3perl)allows you to write your script in non-ASCII and non-UTF-8✨
- encoding::warnings(3perl)Warn on implicit encoding conversions✨
- English(3perl)use nice English (or awk) names for ugly punctuation variables✨
- Env(3perl)perl module that imports environment variables as scalars or arrays✨
- Errno(3perl)System errno constants✨
- experimental(3perl)Experimental features made easy✨
- Exporter(3perl)Implements default import method for modules✨
- Exporter::Heavy(3perl)Exporter guts✨
- ExtUtils::CBuilder(3perl)Compile and link C code for Perl modules✨
- ExtUtils::CBuilder::Platform::Windows(3perl)Builder class for Windows platforms✨
- ExtUtils::Command(3perl)utilities to replace common UNIX commands in Makefiles etc.✨
- ExtUtils::Command::MM(3perl)Commands for the MM's to use in Makefiles✨
- ExtUtils::Constant(3perl)generate XS code to import C header constants✨
- ExtUtils::Constant::Base(3perl)base class for ExtUtils::Constant objects✨
- ExtUtils::Constant::Utils(3perl)helper functions for ExtUtils::Constant✨
- ExtUtils::Constant::XS(3perl)generate C code for XS modules' constants.✨
- ExtUtils::Embed(3perl)Utilities for embedding Perl in C/C++ applications✨
- ExtUtils::Install(3perl)install files from here to there✨
- ExtUtils::Installed(3perl)Inventory management of installed modules✨
- ExtUtils::Liblist(3perl)determine libraries to use and how to use them✨
- ExtUtils::MakeMaker(3perl)Create a module Makefile✨
- ExtUtils::MakeMaker::Config(3perl)Wrapper around Config.pm✨
- ExtUtils::MakeMaker::FAQ(3perl)Frequently Asked Questions About MakeMaker✨
- ExtUtils::MakeMaker::Locale(3perl)bundled Encode::Locale✨
- ExtUtils::MakeMaker::Tutorial(3perl)Writing a module with MakeMaker✨
- ExtUtils::Manifest(3perl)Utilities to write and check a MANIFEST file✨
- ExtUtils::Miniperl(3perl)write the C code for miniperlmain.c and perlmain.c✨
- ExtUtils::Mkbootstrap(3perl)make a bootstrap file for use by DynaLoader✨
- ExtUtils::Mksymlists(3perl)write linker options files for dynamic extension✨
- ExtUtils::MM(3perl)OS adjusted ExtUtils::MakeMaker subclass✨
- ExtUtils::MM_AIX(3perl)AIX specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_Any(3perl)Platform-agnostic MM methods✨
- ExtUtils::MM_BeOS(3perl)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_Cygwin(3perl)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_Darwin(3perl)special behaviors for OS X✨
- ExtUtils::MM_DOS(3perl)DOS specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_MacOS(3perl)once produced Makefiles for MacOS Classic✨
- ExtUtils::MM_NW5(3perl)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_OS2(3perl)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_OS390(3perl)OS390 specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_QNX(3perl)QNX specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_Unix(3perl)methods used by ExtUtils::MakeMaker✨
- ExtUtils::MM_UWIN(3perl)U/WIN specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_VMS(3perl)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_VOS(3perl)VOS specific subclass of ExtUtils::MM_Unix✨
- ExtUtils::MM_Win32(3perl)methods to override UN*X behaviour in ExtUtils::MakeMaker✨
- ExtUtils::MM_Win95(3perl)method to customize MakeMaker for Win9X✨
- ExtUtils::MY(3perl)ExtUtils::MakeMaker subclass for customization✨
- ExtUtils::Packlist(3perl)manage .packlist files✨
- ExtUtils::ParseXS(3perl)converts Perl XS code into C code✨
- ExtUtils::ParseXS::Constants(3perl)Initialization values for some globals✨
- ExtUtils::ParseXS::Eval(3perl)Clean package to evaluate code in✨
- ExtUtils::ParseXS::Node(3perl)Classes for nodes of an Abstract Syntax Tree✨
- ExtUtils::ParseXS::Utilities(3perl)Subroutines used with ExtUtils::ParseXS✨
- ExtUtils::PL2Bat(3perl)Batch file creation to run perl scripts on Windows✨
- ExtUtils::testlib(3perl)add blib/* directories to @INC✨
- ExtUtils::Typemaps(3perl)Read/Write/Modify Perl/XS typemap files✨
- ExtUtils::Typemaps::Cmd(3perl)Quick commands for handling typemaps✨
- ExtUtils::Typemaps::InputMap(3perl)Entry in the INPUT section of a typemap✨
- ExtUtils::Typemaps::OutputMap(3perl)Entry in the OUTPUT section of a typemap✨
- ExtUtils::Typemaps::Type(3perl)Entry in the TYPEMAP section of a typemap✨
F
- Fatal(3perl)Replace functions with equivalents which succeed or die✨
- Fcntl(3perl)various flag constants and helper functions from C's fcntl.h✨
- feature(3perl)Perl pragma to enable new features✨
- fields(3perl)compile-time class fields✨
- File::Basename(3perl)Parse file paths into directory, filename and suffix.✨
- File::Compare(3perl)Compare files or filehandles✨
- File::Copy(3perl)Copy files or filehandles✨
- File::DosGlob(3perl)DOS like globbing and then some✨
- File::Fetch(3perl)A generic file fetching mechanism✨
- File::Find(3perl)Traverse a directory tree.✨
- File::Glob(3perl)Perl extension for BSD glob routine✨
- File::GlobMapper(3perl)Extend File Glob to Allow Input and Output Files✨
- File::Path(3perl)Create or remove directory trees✨
- File::Spec(3perl)portably perform operations on file names✨
- File::Spec::AmigaOS(3perl)File::Spec for AmigaOS✨
- File::Spec::Cygwin(3perl)methods for Cygwin file specs✨
- File::Spec::Epoc(3perl)methods for Epoc file specs✨
- File::Spec::Functions(3perl)portably perform operations on file names✨
- File::Spec::Mac(3perl)File::Spec for Mac OS (Classic)✨
- File::Spec::OS2(3perl)methods for OS/2 file specs✨
- File::Spec::Unix(3perl)File::Spec for Unix, base for other File::Spec modules✨
- File::Spec::VMS(3perl)methods for VMS file specs✨
- File::Spec::Win32(3perl)methods for Win32 file specs✨
- File::stat(3perl)by-name interface to Perl's built-in stat() functions✨
- File::Temp(3perl)return name and handle of a temporary file safely✨
- FileCache(3perl)keep more files open than the system permits✨
- FileHandle(3perl)supply object methods for filehandles✨
- filetest(3perl)Perl pragma to control the filetest permission operators✨
- Filter::Simple(3perl)Simplified source filtering✨
- Filter::Util::Call(3perl)Perl Source Filter Utility Module✨
- FindBin(3perl)Locate directory of original Perl script✨
G
- GDBM_File(3perl)Perl5 access to the gdbm library.✨
- Getopt::Long(3perl)Extended processing of command line options✨
- Getopt::Long::Parser(3perl)Getopt::Long object-oriented interface✨
- Getopt::Std(3perl)Process single-character switches with switch clustering✨
- gv(3perl)graph manipulation in perl✨
H
- Hash::Util(3perl)A selection of general-utility hash subroutines✨
- Hash::Util::FieldHash(3perl)Support for Inside-Out Classes✨
- HTTP::Tiny(3perl)A small, simple, correct HTTP/1.1 client✨
I
- I18N::Collate(3perl)compare 8-bit scalar data according to the current locale✨
- I18N::Langinfo(3perl)query locale information✨
- I18N::LangTags(3perl)functions for dealing with RFC3066-style language tags✨
- I18N::LangTags::Detect(3perl)detect the user's language preferences✨
- I18N::LangTags::List(3perl)tags and names for human languages✨
- if(3perl)"use" a Perl module if a condition holds✨
- integer(3perl)Perl pragma to use integer arithmetic instead of floating point✨
- Internals(3perl)Reserved special namespace for internals related functions✨
- IO(3perl)load various IO modules✨
- IO::Compress(3perl)read/write compressed data in multiple formats✨
- IO::Compress::Base(3perl)Base Class for IO::Compress modules✨
- IO::Compress::Bzip2(3perl)Write bzip2 files/buffers✨
- IO::Compress::Deflate(3perl)Write RFC 1950 files/buffers✨
- IO::Compress::FAQ(3perl)Frequently Asked Questions about IO::Compress✨
- IO::Compress::Gzip(3perl)Write RFC 1952 files/buffers✨
- IO::Compress::RawDeflate(3perl)Write RFC 1951 files/buffers✨
- IO::Compress::Zip(3perl)Write zip files/buffers✨
- IO::Dir(3perl)supply object methods for directory handles✨
- IO::File(3perl)supply object methods for filehandles✨
- IO::Handle(3perl)supply object methods for I/O handles✨
- IO::Pipe(3perl)supply object methods for pipes✨
- IO::Poll(3perl)Object interface to system poll call✨
- IO::Seekable(3perl)supply seek based methods for I/O objects✨
- IO::Select(3perl)OO interface to the "select" system call✨
- IO::Socket(3perl)Object interface to socket communications✨
- IO::Socket::INET(3perl)Object interface for AF_INET domain sockets✨
- IO::Socket::IP(3perl)Family-neutral IP socket supporting both IPv4 and IPv6✨
- IO::Socket::UNIX(3perl)Object interface for AF_UNIX domain sockets✨
- IO::Uncompress::AnyInflate(3perl)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyUncompress(3perl)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::Base(3perl)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Bunzip2(3perl)Read bzip2 files/buffers✨
- IO::Uncompress::Gunzip(3perl)Read RFC 1952 files/buffers✨
- IO::Uncompress::Inflate(3perl)Read RFC 1950 files/buffers✨
- IO::Uncompress::RawInflate(3perl)Read RFC 1951 files/buffers✨
- IO::Uncompress::Unzip(3perl)Read zip files/buffers✨
- IO::Zlib(3perl)IO:: style interface to Compress::Zlib✨
- IPC::Cmd(3perl)finding and running system commands made easy✨
- IPC::Msg(3perl)SysV Msg IPC object class✨
- IPC::Open2(3perl)open a process for both reading and writing using open2()✨
- IPC::Open3(3perl)open a process for reading, writing, and error handling using open3()✨
- IPC::Semaphore(3perl)SysV Semaphore IPC object class✨
- IPC::SharedMem(3perl)SysV Shared Memory IPC object class✨
- IPC::SysV(3perl)System V IPC constants and system calls✨
J
- JSON::PP(3perl)JSON::XS compatible pure-Perl module.✨
- JSON::PP::Boolean(3perl)dummy module providing JSON::PP::Boolean✨
L
- less(3perl)perl pragma to request less of something✨
- lib(3perl)manipulate @INC at compile time✨
- List::Util(3perl)A selection of general-utility list subroutines✨
- List::Util::XS(3perl)Indicate if List::Util was compiled with a C compiler✨
- locale(3perl)Perl pragma to use or avoid POSIX locales for built-in operations✨
- Locale::Maketext(3perl)framework for localization✨
- Locale::Maketext::Cookbook(3perl)recipes for using Locale::Maketext✨
- Locale::Maketext::Guts(3perl)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::GutsLoader(3perl)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::Simple(3perl)Simple interface to Locale::Maketext::Lexicon✨
- Locale::Maketext::TPJ13(3perl)article about software localization✨
- LW2(3perl)Perl HTTP library version 2.5✨
M
- Math::BigFloat(3perl)arbitrary size floating point math package✨
- Math::BigInt(3perl)arbitrary size integer math package✨
- Math::BigInt::Calc(3perl)pure Perl module to support Math::BigInt✨
- Math::BigInt::FastCalc(3perl)Math::BigInt::Calc with some XS for more speed✨
- Math::BigInt::Lib(3perl)virtual parent class for Math::BigInt libraries✨
- Math::BigRat(3perl)arbitrary size rational number math package✨
- Math::Complex(3perl)complex numbers and associated mathematical functions✨
- Math::Trig(3perl)trigonometric functions✨
- Memoize(3perl)Make functions faster by trading space for time✨
- Memoize::AnyDBM_File(3perl)glue to provide EXISTS for AnyDBM_File for Storable use✨
- Memoize::Expire(3perl)Plug-in module for automatic expiration of memoized values✨
- Memoize::ExpireFile(3perl)test for Memoize expiration semantics✨
- Memoize::ExpireTest(3perl)test for Memoize expiration semantics✨
- Memoize::NDBM_File(3perl)glue to provide EXISTS for NDBM_File for Storable use✨
- Memoize::SDBM_File(3perl)DEPRECATED compatibility shim✨
- Memoize::Storable(3perl)store Memoized data in Storable database✨
- MIME::Base64(3perl)Encoding and decoding of base64 strings✨
- MIME::QuotedPrint(3perl)Encoding and decoding of quoted-printable strings✨
- Module::CoreList(3perl)what modules shipped with versions of perl✨
- Module::CoreList::Utils(3perl)what utilities shipped with versions of perl✨
💅
getting it ready, bestie…