📦 perl-doc
1675 pages · page 3 of 9
F (continued)
- File::GlobMapper(3pm)Extend File Glob to Allow Input and Output Files✨
- File::Path(3perl)Create or remove directory trees✨
- File::Path(3pm)Create or remove directory trees✨
- File::Spec(3perl)portably perform operations on file names✨
- File::Spec(3pm)portably perform operations on file names✨
- File::Spec::AmigaOS(3perl)File::Spec for AmigaOS✨
- File::Spec::AmigaOS(3pm)File::Spec for AmigaOS✨
- File::Spec::Cygwin(3perl)methods for Cygwin file specs✨
- File::Spec::Cygwin(3pm)methods for Cygwin file specs✨
- File::Spec::Epoc(3perl)methods for Epoc file specs✨
- File::Spec::Epoc(3pm)methods for Epoc file specs✨
- File::Spec::Functions(3perl)portably perform operations on file names✨
- File::Spec::Functions(3pm)portably perform operations on file names✨
- File::Spec::Mac(3perl)File::Spec for Mac OS (Classic)✨
- File::Spec::Mac(3pm)File::Spec for Mac OS (Classic)✨
- File::Spec::OS2(3perl)methods for OS/2 file specs✨
- File::Spec::OS2(3pm)methods for OS/2 file specs✨
- File::Spec::Unix(3perl)File::Spec for Unix, base for other File::Spec modules✨
- File::Spec::Unix(3pm)File::Spec for Unix, base for other File::Spec modules✨
- File::Spec::VMS(3perl)methods for VMS file specs✨
- File::Spec::VMS(3pm)methods for VMS file specs✨
- File::Spec::Win32(3perl)methods for Win32 file specs✨
- File::Spec::Win32(3pm)methods for Win32 file specs✨
- File::stat(3perl)by-name interface to Perl's built-in stat() functions✨
- File::stat(3pm)by-name interface to Perl's built-in stat() functions✨
- File::Temp(3perl)return name and handle of a temporary file safely✨
- File::Temp(3pm)return name and handle of a temporary file safely✨
- FileCache(3perl)keep more files open than the system permits✨
- FileCache(3pm)keep more files open than the system permits✨
- FileHandle(3perl)supply object methods for filehandles✨
- FileHandle(3pm)supply object methods for filehandles✨
- filetest(3perl)Perl pragma to control the filetest permission operators✨
- filetest(3pm)Perl pragma to control the filetest permission operators✨
- Filter::Simple(3perl)Simplified source filtering✨
- Filter::Simple(3pm)Simplified source filtering✨
- Filter::Util::Call(3perl)Perl Source Filter Utility Module✨
- Filter::Util::Call(3pm)Perl Source Filter Utility Module✨
- FindBin(3perl)Locate directory of original Perl script✨
- FindBin(3pm)Locate directory of original Perl script✨
G
- GDBM_File(3perl)Perl5 access to the gdbm library.✨
- GDBM_File(3pm)Perl5 access to the gdbm library.✨
- Getopt::Long(3perl)Extended processing of command line options✨
- Getopt::Long(3pm)Extended processing of command line options✨
- Getopt::Long::Parser(3perl)Getopt::Long object-oriented interface✨
- Getopt::Long::Parser(3pm)Getopt::Long object-oriented interface✨
- Getopt::Std(3perl)Process single-character switches with switch clustering✨
- Getopt::Std(3pm)Process single-character switches with switch clustering✨
H
- h2ph(1)convert .h C header files to .ph Perl header files✨
- h2xs(1)convert .h C header files to Perl extensions✨
- Hash::Util(3perl)A selection of general-utility hash subroutines✨
- Hash::Util(3pm)A selection of general-utility hash subroutines✨
- Hash::Util::FieldHash(3perl)Support for Inside-Out Classes✨
- Hash::Util::FieldHash(3pm)Support for Inside-Out Classes✨
- HTTP::Tiny(3perl)A small, simple, correct HTTP/1.1 client✨
- HTTP::Tiny(3pm)A small, simple, correct HTTP/1.1 client✨
I
- I18N::Collate(3perl)compare 8-bit scalar data according to the current locale✨
- I18N::Collate(3pm)compare 8-bit scalar data according to the current locale✨
- I18N::Langinfo(3perl)query locale information✨
- I18N::Langinfo(3pm)query locale information✨
- I18N::LangTags(3perl)functions for dealing with RFC3066-style language tags✨
- I18N::LangTags(3pm)functions for dealing with RFC3066-style language tags✨
- I18N::LangTags::Detect(3perl)detect the user's language preferences✨
- I18N::LangTags::Detect(3pm)detect the user's language preferences✨
- I18N::LangTags::List(3perl)tags and names for human languages✨
- I18N::LangTags::List(3pm)tags and names for human languages✨
- if(3perl)"use" a Perl module if a condition holds✨
- if(3pm)"use" a Perl module if a condition holds✨
- instmodsh(1)A shell to examine installed modules✨
- integer(3perl)Perl pragma to use integer arithmetic instead of floating point✨
- integer(3pm)Perl pragma to use integer arithmetic instead of floating point✨
- Internals(3perl)Reserved special namespace for internals related functions✨
- Internals(3pm)Reserved special namespace for internals related functions✨
- IO(3perl)load various IO modules✨
- IO(3pm)load various IO modules✨
- IO::Compress(3perl)read/write compressed data in multiple formats✨
- IO::Compress(3pm)read/write compressed data in multiple formats✨
- IO::Compress::Base(3perl)Base Class for IO::Compress modules✨
- IO::Compress::Base(3pm)Base Class for IO::Compress modules✨
- IO::Compress::Bzip2(3perl)Write bzip2 files/buffers✨
- IO::Compress::Bzip2(3pm)Write bzip2 files/buffers✨
- IO::Compress::Deflate(3perl)Write RFC 1950 files/buffers✨
- IO::Compress::Deflate(3pm)Write RFC 1950 files/buffers✨
- IO::Compress::FAQ(3perl)Frequently Asked Questions about IO::Compress✨
- IO::Compress::FAQ(3pm)Frequently Asked Questions about IO::Compress✨
- IO::Compress::Gzip(3perl)Write RFC 1952 files/buffers✨
- IO::Compress::Gzip(3pm)Write RFC 1952 files/buffers✨
- IO::Compress::RawDeflate(3perl)Write RFC 1951 files/buffers✨
- IO::Compress::RawDeflate(3pm)Write RFC 1951 files/buffers✨
- IO::Compress::Zip(3perl)Write zip files/buffers✨
- IO::Compress::Zip(3pm)Write zip files/buffers✨
- IO::Dir(3perl)supply object methods for directory handles✨
- IO::Dir(3pm)supply object methods for directory handles✨
- IO::File(3perl)supply object methods for filehandles✨
- IO::File(3pm)supply object methods for filehandles✨
- IO::Handle(3perl)supply object methods for I/O handles✨
- IO::Handle(3pm)supply object methods for I/O handles✨
- IO::Pipe(3perl)supply object methods for pipes✨
- IO::Pipe(3pm)supply object methods for pipes✨
- IO::Poll(3perl)Object interface to system poll call✨
- IO::Poll(3pm)Object interface to system poll call✨
- IO::Seekable(3perl)supply seek based methods for I/O objects✨
- IO::Seekable(3pm)supply seek based methods for I/O objects✨
- IO::Select(3perl)OO interface to the "select" system call✨
- IO::Select(3pm)OO interface to the "select" system call✨
- IO::Socket(3perl)Object interface to socket communications✨
- IO::Socket(3pm)Object interface to socket communications✨
- IO::Socket::INET(3perl)Object interface for AF_INET domain sockets✨
- IO::Socket::INET(3pm)Object interface for AF_INET domain sockets✨
- IO::Socket::IP(3perl)Family-neutral IP socket supporting both IPv4 and IPv6✨
- IO::Socket::IP(3pm)Family-neutral IP socket supporting both IPv4 and IPv6✨
- IO::Socket::UNIX(3perl)Object interface for AF_UNIX domain sockets✨
- IO::Socket::UNIX(3pm)Object interface for AF_UNIX domain sockets✨
- IO::Uncompress::AnyInflate(3perl)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyInflate(3pm)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyUncompress(3perl)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::AnyUncompress(3pm)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::Base(3perl)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Base(3pm)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Bunzip2(3perl)Read bzip2 files/buffers✨
- IO::Uncompress::Bunzip2(3pm)Read bzip2 files/buffers✨
- IO::Uncompress::Gunzip(3perl)Read RFC 1952 files/buffers✨
- IO::Uncompress::Gunzip(3pm)Read RFC 1952 files/buffers✨
- IO::Uncompress::Inflate(3perl)Read RFC 1950 files/buffers✨
- IO::Uncompress::Inflate(3pm)Read RFC 1950 files/buffers✨
- IO::Uncompress::RawInflate(3perl)Read RFC 1951 files/buffers✨
- IO::Uncompress::RawInflate(3pm)Read RFC 1951 files/buffers✨
- IO::Uncompress::Unzip(3perl)Read zip files/buffers✨
- IO::Uncompress::Unzip(3pm)Read zip files/buffers✨
- IO::Zlib(3perl)IO:: style interface to Compress::Zlib✨
- IO::Zlib(3pm)IO:: style interface to Compress::Zlib✨
- IPC::Cmd(3perl)finding and running system commands made easy✨
- IPC::Cmd(3pm)finding and running system commands made easy✨
- IPC::Msg(3perl)SysV Msg IPC object class✨
- IPC::Msg(3pm)SysV Msg IPC object class✨
- IPC::Open2(3perl)open a process for both reading and writing using open2()✨
- IPC::Open2(3pm)open a process for both reading and writing using open2()✨
- IPC::Open3(3perl)open a process for reading, writing, and error handling using open3()✨
- IPC::Open3(3pm)open a process for reading, writing, and error handling using open3()✨
- IPC::Semaphore(3perl)SysV Semaphore IPC object class✨
- IPC::Semaphore(3pm)SysV Semaphore IPC object class✨
- IPC::SharedMem(3perl)SysV Shared Memory IPC object class✨
- IPC::SharedMem(3pm)SysV Shared Memory IPC object class✨
- IPC::SysV(3perl)System V IPC constants and system calls✨
- IPC::SysV(3pm)System V IPC constants and system calls✨
J
- JSON::PP(3perl)JSON::XS compatible pure-Perl module.✨
- JSON::PP(3pm)JSON::XS compatible pure-Perl module.✨
- JSON::PP::Boolean(3perl)dummy module providing JSON::PP::Boolean✨
- JSON::PP::Boolean(3pm)dummy module providing JSON::PP::Boolean✨
- json_pp(1)JSON::PP command utility✨
L
- less(3perl)perl pragma to request less of something✨
- less(3pm)perl pragma to request less of something✨
- lib(3perl)manipulate @INC at compile time✨
- lib(3pm)manipulate @INC at compile time✨
- libnetcfg(1)configure libnet✨
- List::Util(3perl)A selection of general-utility list subroutines✨
- List::Util(3pm)A selection of general-utility list subroutines✨
- List::Util::XS(3perl)Indicate if List::Util was compiled with a C compiler✨
- List::Util::XS(3pm)Indicate if List::Util was compiled with a C compiler✨
- locale(3perl)Perl pragma to use or avoid POSIX locales for built-in operations✨
- locale(3pm)Perl pragma to use or avoid POSIX locales for built-in operations✨
- Locale::Maketext(3perl)framework for localization✨
- Locale::Maketext(3pm)framework for localization✨
- Locale::Maketext::Cookbook(3perl)recipes for using Locale::Maketext✨
- Locale::Maketext::Cookbook(3pm)recipes for using Locale::Maketext✨
- Locale::Maketext::Guts(3perl)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::Guts(3pm)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::GutsLoader(3perl)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::GutsLoader(3pm)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::Simple(3perl)Simple interface to Locale::Maketext::Lexicon✨
- Locale::Maketext::Simple(3pm)Simple interface to Locale::Maketext::Lexicon✨
- Locale::Maketext::TPJ13(3perl)article about software localization✨
- Locale::Maketext::TPJ13(3pm)article about software localization✨
M
- Math::BigFloat(3perl)arbitrary size floating point math package✨
- Math::BigFloat(3pm)arbitrary size floating point math package✨
- Math::BigInt(3perl)arbitrary size integer math package✨
- Math::BigInt(3pm)arbitrary size integer math package✨
- Math::BigInt::Calc(3perl)pure Perl module to support Math::BigInt✨
- Math::BigInt::Calc(3pm)pure Perl module to support Math::BigInt✨
- Math::BigInt::FastCalc(3perl)Math::BigInt::Calc with some XS for more speed✨
- Math::BigInt::FastCalc(3pm)Math::BigInt::Calc with some XS for more speed✨
- Math::BigInt::Lib(3perl)virtual parent class for Math::BigInt libraries✨
- Math::BigInt::Lib(3pm)virtual parent class for Math::BigInt libraries✨
- Math::BigRat(3perl)arbitrary size rational number math package✨
- Math::BigRat(3pm)arbitrary size rational number math package✨
- Math::Complex(3perl)complex numbers and associated mathematical functions✨
- Math::Complex(3pm)complex numbers and associated mathematical functions✨
- Math::Trig(3perl)trigonometric functions✨
- Math::Trig(3pm)trigonometric functions✨
- Memoize(3perl)Make functions faster by trading space for time✨
- Memoize(3pm)Make functions faster by trading space for time✨
- Memoize::AnyDBM_File(3perl)glue to provide EXISTS for AnyDBM_File for Storable use✨
- Memoize::AnyDBM_File(3pm)glue to provide EXISTS for AnyDBM_File for Storable use✨
- Memoize::Expire(3perl)Plug-in module for automatic expiration of memoized values✨
- Memoize::Expire(3pm)Plug-in module for automatic expiration of memoized values✨
- Memoize::ExpireFile(3perl)test for Memoize expiration semantics✨
- Memoize::ExpireTest(3perl)test for Memoize expiration semantics✨
- Memoize::NDBM_File(3perl)glue to provide EXISTS for NDBM_File for Storable use✨
- Memoize::NDBM_File(3pm)glue to provide EXISTS for NDBM_File for Storable use✨
- Memoize::SDBM_File(3perl)DEPRECATED compatibility shim✨
- Memoize::SDBM_File(3pm)DEPRECATED compatibility shim✨
💅
getting it ready, bestie…