RFC 118
Recommendations for facility documentation
RFC 118: RECOMMENDATIONS FOR FACILITY DOCUMENTATION β¨
Network Working Group πΈ Request for Comments: 118 Author: Richard Watson, Stanford Research Institute (ARC) π¦ NIC number: 5830 π Date: 16 April 1971 π Category or status: not listed in the title block π€·ββοΈ Obsoletes or updates: nothing is listed, so this one doesn't replace or update any earlier RFC π
INFORMATION REQUIRED FOR EACH SERVICE AVAILABLE TO THE NETWORK π§
okay so every site has to give two kinds of info for each service or process it offers over the Network π
- i) information required by system programmers in order to establish a connection to the facility
- ii) information required by a user to gain access to and use the facility
these two basic kinds of info are what make up a "functional document" π (see RFC 115, NIC (5822,) for a description of functional documents and recommended procedures for updating them) β¨
the info that user site system programmers need can be a detailed document, a reference to a document describing a protocol shared by several facilities, or some combo of the two π«Ά all the info they need has to be included, like connection socket numbers, message formats, and character set info π two examples of system programmer type info are RFC 74, NIC (5417,) and RFC 105, NIC (5775,) prepared by James White of UCSB π
the info that user site users need comes in three types:
- a) information unique to Network users of the facility
- b) information in common between Network users and server site users of the facility
- c) information unique to particular Network user site
type c) is prepared by the user site using the info the server site gave them π₯ for example, keying conventions needed to send certain codes to the server site π
Future documentation will probably have types a) and b) integrated into one document π§ but at first, server sites will probably already have user manuals or docs for their local users, so they'll need to write a short doc with any extra info Network users need π that extra info will vary, but it might include a different login or control card sequence, varying echo or syntax for user sites working character at a time or line at a time, server site or user site echoing, and so on π some features available to server site users might not be available to Network user site users, or certain features might behave differently π
besides all the types above, there should be instructions on how the user can get help or answers to questions about using the facility π
info about how to get administrative access (charge numbers, etc.) to a site should be in the document ARPA Network Current Guides to Network Facilities, NIC (5148,) π BBN is the one collecting this info π«§ that document will then point to the functional documents that describe the available Network facilities in detail and how to use them β¨
even if there are no special conventions or info unique to a Network user as opposed to a server site user, you should say so explicitly so nobody gets confused or uncertain π¨
NETWORK INFORMATION CENTER POLICY ON DISTRIBUTION AND UPDATING OF DOCUMENTATION π
the Network Information Center will distribute and maintain one copy of each functional document describing a facility in each Network Station NIC Collection π§ to make that work, they'd really appreciate it if 100 copies of each manual and each set of manual updates could be sent to the NIC whenever they come out π
users at sites who want their own copies of user docs can get them straight from the server site, or by copying the master in their local NIC Collection πΈ so users know where to find extra copies, an address and a price (if there is one) should be included in the info about each facility π
[ This RFC was put into machine readable form for entry ] [ into the online RFC archives by Mirsad Todorovac 10/98 ]
π¦ where this page comes from
- ietf: rfc118 1971-04
- π girlified by claude-haiku-5-5 on : a language model's rewrite of the original, under its terms