📦 perl
1224 pages · page 2 of 7
F (continued)
- File::Compare(3perl)Compare files or filehandles✨
- File::Copy(3perl)Copy files or filehandles✨
- File::DosGlob(3perl)DOS like globbing and then some✨
- File::Fetch(3perl)A generic file fetching mechanism✨
- File::Find(3perl)Traverse a directory tree.✨
- File::Glob(3perl)Perl extension for BSD glob routine✨
- File::GlobMapper(3perl)Extend File Glob to Allow Input and Output Files✨
- File::Path(3perl)Create or remove directory trees✨
- File::Spec(3perl)portably perform operations on file names✨
- File::Spec::AmigaOS(3perl)File::Spec for AmigaOS✨
- File::Spec::Cygwin(3perl)methods for Cygwin file specs✨
- File::Spec::Epoc(3perl)methods for Epoc file specs✨
- File::Spec::Functions(3perl)portably perform operations on file names✨
- File::Spec::Mac(3perl)File::Spec for Mac OS (Classic)✨
- File::Spec::OS2(3perl)methods for OS/2 file specs✨
- File::Spec::Unix(3perl)File::Spec for Unix, base for other File::Spec modules✨
- File::Spec::VMS(3perl)methods for VMS file specs✨
- File::Spec::Win32(3perl)methods for Win32 file specs✨
- File::stat(3perl)by-name interface to Perl's built-in stat() functions✨
- File::Temp(3perl)return name and handle of a temporary file safely✨
- FileCache(3perl)keep more files open than the system permits✨
- FileHandle(3perl)supply object methods for filehandles✨
- filetest(3perl)Perl pragma to control the filetest permission operators✨
- Filter::Simple(3perl)Simplified source filtering✨
- Filter::Util::Call(3perl)Perl Source Filter Utility Module✨
- FindBin(3perl)Locate directory of original Perl script✨
G
- GDBM_File(3perl)Perl5 access to the gdbm library.✨
- Getopt::Long(3perl)Extended processing of command line options✨
- Getopt::Long::Parser(3perl)Getopt::Long object-oriented interface✨
- Getopt::Std(3perl)Process single-character switches with switch clustering✨
H
- h2ph(1)convert .h C header files to .ph Perl header files✨
- h2ph(1perl)convert .h C header files to .ph Perl header files✨
- h2xs(1)convert .h C header files to Perl extensions✨
- h2xs(1perl)convert .h C header files to Perl extensions✨
- Hash::Util(3perl)A selection of general-utility hash subroutines✨
- Hash::Util::FieldHash(3perl)Support for Inside-Out Classes✨
- HTTP::Tiny(3perl)A small, simple, correct HTTP/1.1 client✨
I
- I18N::Collate(3perl)compare 8-bit scalar data according to the current locale✨
- I18N::Langinfo(3perl)query locale information✨
- I18N::LangTags(3perl)functions for dealing with RFC3066-style language tags✨
- I18N::LangTags::Detect(3perl)detect the user's language preferences✨
- I18N::LangTags::List(3perl)tags and names for human languages✨
- if(3perl)"use" a Perl module if a condition holds✨
- instmodsh(1)A shell to examine installed modules✨
- instmodsh(1perl)A shell to examine installed modules✨
- integer(3perl)Perl pragma to use integer arithmetic instead of floating point✨
- Internals(3perl)Reserved special namespace for internals related functions✨
- IO(3perl)load various IO modules✨
- IO::Compress(3perl)read/write compressed data in multiple formats✨
- IO::Compress::Base(3perl)Base Class for IO::Compress modules✨
- IO::Compress::Bzip2(3perl)Write bzip2 files/buffers✨
- IO::Compress::Deflate(3perl)Write RFC 1950 files/buffers✨
- IO::Compress::FAQ(3perl)Frequently Asked Questions about IO::Compress✨
- IO::Compress::Gzip(3perl)Write RFC 1952 files/buffers✨
- IO::Compress::RawDeflate(3perl)Write RFC 1951 files/buffers✨
- IO::Compress::Zip(3perl)Write zip files/buffers✨
- IO::Dir(3perl)supply object methods for directory handles✨
- IO::File(3perl)supply object methods for filehandles✨
- IO::Handle(3perl)supply object methods for I/O handles✨
- IO::Pipe(3perl)supply object methods for pipes✨
- IO::Poll(3perl)Object interface to system poll call✨
- IO::Seekable(3perl)supply seek based methods for I/O objects✨
- IO::Select(3perl)OO interface to the "select" system call✨
- IO::Socket(3perl)Object interface to socket communications✨
- IO::Socket::INET(3perl)Object interface for AF_INET domain sockets✨
- IO::Socket::IP(3perl)Family-neutral IP socket supporting both IPv4 and IPv6✨
- IO::Socket::UNIX(3perl)Object interface for AF_UNIX domain sockets✨
- IO::Uncompress::AnyInflate(3perl)Uncompress zlib-based (zip, gzip) file/buffer✨
- IO::Uncompress::AnyUncompress(3perl)Uncompress gzip, zip, bzip2, zstd, xz, lzma, lzip, lzf or lzop file/buffer✨
- IO::Uncompress::Base(3perl)Base Class for IO::Uncompress modules✨
- IO::Uncompress::Bunzip2(3perl)Read bzip2 files/buffers✨
- IO::Uncompress::Gunzip(3perl)Read RFC 1952 files/buffers✨
- IO::Uncompress::Inflate(3perl)Read RFC 1950 files/buffers✨
- IO::Uncompress::RawInflate(3perl)Read RFC 1951 files/buffers✨
- IO::Uncompress::Unzip(3perl)Read zip files/buffers✨
- IO::Zlib(3perl)IO:: style interface to Compress::Zlib✨
- IPC::Cmd(3perl)finding and running system commands made easy✨
- IPC::Msg(3perl)SysV Msg IPC object class✨
- IPC::Open2(3perl)open a process for both reading and writing using open2()✨
- IPC::Open3(3perl)open a process for reading, writing, and error handling using open3()✨
- IPC::Semaphore(3perl)SysV Semaphore IPC object class✨
- IPC::SharedMem(3perl)SysV Shared Memory IPC object class✨
- IPC::SysV(3perl)System V IPC constants and system calls✨
J
- JSON::PP(3perl)JSON::XS compatible pure-Perl module.✨
- JSON::PP::Boolean(3perl)dummy module providing JSON::PP::Boolean✨
- json_pp(1)JSON::PP command utility✨
- json_pp(1perl)JSON::PP command utility✨
L
- less(3perl)perl pragma to request less of something✨
- lib(3perl)manipulate @INC at compile time✨
- libnetcfg(1)configure libnet✨
- libnetcfg(1perl)configure libnet✨
- List::Util(3perl)A selection of general-utility list subroutines✨
- List::Util::XS(3perl)Indicate if List::Util was compiled with a C compiler✨
- locale(3perl)Perl pragma to use or avoid POSIX locales for built-in operations✨
- Locale::Maketext(3perl)framework for localization✨
- Locale::Maketext::Cookbook(3perl)recipes for using Locale::Maketext✨
- Locale::Maketext::Guts(3perl)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::GutsLoader(3perl)Deprecated module to load Locale::Maketext utf8 code✨
- Locale::Maketext::Simple(3perl)Simple interface to Locale::Maketext::Lexicon✨
- Locale::Maketext::TPJ13(3perl)article about software localization✨
M
- Math::BigFloat(3perl)arbitrary size floating point math package✨
- Math::BigInt(3perl)arbitrary size integer math package✨
- Math::BigInt::Calc(3perl)pure Perl module to support Math::BigInt✨
- Math::BigInt::FastCalc(3perl)Math::BigInt::Calc with some XS for more speed✨
- Math::BigInt::Lib(3perl)virtual parent class for Math::BigInt libraries✨
- Math::BigRat(3perl)arbitrary size rational number math package✨
- Math::Complex(3perl)complex numbers and associated mathematical functions✨
- Math::Trig(3perl)trigonometric functions✨
- Memoize(3perl)Make functions faster by trading space for time✨
- Memoize::AnyDBM_File(3perl)glue to provide EXISTS for AnyDBM_File for Storable use✨
- Memoize::Expire(3perl)Plug-in module for automatic expiration of memoized values✨
- Memoize::NDBM_File(3perl)glue to provide EXISTS for NDBM_File for Storable use✨
- Memoize::SDBM_File(3perl)DEPRECATED compatibility shim✨
- Memoize::Storable(3perl)store Memoized data in Storable database✨
- MIME::Base64(3perl)Encoding and decoding of base64 strings✨
- MIME::QuotedPrint(3perl)Encoding and decoding of quoted-printable strings✨
- Module::CoreList(3perl)what modules shipped with versions of perl✨
- Module::CoreList::Utils(3perl)what utilities shipped with versions of perl✨
- Module::Load(3perl)runtime require of both modules and files✨
- Module::Load::Conditional(3perl)Looking up module information / loading at runtime✨
- Module::Loaded(3perl)mark modules as loaded or unloaded✨
- Module::Metadata(3perl)Gather package and POD information from perl module files✨
- mro(3perl)Method Resolution Order✨
N
- NDBM_File(3perl)Tied access to ndbm files✨
- Net::Cmd(3perl)Network Command class (as used by FTP, SMTP etc)✨
- Net::Config(3perl)Local configuration data for libnet✨
- Net::Domain(3perl)Attempt to evaluate the current host's internet name and domain✨
- Net::FTP(3perl)FTP Client class✨
- Net::hostent(3perl)by-name interface to Perl's built-in gethost*() functions✨
- Net::libnetFAQ(3perl)libnet Frequently Asked Questions✨
- Net::netent(3perl)by-name interface to Perl's built-in getnet*() functions✨
- Net::Netrc(3perl)OO interface to users netrc file✨
- Net::NNTP(3perl)NNTP Client class✨
- Net::Ping(3perl)check a remote host for reachability✨
- Net::POP3(3perl)Post Office Protocol 3 Client class (RFC1939)✨
- Net::protoent(3perl)by-name interface to Perl's built-in getproto*() functions✨
- Net::servent(3perl)by-name interface to Perl's built-in getserv*() functions✨
- Net::SMTP(3perl)Simple Mail Transfer Protocol Client✨
- Net::Time(3perl)time and daytime network client interface✨
- NEXT(3perl)Provide a pseudo-class NEXT (et al) that allows method redispatch✨
O
- O(3perl)Generic interface to Perl Compiler backends✨
- ODBM_File(3perl)Tied access to odbm files✨
- ok(3perl)Alternative to Test::More::use_ok✨
- Opcode(3perl)Disable named opcodes when compiling perl code✨
- open(3perl)perl pragma to set default PerlIO layers for input and output✨
- ops(3perl)Perl pragma to restrict unsafe operations when compiling✨
- overload(3perl)Package for overloading Perl operations✨
- overloading(3perl)perl pragma to lexically control overloading✨
P
- Params::Check(3perl)A generic input parsing/checking mechanism.✨
- parent(3perl)Establish an ISA relationship with base classes at compile time✨
- Parse::CPAN::Meta(3perl)Parse META.yml and META.json CPAN metadata files✨
- perl(1)The Perl 5 language interpreter✨
- perl(1perl)The Perl 5 language interpreter✨
- perl5004delta(1)what's new for perl5.004✨
- perl5004delta(1perl)what's new for perl5.004✨
- perl5005delta(1)what's new for perl5.005✨
- perl5005delta(1perl)what's new for perl5.005✨
- perl5100delta(1)what is new for perl 5.10.0✨
- perl5100delta(1perl)what is new for perl 5.10.0✨
- perl5101delta(1)what is new for perl v5.10.1✨
- perl5101delta(1perl)what is new for perl v5.10.1✨
- perl5120delta(1)what is new for perl v5.12.0✨
- perl5120delta(1perl)what is new for perl v5.12.0✨
- perl5121delta(1)what is new for perl v5.12.1✨
- perl5121delta(1perl)what is new for perl v5.12.1✨
- perl5122delta(1)what is new for perl v5.12.2✨
- perl5122delta(1perl)what is new for perl v5.12.2✨
- perl5123delta(1)what is new for perl v5.12.3✨
- perl5123delta(1perl)what is new for perl v5.12.3✨
- perl5124delta(1)what is new for perl v5.12.4✨
- perl5124delta(1perl)what is new for perl v5.12.4✨
- perl5125delta(1)what is new for perl v5.12.5✨
- perl5125delta(1perl)what is new for perl v5.12.5✨
- perl5140delta(1)what is new for perl v5.14.0✨
- perl5140delta(1perl)what is new for perl v5.14.0✨
- perl5141delta(1)what is new for perl v5.14.1✨
- perl5141delta(1perl)what is new for perl v5.14.1✨
- perl5142delta(1)what is new for perl v5.14.2✨
- perl5142delta(1perl)what is new for perl v5.14.2✨
- perl5143delta(1)what is new for perl v5.14.3✨
- perl5143delta(1perl)what is new for perl v5.14.3✨
- perl5144delta(1)what is new for perl v5.14.4✨
- perl5144delta(1perl)what is new for perl v5.14.4✨
- perl5160delta(1)what is new for perl v5.16.0✨
- perl5160delta(1perl)what is new for perl v5.16.0✨
- perl5161delta(1)what is new for perl v5.16.1✨
- perl5161delta(1perl)what is new for perl v5.16.1✨
- perl5162delta(1)what is new for perl v5.16.2✨
- perl5162delta(1perl)what is new for perl v5.16.2✨
- perl5163delta(1)what is new for perl v5.16.3✨
- perl5163delta(1perl)what is new for perl v5.16.3✨
- perl5180delta(1)what is new for perl v5.18.0✨
- perl5180delta(1perl)what is new for perl v5.18.0✨
- perl5181delta(1)what is new for perl v5.18.1✨
- perl5181delta(1perl)what is new for perl v5.18.1✨
- perl5182delta(1)what is new for perl v5.18.2✨
- perl5182delta(1perl)what is new for perl v5.18.2✨
- perl5184delta(1)what is new for perl v5.18.4✨
- perl5184delta(1perl)what is new for perl v5.18.4✨
- perl5200delta(1)what is new for perl v5.20.0✨
💅
getting it ready, bestie…