📦 jose
24 pages
J
- jose(1)Toolkit for performing JSON Object Signing and Encryption✨
- jose-alg(1)Lists all supported algorithms✨
- jose-b64-dec(1)Decodes URL-safe Base64 data to binary✨
- jose-b64-enc(1)Encodes binary data to URL-safe Base64✨
- jose-fmt(1)Converts JSON between serialization formats✨
- jose-jwe-dec(1)Decrypts a JWE using the supplied JWKs✨
- jose-jwe-enc(1)Encrypts plaintext using one or more JWK/password✨
- jose-jwe-fmt(1)Converts a JWE between serialization formats✨
- jose-jwk-eql(1)Checks if two keys are equal✨
- jose-jwk-exc(1)Performs a key exchange using the two input keys✨
- jose-jwk-gen(1)Creates a random JWK for each input JWK template✨
- jose-jwk-pub(1)Cleans private keys from a JWK✨
- jose-jwk-thp(1)Calculates the JWK thumbprint✨
- jose-jwk-use(1)Validates a key for the specified use(s)✨
- jose-jws-fmt(1)Converts a JWS between serialization formats✨
- jose-jws-sig(1)Signs a payload using one or more JWKs✨
- jose-jws-ver(1)Verifies a JWS using the supplied JWKs✨
- jose_b64(3)URL-safe Base64 Encoding & Decoding.✨
- jose_cfg(3)José Configuration.✨
- jose_io(3)IO Chaining.✨
- jose_io_t(3)The interface for chained IO.✨
- jose_jwe(3)JSON Web Encryption (RFC 7516)✨
- jose_jwk(3)JSON Web Keys (RFC 7517)✨
- jose_jws(3)JSON Web Signature (RFC 7515)✨
💅
getting it ready, bestie…