📦 erlang
592 pages · page 2 of 3
N (continued)
- net_adm(3)Various Erlang net administration routines.✨
- net_kernel(3)Erlang networking kernel.✨
- nteventlog(3)Interface to Windows Event Log✨
O
- observer(3)A GUI tool for observing an Erlang system.✨
- observer(6)✨
- odbc(3)Erlang ODBC application✨
- orddict(3)Key-value dictionary as ordered list.✨
- ordsets(3)Functions for manipulating sets as ordered lists.✨
- os(3)Operating system-specific functions.✨
- os_mon(6)✨
- os_sup(3)Interface to OS System Messages✨
- OTP-REG(7)✨
- OTP-SNMPEA-MIB(7)The Erlang/OTP MIB module for the SNMPEA component in OTP✨
- OTP-TC(7)✨
P
- peer(3)Start and control linked Erlang nodes.✨
- persistent_term(3)Persistent terms.✨
- pg(3)Distributed named process groups.✨
- pool(3)Load distribution facility.✨
- prettypr(3)A generic pretty printer library.✨
- proc_lib(3)Functions for asynchronous and synchronous start of processes adhering to the OTP design principles.✨
- proplists(3)Support functions for property lists.✨
- public_key(3)API module for public-key infrastructure.✨
- public_key(6)✨
Q
- qlc(3)This module provides a query interface to Mnesia, ETS, Dets, and other data structures that provide an iterator style traversal of objects.✨
- queue(3)implementations of linked lists and queues✨
R
- rand(3)pseudo-random number generator✨
- random(3)random number generator✨
- rb(3)The Report Browser Tool✨
- re(3)This module contains regular expression matching functions for strings and binaries.✨
- records(3)Native records processing functions.✨
- rel(4)Release resource file✨
- release_handler(3)Unpacking and Installation of Release Packages✨
- reltool(3)Main API of the Reltool application✨
- relup(4)Release upgrade file✨
- RFC-1212(7)✨
- RFC-1215(7)✨
- RFC1155-SMI(7)✨
- RFC1213-MIB(7)The Erlang/OTP MIB module for RFC-1213✨
- rpc(3)library routines for remote procedure calls✨
- run_erl(1)Redirect Erlang input and output streams on Unix systems✨
- runtime_tools(6)✨
S
- sasl(6)✨
- scheduler(3)Measure scheduler utilization✨
- script(4)Boot script✨
- seq_trace(3)Sequential tracing of information transfers.✨
- sets(3)Sets are collections of elements with no duplicate elements.✨
- shell(3)The Erlang shell.✨
- shell_default(3)Customizing the Erlang environment.✨
- shell_docs(3)Functions used to render EEP-48 style documentation for a shell.✨
- slave(3)This module provides functions for starting Erlang slave nodes.✨
- snmp(3)Interface functions to the SNMP toolkit✨
- snmp(6)✨
- SNMP-COMMUNITY-MIB(7)The Erlang/OTP MIB module for supporting coexistence between SNMPv1, SNMPv2, and SNMPv3✨
- SNMP-FRAMEWORK-MIB(7)The Erlang/OTP MIB module for textual conventions used in the SNMP management architecture✨
- SNMP-MPD-MIB(7)The Erlang/OTP MIB module for message processing and dispatching✨
- SNMP-NOTIFICATION-MIB(7)The Erlang/OTP MIB module for mechanisms to remotely configure the parameters for the generation of notifications✨
- SNMP-TARGET-MIB(7)The Erlang/OTP MIB module for mechanisms to remotely configure the parameters for the generation of SNMP messages✨
- SNMP-USER-BASED-SM-MIB(7)The Erlang/OTP MIB module for the SNMP user- based security model✨
- SNMP-USM-AES-MIB(7)The Erlang/OTP MIB module for the use of AES by SNMP's user-based security model✨
- SNMP-USM-HMAC-SHA2-MIB(7)✨
- SNMP-VIEW-BASED-ACM-MIB(7)The Erlang/OTP MIB module for the view-based access control model for SNMP✨
- snmp_community_mib(3)Instrumentation Functions for SNMP-COMMUNITY-MIB✨
- snmp_framework_mib(3)Instrumentation Functions for SNMP-FRAMEWORK-MIB✨
- snmp_generic(3)Generic Functions for Implementing SNMP Objects in a Database✨
- snmp_index(3)Abstract Data Type for SNMP Indexing✨
- snmp_notification_mib(3)Instrumentation Functions for SNMP-NOTIFICATION- MIB✨
- snmp_pdus(3)Encode and Decode Functions for SNMP PDUs✨
- snmp_standard_mib(3)Instrumentation Functions for STANDARD-MIB and SNMPv2-MIB✨
- snmp_target_mib(3)Instrumentation Functions for SNMP-TARGET-MIB✨
- snmp_user_based_sm_mib(3)Instrumentation Functions for SNMP-USER-BASED- SM-MIB✨
- snmp_view_based_acm_mib(3)Instrumentation Functions for SNMP-VIEW-BASED- ACM-MIB✨
- snmpa(3)Interface Functions to the SNMP toolkit agent✨
- snmpa_conf(3)Utility functions for handling the agent config files.✨
- snmpa_discovery_handler(3)Behaviour module for the SNMP agent discovery handler.✨
- snmpa_error(3)Functions for Reporting SNMP Errors✨
- snmpa_error_io(3)Functions for Reporting SNMP Errors on stdio✨
- snmpa_error_logger(3)Functions for Reporting SNMP Errors through the error_logger✨
- snmpa_error_report(3)Behaviour module for reporting SNMP agent errors✨
- snmpa_local_db(3)The SNMP built-in database✨
- snmpa_mib_data(3)Behaviour module for the SNMP agent mib-server data module.✨
- snmpa_mib_storage(3)Behaviour module for the SNMP agent mib storage.✨
- snmpa_mpd(3)Message Processing and Dispatch module for the SNMP agent✨
- snmpa_network_interface(3)Behaviour module for the SNMP agent network interface.✨
- snmpa_network_interface_filter(3)Behaviour module for the SNMP agent network-interface filter.✨
- snmpa_notification_delivery_info_receiver(3)Behaviour module for the SNMP agent notification delivery information receiver.✨
- snmpa_notification_filter(3)Behaviour module for the SNMP agent notification filters.✨
- snmpa_supervisor(3)A supervisor for the SNMP agent Processes✨
- snmpc(1)SNMP MIB compiler frontend✨
- snmpc(3)Interface Functions to the SNMP toolkit MIB compiler✨
- snmpm(3)Interface functions to the SNMP toolkit manager✨
- snmpm_conf(3)Utility functions for handling the manager config files.✨
- snmpm_mpd(3)Message Processing and Dispatch module for the SNMP manager✨
- snmpm_network_interface(3)Behaviour module for the SNMP manager network interface.✨
- snmpm_network_interface_filter(3)Behaviour module for the SNMP manager network-interface filter.✨
- snmpm_user(3)Behaviour module for the SNMP manager user.✨
- SNMPv2-CONF(7)✨
- SNMPv2-MIB(7)The Erlang/OTP MIB module for SNMP entities✨
- SNMPv2-SMI(7)✨
- SNMPv2-TC(7)✨
- SNMPv2-TM(7)The Erlang/OTP MIB module for SNMPv2 Transport Mappings✨
- socket(3)Socket interface.✨
- sofs(3)Functions for manipulating sets of sets.✨
- ssh(3)Main API of the ssh application✨
- ssh(6)The ssh application implements the Secure Shell (SSH) protocol and provides an SSH File Transfer Protocol (SFTP) client and server✨
- ssh_agent(3)Callback module for using an SSH agent instead of the default ssh_file callback.✨
- ssh_client_channel(3)SSH services (clients and servers) are implemented as channels that are multiplexed over an SSH connection and communicates over the SSH Connection Protocol. This module provides a callback API…✨
- ssh_client_key_api(3)-behaviour(ssh_client_key_api).✨
- ssh_connection(3)This module provides API functions to send SSH Connection Protocol events to the other side of an SSH channel.✨
- ssh_file(3)Default callback module for the client's and server's database operations in the ssh application✨
- ssh_server_channel(3)-behaviour(ssh_server_channel). (Replaces ssh_daemon_channel)✨
- ssh_server_key_api(3)-behaviour(ssh_server_key_api).✨
- ssh_sftp(3)SFTP client.✨
- ssh_sftpd(3)Specifies the channel process to handle an SFTP subsystem.✨
- ssl(3)Interface functions for TLS (Transport Layer Security) and DTLS (Datagram Transport Layer Security).✨
- ssl(6)The ssl application provides secure communication over sockets✨
- ssl_crl_cache(3)CRL cache✨
- ssl_crl_cache_api(3)API for a TLS CRL (Certificate Revocation List) cache.✨
- ssl_session_cache_api(3)TLS session cache API✨
- STANDARD-MIB(7)The Erlang/OTP MIB module for SNMP standard datatypes✨
- start(1)OTP start script example for Unix✨
- start_erl(1)Start Erlang for embedded systems on Windows systems✨
- stdlib(6)✨
- string(3)string operations✨
- supervisor(3)Generic supervisor behavior.✨
- supervisor_bridge(3)Generic supervisor bridge behavior.✨
- sys(3)A functional interface to system messages.✨
- system_information(3)System Information✨
- systools(3)A Set of Release Handling Tools✨
T
- tags(3)Generate Emacs TAGS file from Erlang source files✨
- tftp(3)Trivial FTP.✨
- tftp_logger(3)Trivial FTP logger.✨
- timer(3)Timer functions.✨
- tprof(3)Process Tracing Profiling Tool✨
- trace(3)The Erlang trace interface.✨
- TRANSPORT-ADDRESS-MIB(7)The Erlang/OTP MIB module for commonly used transport address definitions✨
- ttb(3)A base for building trace tools for distributed systems.✨
- typer(1)Type annotator for Erlang programs✨
U
- unicode(3)Functions for converting and classifying Unicode characters.✨
- unix_telnet(3)Callback module for ct_telnet, for connecting to a Telnet server on a UNIX host.✨
- uri_string(3)URI processing functions.✨
V
- versions(3)Utility functions for versions using the OTP Versions Scheme.✨
W
- werl(1)The Erlang Emulator on Windows✨
- win32reg(3)Provides access to the registry on Windows.✨
- wrap_log_reader(3)A service to read internally formatted wrap disk logs.✨
- wx(3)A port of wxWidgets.✨
- wx_misc(3)Miscellaneous functions.✨
- wx_object(3)wx_object - Generic wx object behaviour✨
- wxAcceleratorEntry(3)An object used by an application wishing to create an accelerator table (see wxAcceleratorTable).✨
- wxAcceleratorTable(3)An accelerator table allows the application to specify a table of keyboard shortcuts for menu or button commands.✨
- wxActivateEvent(3)An activate event is sent when a window or application is being activated or deactivated.✨
- wxArtProvider(3)wxArtProvider class is used to customize the look of wxWidgets application.✨
- wxAuiDockArt(3)wxAuiDockArt is part of the wxAUI class framework.✨
- wxAuiManager(3)wxAuiManager is the central class of the wxAUI class framework.✨
- wxAuiManagerEvent(3)Event used to indicate various actions taken with wxAuiManager.✨
- wxAuiNotebook(3)wxAuiNotebook is part of the wxAUI class framework, which represents a notebook control, managing multiple windows with associated tabs.✨
- wxAuiNotebookEvent(3)This class is used by the events generated by wxAuiNotebook.✨
- wxAuiPaneInfo(3)wxAuiPaneInfo is part of the wxAUI class framework.✨
- wxAuiSimpleTabArt(3)Another standard tab art provider for wxAuiNotebook.✨
- wxAuiTabArt(3)Tab art provider defines all the drawing functions used by wxAuiNotebook.✨
- wxBitmap(3)This class encapsulates the concept of a platform-dependent bitmap, either monochrome or colour or colour with alpha channel support.✨
- wxBitmapButton(3)A bitmap button is a control that contains a bitmap.✨
- wxBitmapDataObject(3)wxBitmapDataObject is a specialization of wxDataObject for bitmap data.✨
- wxBookCtrlBase(3)A book control is a convenient way of displaying multiple pages of information, displayed one page at a time.✨
- wxBookCtrlEvent(3)This class represents the events generated by book controls (wxNotebook, wxListbook, wxChoicebook, wxTreebook, wxAuiNotebook).✨
- wxBoxSizer(3)The basic idea behind a box sizer is that windows will most often be laid out in rather simple basic geometry, typically in a row or a column or several hierarchies of either.✨
- wxBrush(3)A brush is a drawing tool for filling in areas.✨
- wxBufferedDC(3)This class provides a simple way to avoid flicker: when drawing on it, everything is in fact first drawn on an in-memory buffer (a wxBitmap) and then copied to the screen, using the associated wxDC…✨
- wxBufferedPaintDC(3)This is a subclass of wxBufferedDC which can be used inside of an EVT\_PAINT() event handler to achieve double-buffered drawing.✨
- wxButton(3)A button is a control that contains a text string, and is one of the most common elements of a GUI.✨
- wxCalendarCtrl(3)The calendar control allows the user to pick a date.✨
- wxCalendarDateAttr(3)wxCalendarDateAttr is a custom attributes for a calendar date.✨
- wxCalendarEvent(3)The wxCalendarEvent class is used together with wxCalendarCtrl.✨
- wxCaret(3)A caret is a blinking cursor showing the position where the typed text will appear.✨
- wxCheckBox(3)A checkbox is a labelled box which by default is either on (checkmark is visible) or off (no checkmark).✨
- wxCheckListBox(3)A wxCheckListBox is like a wxListBox, but allows items to be checked or unchecked.✨
- wxChildFocusEvent(3)A child focus event is sent to a (parent-)window when one of its child windows gains focus, so that the window could restore the focus back to its corresponding child if it loses it now and regains…✨
- wxChoice(3)A choice item is used to select one of a list of strings.✨
- wxChoicebook(3)wxChoicebook is a class similar to wxNotebook, but uses a wxChoice control to show the labels instead of the tabs.✨
- wxClientDC(3)wxClientDC is primarily useful for obtaining information about the window from outside EVT_PAINT() handler.✨
- wxClipboard(3)A class for manipulating the clipboard.✨
- wxClipboardTextEvent(3)This class represents the events generated by a control (typically a wxTextCtrl but other windows can generate these events as well) when its content gets copied or cut to, or pasted from the…✨
- wxCloseEvent(3)This event class contains information about window and session close events.✨
- wxColourData(3)This class holds a variety of information related to colour dialogs.✨
- wxColourDialog(3)This class represents the colour chooser dialog.✨
- wxColourPickerCtrl(3)This control allows the user to select a colour.✨
- wxColourPickerEvent(3)This event class is used for the events generated by wxColourPickerCtrl.✨
- wxComboBox(3)A combobox is like a combination of an edit control and a listbox.✨
- wxCommandEvent(3)This event class contains information about command events, which originate from a variety of simple controls.✨
- wxContextMenuEvent(3)This class is used for context menu events, sent to give the application a chance to show a context (popup) menu for a wxWindow.✨
- wxControl(3)This is the base class for a control or "widget".✨
- wxControlWithItems(3)This is convenience class that derives from both wxControl and wxItemContainer (not implemented in wx).✨
- wxCursor(3)A cursor is a small bitmap usually used for denoting where the mouse pointer is, with a picture that might indicate the interpretation of a mouse click.✨
- wxDataObject(3)A wxDataObject represents data that can be copied to or from the clipboard, or dragged and dropped.✨
- wxDateEvent(3)This event class holds information about a date change and is used together with wxDatePickerCtrl.✨
- wxDatePickerCtrl(3)This control allows the user to select a date.✨
- wxDC(3)A wxDC is a "device context" onto which graphics and text can be drawn.✨
- wxDCOverlay(3)Connects an overlay with a drawing DC.✨
- wxDialog(3)A dialog box is a window with a title bar and sometimes a system menu, which can be moved around the screen.✨
- wxDirDialog(3)This class represents the directory chooser dialog.✨
- wxDirPickerCtrl(3)This control allows the user to select a directory.✨
💅
getting it ready, bestie…